Hi,

I'm upgrading RadiantCMS according to OS update. All
systems relevant to RadiantCMS(DB, Ruby, gem) also
updated. And then run script/server, failed to start.
I'm wondering how to upgrade RadiantCMS. RadiantCMS could
not be work by upgradeing whole application without RadiantCMS
it's self? If so,database should be rebuild and old databse
would be thrown away? Detail procedures I've done as follows:

- Old system is

    OS: FreeBSD 7.2-PRERELEASE
    DB: MySQL-5.1.29
    Ruby: 1.8.6
    gem: 1.2.0
    radiant: 0.6.7

  and installed applications by gem are

    web# gem list
    
    *** LOCAL GEMS ***
    
    actionmailer (2.0.2)
    actionpack (2.0.2)
    activerecord (2.0.2)
    activeresource (2.0.2)
    activesupport (2.0.2)
    acts_as_ferret (0.4.3)
    ferret (0.11.6)
    gettext (1.91.0)
    radiant (0.6.7)
    radius (0.5.1)
    rails (2.0.2)
    rake (0.8.2, 0.8.1)
    sources (0.0.2)
    web# 

  Additional extentions are

    AAF Search(0.1)
    Iphone(0.0.1)
    Language Redirect
    Paperclipped

- New system is

    OS: FreeBSD 8.2-PRERELEASE
    DB: MySQL-5.5.7
    Ruby: 1.8.7
    gem: 1.3.7
    radiant: 0.9.1

  and installed applications by gem are
    
    web# gem list

    *** LOCAL GEMS ***
    
    abstract (1.0.0)
    actionmailer (3.0.3)
    actionpack (3.0.3)
    activemodel (3.0.3)
    activerecord (3.0.3)
    activeresource (3.0.3)
    activesupport (3.0.3)
    acts_as_ferret (0.5.2)
    arel (2.0.6)
    builder (2.1.2)
    bundler (1.0.7)
    erubis (2.6.6)
    ferret (0.11.6)
    gettext (2.1.0)
    i18n (0.5.0)
    jk-ferret (0.11.8.2)
    locale (2.0.5)
    mail (2.2.12)
    mime-types (1.16)
    polyglot (0.3.1)
    rack (1.2.1, 1.1.0)
    rack-mount (0.6.13)
    rack-test (0.5.6)
    radiant (0.9.1)
    radius (0.6.1)
    rails (3.0.3)
    railties (3.0.3)
    rake (0.8.7)
    RedCloth (4.2.3)
    thor (0.14.6)
    treetop (1.4.9)
    tzinfo (0.3.23)
    will_paginate (2.3.15)
    web#

  and MySQL DB was updated successfully by mysql_upgrade.
  Then run ferret_server and server at old RadiantCMS root
  directory

    web# env PATH=${PATH}:/usr/local/bin script/ferret_server -e production 
start
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`gem_original_require': no such file to load -- server_manager (LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`require'
        from script/ferret_server:9
    web# env PATH=${PATH}:/usr/local/bin script/server -dp 8080 -e production
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`gem_original_require': no such file to load -- iconv (LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`require'
        from 
/usr/local/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activesupport/lib/active_support/inflector.rb:3
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`require'
        from 
/usr/local/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activesupport/lib/active_support/core_ext/integer/inflections.rb:1
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`require'
        from 
/usr/local/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activesupport/lib/active_support/core_ext/integer.rb:2
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`require'
        from 
/usr/local/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activesupport/lib/active_support/core_ext.rb:8
        from 
/usr/local/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activesupport/lib/active_support/core_ext.rb:8:in
 `each'
        from 
/usr/local/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activesupport/lib/active_support/core_ext.rb:8
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`require'
        from 
/usr/local/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/activesupport/lib/active_support.rb:56
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`require'
        from 
/usr/local/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/railties/lib/commands/server.rb:1
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in 
`require'
        from script/server:3
    web# 

Regards

Kazuhiko KIRIYAMA

Reply via email to