On 20 Jul 2011, at 23:33, Wes Gamble wrote:

> On 7/20/11 4:58 PM, Wes Gamble wrote:
>> 
>> On 7/20/11 4:32 PM, Wes Gamble wrote:
>>> 
>>> Does anyone know if there is a version of Compass that's compatible with 
>>> using Radiant 0.9.1 as a gem?  
>>> 
>>> Radiant 0.9.1 packages haml as a plugin (and hence Sass).
>>> 
>>> Thanks,
>>> Wes
>> FWIW, I vendor'ed radiant, removed the haml plugin and seem to be 
>> successfully running off the latest compass, haml, and sass gems.
>> 
>> Wes
> OK, I inadvertently lied, I had to make changes to the following Sass files 
> to make them conform to the new Sass syntax.
> 
> public/stylesheets/sass/admin/modules
>   _opacity.sass
>   _rounded.sass
>   _shadow.sass

Those files have all been removed from nearly-version-1 in favour of compass 
mixins. They can cause intermittent crashes if left in place (each time an 
nginx worker starts up and sass tries to parse the old files) so we will need a 
routine, or at least a warning, to remove them.

I think sass 3.1 is the first version of Sass not to understand !notation. Not 
sure. You shouldn't run into any other problems but if you do, you could try 
Haml 3.

best

will

Reply via email to