Just went through the upgrade according to the gist and so far it's
accurate and does the trick.  I commented on the gist in case anyone
stumbles on the only issue I had, which has to do with using 1.9.x. In a
nutshell `script/server` needed updating in my site where:

`require File.dirname(__FILE__) + '/../config/boot'`

should be changed to

`require File.expand_path('../../config/boot', __FILE__)`

Other than that I think this was pretty much spot on.  Thanks Jim.

- Joel

On Wed, Jun 20, 2012 at 10:37 AM, Jim Gay <j...@saturnflyer.com> wrote:

> Did you follow these instructions? https://gist.github.com/1540782
>
> On Wed, Jun 20, 2012 at 7:00 AM,  <pi...@gniezno.net.pl> wrote:
> > Hi,
> > I want to upgrade a Radiant CMS from version 0.8.0 to a new - 1.0.
> > I put a "gem update radiant" command like in manual, however at the end
> of
> > script, I have some warning and errors like below:
> >
> > WARNING:  Invalid .gemspec format in
> > '/home/targi/www/.ruby/gems/1.8/specifications/radiant-1.0.1.gemspec'
> > Updating installed gems
> > Updating radiant-clipped-extension
> > ERROR:  While executing gem ... (NoMethodError)
> >    undefined method `call' for nil:NilClass
> >
> > Could you please let me know what's wrong with it? I'm new with Radiant
> so
> > please be patient :).
> >
> > Second case is lack of RADIANT_GEM_VERSION constant in my
> > config/environment.rb - what should I do with it? Add it to this file
> > manually?
> >
> > regards!
> >
> > Piotr
>
>
>
> --
> Write intention revealing code #=> http://www.clean-ruby.com
>
> Jim Gay
> Saturn Flyer LLC
> 571-403-0338
>

Reply via email to