Does anyone have a version of the DragOrder extension working on a Radiant
1.0.1 site? I've tried all the forked versions I can find but none of them
work on a fresh Radiant 1.0.1 install.

My environment is:
 Linux (Ubuntu 12.04)
 ruby 1.9.3
 rvm (
 radiant (1.0.1)
 bundler (1.1.5)

The Gemfile for this fresh install has:
 source :rubygems
 gem "radiant", "~> 1.0.1"
 gem "sqlite3", "~> 1.3.4"
 gem "radiant-drag_order-extension", :git => "git://
/radiant-drag_order-extension # (seems to be the most up-to-date)

After a "bundle install", I ran the migrate and update tasks, and started
the WEBrick server.

At first, the drag_order extension appears to work: hovering the mouse over
the leftmost area of the admin UI brings the drag icon into view, and
dragging it to a new location seems to change the order. However, any other
operation, like editing a page, throws me back to the login screen, and
after logging in again, all the pages are back in their original order.

The second most visible problem is when a page has children it can no
longer be collapsed/expanded. The little triangle icon appears, but cannot
be clicked (no effect when clicked).

This is a must-have extension for me and is the last hurdle to migrate from
0.9.1 to 1.0.1. Any/all help would be much appreciated.

Reply via email to