Thanks Benny. I think I'm a bit closer to finding the culprit.

Following your suggestion, I uninstalled all the gems I could find that
were not needed, including Mail, Actionmailer, Rails, etc. No change --
same error message.

But you said "... you have something in your application that redefines
Mail.", so I started looking through all the gems for any that defined a
Mail class. The radiant-mailer-extension gem has one that includes a
valid_config?
method and then there is this one that I'm guessing supersedes it:

/usr/local/lib/ruby/gems/1.8/gems/radiant-0.9.1/vendor/rails/actionmailer/lib/action_mailer/vendor/tmail-1.2.7/tmail/mail.rb

The tmail/mail.rb defines a Mail class without any valid_config? method.

Now what?
--
marshal

Reply via email to