For me, the problem was that "rake db:migrate" had failed when I first 
upgraded (for unrelated reasons) and I hadn't noticed; running it 
successfully fixed it. Did it not fix this for you?

On Monday, March 11, 2013 2:21:05 PM UTC-4, Andrew vonderLuft wrote:
>
> I am getting the same error while running rake db:migrate, upgrading from 
> 0.7.2 to 1.1.3
> Here is the trace:   https://gist.github.com/anonymous/5136388
>
> Any ideas?
>
> On Tuesday, January 15, 2013 8:45:31 AM UTC-8, Jim Gay wrote:
>>
>> Have you run "rake db:migrate" for your environment (prod/dev)? 
>>
>> On Tue, Jan 15, 2013 at 11:00 AM, saalon <saa...@gmail.com> wrote: 
>> > Hey all, 
>> > 
>> > I'm trying to upgrade to Radiant 1.1.1 (from the 1.0 rc3 release) due 
>> to the 
>> > new security patch, but when trying to load the admin section I'm 
>> getting 
>> > the error below. Any ideas on what might be going on, or what I might 
>> be 
>> > missing? 
>> > 
>> > ActionView::TemplateError (undefined local variable or method 
>> > `allowed_children_cache' for #<Page:0x105083918>) on line #22 of 
>> > 
>> /Library/Ruby/Gems/1.8/gems/radiant-1.1.1/app/views/admin/pages/_node.html.haml:
>>  
>>
>> > 19:         %td.actions 
>> > 20:           = page.add_child_option 
>> > 21:           = page.remove_option 
>> > 22: 
>> > 23: - if expanded 
>> > 24:   - page.children.each do |child| 
>> > 25:     - child.becomes(child.class_name.constantize) if 
>> > child.class_name.present? 
>> > 
>> > Eric 
>> > 
>>
>>
>>
>> -- 
>> Write intention revealing code #=> http://www.clean-ruby.com 
>>
>> Jim Gay 
>> Saturn Flyer LLC 
>> 571-403-0338 
>>
>

-- 

--- 
You received this message because you are subscribed to the Google Groups 
"Radiant CMS" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to radiantcms+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to