On Jun 28, 2006, at 10:18 AM, Zack Chandler wrote:
I love the simply_restful plugin (beautiful work Jamis) but wonder why
the naming convention changed to look for pluralized controllers by
default.
If you do:
map.resource :message
then you must have a MessagesController.
If you already have a MessageController you need:
map.resource :message, :controller => 'message'
which is slightly less DRY.
Is this a change in convention to pluralize controller names? Almost
all the examples in the docs and rails books use singular controller
names. I'd be happy to make a patch if this is an unwanted
side-effect of the plugin.
simply_restful addresses collections of resources and their members
so pluralization feels natural. (The scaffold generator has used
pluralized names for months, too.)
jeremy
_______________________________________________
Rails-core mailing list
Rails-core@lists.rubyonrails.org
http://lists.rubyonrails.org/mailman/listinfo/rails-core