On Aug 2, 2006, at 3:28 AM, Lars Pind wrote:
I've added a new feature to acts_as_nested_set, namely the ability
to move a node within a tree.
It is accomplished with calls ActiveRecord::Base.update_all, works
fine on a whole subtree, and works by opening a gap for the
destination, moving, and then closing the gap at the origin.
<snip>
What's the policy on changing existing code to adhere to coding
standards? Is that a good thing or a bad thing to do? Is it better
to leave it, to keep the patch simpler?
I'm personally in favor of making code adhere to the standards,
because it makes it easier to read, and because it increases the
chance that people will adhere to them going forward. And looking
at code that's half-adherent-half-not is even worse than pure non-
adherence.
Is nested_set something that should be moved to, say, a plugin and a
rubyforge project? Particularly given the few people using it, and
the 'fragility' of the code..
________
courtenay
http://blog.caboo.se @o O@
_______________________________________________
Rails-core mailing list
Rails-core@lists.rubyonrails.org
http://lists.rubyonrails.org/mailman/listinfo/rails-core