The move to modern C++ is coming (at last!) and when we make it, I would
like to go ahead and specify (relatively) modern minimum versions of boost
and/or cmake. This is your chance to pipe up on what we do here. In case
you have no idea what I'm talking about here, the relevant blog post is:

First things first: I'm not proposing that we immediately start using a
bunch of new libraries (particularly not new libraries that aren't
header-only), but I would like to have the option of doing so and to make
explicit that versions like 1.41 are just too old.

This decision shouldn't matter to most users since they will be getting
pre-built binaries either via their OS's package manager or conda.

We've been using 1.56 (or 1.59 for py35 on windows) with the conda builds
and haven't had any complaints about those not working, so I am inclined to
pick *at least* 1.56 as a minimum. I almost want to suggest that we take
1.62 - since that includes QVM (, which I
think could be useful - but that's probably overly radical.

With cmake I don't have as clear of an overview of what the differences
between the versions are, but it seems like updating to require at least
3.0 wouldn't be insane.

Any input/opinions from the community about any of this?

Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today.
Rdkit-devel mailing list

Reply via email to