On Mar 28, 2017, at 17:56, 杨弘宾 <yanyangh...@163.com> wrote:
>     Have you tried install rdkit from source? It's ok when I installed rdkit 
> by conda in my PC. But when I tried installing it in a server in which I am 
> only a user who cannot use "sudo" and the "python" is in a read-only 
> directory.

Yes I have, and I find it rather difficult. (My system has Python 2.7 and 
Python 3.5, for several versions of RDKit, so I can do regression testing 
across multiple environments.)

I use Python virtual environments which helps, in that I effectively can 
control a Python installation, but also adds its own layer of complexity.

> But when I used:
> `from rdkit import rdBase`
> error happened:
> ImportError: 
> /home/yccai/Programs/Anaconda/bin/../lib/libboost_serialization.so.1.56.0: 
> undefined symbol: 
> _ZN5boost13serialization6detail17singleton_wrapperINS_7archive6detail12extra_detail3mapINS3_15binary_oarchiveEEEE14m_is_destroyedE

I think you are missing an LD_LIBRARY_PATH entry to point to your Boost 


Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Rdkit-discuss mailing list

Reply via email to