Hi
I built rdkit using the following command using boost 1.56 (tried boost 1.61 as 
well):
cmake -G"Visual Studio 10" -DRDK_BUILD_PYTHON_WRAPPERS=ON 
-DBOOST_ROOT=C:\local\boost_1_56_0 
-DBOOST_LIBRARYDIR=C:\local\boost_1_56_0\lib32-msvc-10.0 ..
... and then Visual C++ 2010 Express.
When I run the code below with:
from rdkit.Chem import rdRGroupDecomposition
... the decomposition works. It does as well if I do:
from rdkit.Chem import AllChem,rdRGroupDecomposition
... but I get the pop-up error described below in the code block. Has anyone 
else built for win32 and if yes, do you get the error as well?
## code starts here ************
import sys
print(sys.version)
import rdkit
print(rdkit.__version__)
from rdkit import Chem
##from rdkit.Chem import rdRGroupDecomposition
from rdkit.Chem import AllChem,rdRGroupDecomposition ## <-- gives pop-up window 
with error if used instead of above.
## The error is:
## RuntimeWarning: to-Python converter for class std::vector<class 
boost::shared_ptr<class RDKit::ROMol>,class std::allocator<class 
boost::shared_ptr<class RDKit::ROMol> > > already registered; second conversion 
method ignored.


#core = Chem.MolFromSmarts('Oc1ccccc1')
#rg = rdRGroupDecomposition.RGroupDecomposition(core)

print ('done')
## code ends here ***********
Should I try another boost version?

  *   RDKit Version: 2017.09.2
  *   Platform: Windows 10 / python 2.7.3 (default, Apr 10 2012, 23:31:26) [MSC 
v.1500 32 bit (Intel)]
Best regards
Johannes


[cid:image003.png@01D060C2.0E04EC70]


Johannes Dolberg
Informatics Architect
Tel. +45 3913 0951
j...@nuevolution.com<mailto:m...@nuevolution.com>
www.nuevolution.com<http://www.nuevolution.com/>

Nuevolution A/S
R√łnnegade 8, 5th floor
DK-2100 Copenhagen
Denmark
Tel. +45 7020 0987
Fax +45 7020 0986



------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Rdkit-discuss mailing list
Rdkit-discuss@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/rdkit-discuss

Reply via email to