Hi Edward,

I was talking to the developer of mpi4py, and he said that mpi4py should
work with both, even if you have both of them installed, by loading the
appropriate module (openmpi or mpich) I should be able to run mpi4py. He
said he suspects there was probably a problem with the installation of
openmpi itself (improper compilation, or the package itself was improperly
configured itself). Regardless, it finally works Thanks to both of you for
your help with relax and my multi-processor problem.


On Thu, Oct 6, 2016 at 2:39 PM, Edward d'Auvergne <edw...@nmr-relax.com>

> On Thursday, 6 October 2016, Mahdi, Sam <sam.mahdi....@my.csun.edu> wrote:
>> Hi Troels and Edward,
>> I was able to get relax working on a multi-processor platform finally. I
>> tried using the mpich instead of openmpi.
>> module load mpi/mpich-x86_64
>> mpirun -np 7 ./relax --multi='mpi4py'
>> and it loaded up relax with 1 master and 7 slaves. I don't exactly
>> understand why openmpi doesn't work. I have gotten both from the package
>> list, and installed them directly., and I have mpi4py for both mpich and
>> openmpi (I also got these from the package list and installed directly),
>> but this seemed to finally get it to work.
> Hi Sam,
> This sounds like a classic software clash, with OpenMPI loosing out to
> MPICH with respect to mpi4py.  Maybe uninstalling all MPI packages and just
> having openmpi and python-mpi4py would have solved this.  Anyway, as long
> as something works, that's all that is needed.  Thank you Troels for all of
> your help!
> Regards,
> Edward
relax (http://www.nmr-relax.com)

This is the relax-users mailing list

To unsubscribe from this list, get a password
reminder, or change your subscription options,
visit the list information page at

Reply via email to