On Mon, Mar 12, 2018 at 7:27 PM, Michael Catanzaro <mcatanz...@posteo.net> wrote:
And then build and release as normal once inside the shell.

Easier said than done. :) 'bst build' worked fine, but then I got stuck here when trying to run make inside the BuildStream shell:

(process:9730): Gtk-CRITICAL **: 01:15:08.492: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed 2018-03-13 01:15:08,929:scangobj.py:execute_command:1196:WARNING:Running scanner failed: -11, command: /bin/bash ../../libtool --mode=execute ./libyelp-scan

It looks like gtkdoc is broken inside the shell. Not sure what to do about that. As a workaround, I tried exiting the shell, running 'bst build core/yelp.bst', and reentering the shell, to ensure that I would only need to do an incremental build inside the shell, but that wasn't enough. So I don't know what to do either, other than try to debug what is going wrong with gtk-doc, or revert the commit that depends on a newer WebKit. (You could, for example, add WEBKIT_CHECK_VERSION conditionals to build that code only with older WebKit.)

I also noticed that running yelp inside the shell doesn't work because it requires its gsettings schemas to be installed. This is a common problem; [1] shows how to fix it when using meson, not sure if there are any Autotools examples. This isn't hard, and isn't a blocker to releasing.

[1] https://git.gnome.org/browse/epiphany/commit/?id=8e0f8b963063c744afe862cbdb0c17438bc846be

Release-team lurker? Do NOT participate in discussions.

Reply via email to