Package: reportbug
Version: 6.6.3
Severity: important

Dear Maintainer,
i got a NoneTypeException, when i tried to report a bug (on another
system)

Submit this report on coreutils (e to edit) [Y|n|a|c|e|i|l|m|p|q|d|t|s|?]? 
Traceback (most recent call last):
  File "/usr/bin/reportbug", line 2211, in <module>
    main()
  File "/usr/bin/reportbug", line 1081, in main
    return iface.user_interface()
  File "/usr/bin/reportbug", line 2203, in user_interface
    self.options.envelopefrom)
  File "/usr/lib/python2.7/dist-packages/reportbug/submit.py", line 316, in 
send_report
    msgname = os.path.expanduser(outfile) or ('/var/tmp/%s.bug' % package)
  File "/usr/lib/python2.7/posixpath.py", line 261, in expanduser
    if not path.startswith('~'):
AttributeError: 'NoneType' object has no attribute 'startswith'

with kind regards,
Alexander Schier


-- Package-specific info:
** Environment settings:
EDITOR="/usr/bin/vim"
INTERFACE="text"

** /home/allo/.reportbugrc:
reportbug_version "6.4.4"
mode standard
ui text
realname "Alexander Schier"
email "alexander_sch...@yahoo.de"

-- System Information:
Debian Release: 8.3
  APT prefers stable
  APT policy: (900, 'stable'), (100, 'stable-updates'), (100, 'experimental'), 
(100, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages reportbug depends on:
ii  apt               1.0.9.8.2
ii  python            2.7.9-1
ii  python-reportbug  6.6.3
pn  python:any        <none>

reportbug recommends no packages.

Versions of packages reportbug suggests:
pn  claws-mail                               <none>
pn  debconf-utils                            <none>
pn  debsums                                  <none>
pn  dlocate                                  <none>
pn  emacs23-bin-common | emacs24-bin-common  <none>
ii  file                                     1:5.22+15-2+deb8u1
ii  gnupg                                    1.4.18-7
ii  python-gtk2                              2.24.0-4
pn  python-gtkspell                          <none>
pn  python-urwid                             <none>
pn  python-vte                               <none>
ii  ssmtp [mail-transport-agent]             2.64-8
pn  xdg-utils                                <none>

Versions of packages python-reportbug depends on:
ii  apt               1.0.9.8.2
ii  python-debian     0.1.27
ii  python-debianbts  1.12
pn  python:any        <none>

python-reportbug suggests no packages.

-- no debconf information

_______________________________________________
Reportbug-maint mailing list
Reportbug-maint@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reportbug-maint

Reply via email to