Package: reportbug
Version: 7.1.7
Followup-For: Bug #869936

Dear Maintainer,

With new requests and urllib packages, the import error has changed:

mx3210:/home/dave/gnu/glibc# reportbug
Traceback (most recent call last):
  File "/usr/bin/reportbug", line 43, in <module>
    from reportbug import utils
  File "/usr/lib/python3/dist-packages/reportbug/utils.py", line 43, in <module>
    from .urlutils import open_url
  File "/usr/lib/python3/dist-packages/reportbug/urlutils.py", line 34, in 
<module>
    import requests
  File "/usr/lib/python3/dist-packages/requests/__init__.py", line 43, in 
<module>
    import urllib3
  File "/usr/lib/python3/dist-packages/urllib3/__init__.py", line 8, in <module>
    from .connectionpool import (
  File "/usr/lib/python3/dist-packages/urllib3/connectionpool.py", line 11, in 
<module>
    from .exceptions import (
  File "/usr/lib/python3/dist-packages/urllib3/exceptions.py", line 2, in 
<module>
    from six.moves.http_client import (
ImportError: No module named 'six'

-- Package-specific info:
** Environment settings:
INTERFACE="text"

** /home/dave/.reportbugrc:
reportbug_version "5.0"
mode standard
ui text
realname "John David Anglin"
email "dave.ang...@bell.net"

-- System Information:
Debian Release: buster/sid
  APT prefers unreleased
  APT policy: (500, 'unreleased'), (500, 'buildd-unstable'), (500, 'unstable')
Architecture: hppa (parisc64)

Kernel: Linux 4.11.0-2-parisc64-smp (SMP w/1 CPU core)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_CA:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages reportbug depends on:
ii  apt                1.5~beta1
ii  python3            3.5.3-3
ii  python3-reportbug  7.1.7

reportbug recommends no packages.

Versions of packages reportbug suggests:
pn  claws-mail                               <none>
pn  debconf-utils                            <none>
pn  debsums                                  <none>
pn  dlocate                                  <none>
pn  emacs24-bin-common | emacs25-bin-common  <none>
ii  file                                     1:5.30-1
ii  gir1.2-gtk-3.0                           3.22.17-1
pn  gir1.2-vte-2.91                          <none>
ii  gnupg                                    2.1.18-8
ii  postfix [mail-transport-agent]           3.2.2-1
ii  python3-gi                               3.22.0-2+b1
pn  python3-gi-cairo                         <none>
pn  python3-gtkspellcheck                    <none>
pn  python3-urwid                            <none>
ii  xdg-utils                                1.1.1-1

Versions of packages python3-reportbug depends on:
ii  apt                1.5~beta1
ii  file               1:5.30-1
ii  python3            3.5.3-3
ii  python3-debian     0.1.30
ii  python3-debianbts  2.6.1
ii  python3-requests   2.18.1-1

python3-reportbug suggests no packages.

-- no debconf information

_______________________________________________
Reportbug-maint mailing list
Reportbug-maint@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reportbug-maint

Reply via email to