Eureka!
I remembered that the Data.fs file had been set up on an earlier startup of the server. Since then there have been extensive changes. So I deleted the Data.fs and started again.
This time the various views came up without problems.
Maybe a note to this effect should be included in the tutorial docs. Somewhere near the end of this page:
http://docs.repoze.org/bfg/tutorials/bfgwiki/definingviews.html

Regards and thanks for your help
George

On 23/06/2009, at 8:07 AM, George Wright wrote:

Chris
Understand you are busy with the new version going out.
I wonder if you noticed my problem with "BFG ZODB + Traversal Wiki Tutorial" further down the email beginning with "However ..." ?
If you get a moment ...
Regards
George

On 23/06/2009, at 7:26 AM, Chris McDonough wrote:

Thanks for the report back George, glad it worked out for you...

However
Working through the "BFG ZODB + Traversal Wiki Tutorial"
http://docs.repoze.org/bfg/tutorials/bfgwiki/index.html
Went well at first but I ran into troubles about here
http://docs.repoze.org/bfg/tutorials/bfgwiki/definingviews.html#testing-the-views
The tests all pass. The server starts up without complaint but at this point
http://docs.repoze.org/bfg/tutorials/bfgwiki/definingviews.html#viewing-the-application-in-a-browser
all I get is
"404 Not Found
http://127.0.0.1:6543/FrontPage";
etc

I have checked all code carefully but can't find anything different from
the document.
Maybe you have a working version of that "BFG ZODB + Traversal Wiki
Tutorial"


George Wright
georg...@bigpond.net.au
http://mywebsite.bigpond.net.au/georgewr/
http://www.labyrinth.net.au/~gwright





George Wright
georg...@bigpond.net.au
http://mywebsite.bigpond.net.au/georgewr/
http://www.labyrinth.net.au/~gwright




_______________________________________________
Repoze-dev mailing list
Repoze-dev@lists.repoze.org
http://lists.repoze.org/listinfo/repoze-dev

Reply via email to