Hi All,

The attached buildout should generate a versions.cfg file suitable for running a particular version of BFG in a buildout.


I've attached its output for version 1.2, and the current development index as of writing.

Could anyone who knows please check that it has picked the right versions?*
If it has, where/how should I release/put this .cfg and its output such that others can use the generated .cfg files?

cheers,

Chris

* the dev version lists bfg's version as 1.2. Does that just mean bfg's setup.py is wrong on trunk?
# 1. Make sure the eggs directory is empty before running this
# 2. Make sure you fill in the right version!

[buildout]
extensions = buildout.dumppickedversions
parts = bfg
eggs-directory = eggs
find-links = http://pypi.python.org/simple/buildout.dumppickedversions/

# insert the right version here:
bfg_version=dev

index = http://dist.repoze.org/bfg/${buildout:bfg_version}/simple
dump-picked-versions-file = repoze.bfg-${buildout:bfg_version}-versions.cfg

[bfg]
recipe = zc.recipe.egg
eggs = repoze.bfg
[versions]
Paste = 1.7.2
WebOb = 0.9.8
repoze.bfg = 1.2.1
zc.buildout = 1.4.3
zc.recipe.egg = 1.2.2
zope.component = 3.9.1
zope.interface = 3.5.3

#Required by:
#repoze.bfg 1.2.1
Chameleon = 1.1.1

#Required by:
#repoze.bfg 1.2.1
#PasteScript 1.7.3
PasteDeploy = 1.3.3

#Required by:
#repoze.bfg 1.2.1
PasteScript = 1.7.3

#Required by:
#repoze.bfg 1.2.1
repoze.lru = 0.3

#Required by:
#repoze.bfg 1.2.1
#zope.deprecation 3.4.0
#zope.interface 3.5.3
#zope.configuration 3.7.1
#zope.component 3.9.1
setuptools = 0.6c11

#Required by:
#repoze.bfg 1.2.1
zope.configuration = 3.7.1

#Required by:
#repoze.bfg 1.2.1
zope.deprecation = 3.4.0

#Required by:
#zope.schema 3.6.1
#zope.component 3.9.1
zope.event = 3.4.1

#Required by:
#zope.schema 3.6.1
#zope.configuration 3.7.1
zope.i18nmessageid = 3.5.1

#Required by:
#zope.configuration 3.7.1
zope.schema = 3.6.1
[versions]
Paste = 1.7.2
WebOb = 0.9.8
repoze.bfg = 1.2
zc.buildout = 1.4.3
zc.recipe.egg = 1.2.2
zope.component = 3.9.1
zope.interface = 3.5.3

#Required by:
#repoze.bfg 1.2
Chameleon = 1.2.3

#Required by:
#repoze.bfg 1.2
#PasteScript 1.7.3
PasteDeploy = 1.3.3

#Required by:
#repoze.bfg 1.2
PasteScript = 1.7.3

#Required by:
#repoze.bfg 1.2
repoze.lru = 0.3

#Required by:
#repoze.bfg 1.2
#zope.deprecation 3.4.0
#zope.interface 3.5.3
#zope.configuration 3.7.1
#zope.component 3.9.1
setuptools = 0.6c11

#Required by:
#repoze.bfg 1.2
zope.configuration = 3.7.1

#Required by:
#repoze.bfg 1.2
zope.deprecation = 3.4.0

#Required by:
#zope.schema 3.6.1
#zope.component 3.9.1
zope.event = 3.4.1

#Required by:
#zope.schema 3.6.1
#zope.configuration 3.7.1
zope.i18nmessageid = 3.5.1

#Required by:
#zope.configuration 3.7.1
zope.schema = 3.6.1
_______________________________________________
Repoze-dev mailing list
Repoze-dev@lists.repoze.org
http://lists.repoze.org/listinfo/repoze-dev

Reply via email to