Hi Nikolaus,

On Dienstag, 3. März 2015, Nikolaus Rath wrote:
> I managed to get the logs yesterday, but right now it seems down again:

it seems you've found an unlucky time in terms of stability of the service, 
usually it's up all the times...
 
> > did you try to reproduce the problem with pbuilder locally? I think it's
> > more likely a problem with pbuilder than with the reproducible stuff on
> > jenkins. (But I'm offline atm so I cannot test myself.)
> I tried, but for me it works just fine with pbuilder.

let me try with regular pbuilder on the machine...

# Some tests will try to create log files in OME
mkdir -p debian/tmphome
HOME=/tmp/buildd/s3ql-2.13+dfsg/debian/tmphome py.test-3 tests/
=========================================================================================
 test session starts 
=========================================================================================
platform linux -- Python 3.4.2 -- py-1.4.25 -- pytest-2.6.3 -- /usr/bin/python3
collected 279 items 

tests/t1_backends.py::test_read_write[local/aes] PASSED
tests/t1_backends.py::test_read_write[mock-s3c/aes] FAILED

==============================================================================================
 FAILURES 
===============================================================================================
____________________________________________________________________________________
 test_read_write[mock-s3c/aes] 
____________________________________________________________________________________
Traceback (most recent call last):
  File "/tmp/buildd/s3ql-2.13+dfsg/tests/t1_backends.py", line 348, in 
test_read_write
    assert_raises(NoSuchObject, backend.lookup, key)
  File "/usr/lib/python3/dist-packages/_pytest/python.py", line 1037, in raises
    func(*args[1:], **kwargs)
  File "/tmp/buildd/s3ql-2.13+dfsg/src/s3ql/backends/comprenc.py", line 73, in 
lookup
    meta_raw = self.backend.lookup(key)
  File "/tmp/buildd/s3ql-2.13+dfsg/src/s3ql/backends/common.py", line 52, in 
wrapped
    return method(*a, **kw)
  File "/tmp/buildd/s3ql-2.13+dfsg/src/s3ql/backends/s3c.py", line 266, in 
lookup
    resp = self._do_request('HEAD', '/%s%s' % (self.prefix, key))
  File "/tmp/buildd/s3ql-2.13+dfsg/src/s3ql/backends/s3c.py", line 435, in 
_do_request
    query_string=query_string, body=body)
  File "/tmp/buildd/s3ql-2.13+dfsg/src/s3ql/backends/s3c.py", line 695, in 
_send_request
    return read_response()
  File "/tmp/buildd/s3ql-2.13+dfsg/src/s3ql/backends/s3c.py", line 657, in 
read_response
    resp = self.conn.read_response()
  File "/usr/lib/python3/dist-packages/dugong/__init__.py", line 708, in 
read_response
    return eval_coroutine(self.co_read_response(), self.timeout)
  File "/usr/lib/python3/dist-packages/dugong/__init__.py", line 1396, in 
eval_coroutine
    if not next(crt).poll(timeout=timeout):
  File "/usr/lib/python3/dist-packages/dugong/__init__.py", line 733, in 
co_read_response
    (status, reason) = yield from self._co_read_status()
  File "/usr/lib/python3/dist-packages/dugong/__init__.py", line 834, in 
_co_read_status
    line = yield from self._co_readstr_until(b'\r\n', MAX_LINE_SIZE)
  File "/usr/lib/python3/dist-packages/dugong/__init__.py", line 1206, in 
_co_readstr_until
    while not self._try_fill_buffer():
  File "/usr/lib/python3/dist-packages/dugong/__init__.py", line 1254, in 
_try_fill_buffer
    raise ConnectionClosed('connection closed unexpectedly')
dugong.ConnectionClosed: connection closed unexpectedly
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 
Interrupted: stopping after 1 failures 
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
=========================================================================== 1 
failed, 1 passed, 1 warnings in 61.52 seconds 
===========================================================================
debian/rules:55: recipe for target 'override_dh_auto_test' failed
make[1]: *** [override_dh_auto_test] Error 2
make[1]: Leaving directory '/tmp/buildd/s3ql-2.13+dfsg'
debian/rules:13: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
E: Failed autobuilding of package
I: unmounting /run/shm filesystem
I: unmounting /dev/shm filesystem
I: unmounting dev/pts filesystem
I: unmounting proc filesystem
I: cleaning the build env 
I: removing directory /var/cache/pbuilder/build//25946 and its subdirectories
root@jenkins:~/s3# 

So, same result. Which probably means I can reproduce it locally on my laptop
as well. Me tries... and gets the same result. So I suppose an (at least)
important bug is in order...

Nikolaus, which version of pbuilder are you using? I'm using the wheezy one
on wheezy... (on both jenkins.d.n as well as my laptop.)


cheers,
        Holger

Attachment: signature.asc
Description: This is a digitally signed message part.

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to