Source: kadu
Version: 1.3-1
Severity: serious
Tags: sid stretch
Justification: fails to build from source (but built successfully in the past)

Dear Maintainer,

The package fails to build, probably due to CMake version changes:

cd /kadu-1.3/build-dir && cmake -DCMAKE_C_FLAGS="-g -O2 
-fstack-protector-strong -Wformat -Werror=format-security" 
-DCMAKE_CXX_FLAGS="-g -O2 -fstack-protector-strong -Wformat 
-Werror=format-security -D_FORTIFY_SOURCE=2" 
-- Plugin: sql_history
-- Plugin: tabs
-- Plugin: word_fix
CMake Error at /usr/share/cmake-3.2/Modules/CMakePackageConfigHelpers.cmake:231 
  Unknown keywords given to CONFIGURE_PACKAGE_CONFIG_FILE():
Call Stack (most recent call first):
  CMakeLists.txt:226 (configure_package_config_file)
  CMakeLists.txt:279 (kadu_configure_package_config_file)

-- Configuring incomplete, errors occurred!

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.19.0-21-generic (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reproducible-builds mailing list

Reply via email to