Source: kivy
Version: 1.9.0-1
Severity: serious
Tags: sid stretch
Justification: fails to build from source (but built successfully in the past)
Usertags: ftbfs

Dear Maintainer,

The package fails to build with cython 0.22.  Looks like the transition of 
cython 0.22
to testing is blocked for some reason, so this is sid-only.

I: pybuild base:170: python2.7 clean 

Detected Cython version 0.22
  This version of Cython suffers from known bugs and is unsupported.
  Please install the newest supported version, 0.21.2, if possible, but
  the minimum supported version is 0.20.

  If your platform provides a Cython package, check if you can install
  a supported version. Otherwise, uninstall the platform package and
  install Cython via pip:

    pip install -I Cython==0.21.2

  Please note that the following versions of Cython are not supported
  at all: 0.22, 0.22.beta0, 0.22.alpha0

Cython is missing, its required for compiling kivy !

Traceback (most recent call last):
  File "", line 184, in <module>
    raise ImportError('Incompatible Cython Version')
ImportError: Incompatible Cython Version
E: pybuild pybuild:256: clean: plugin distutils failed with: exit code=1: 
python2.7 clean 

Full build log:

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.19.0-21-generic (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reproducible-builds mailing list

Reply via email to