Source: libodb-qt
Version: 2.4.0-1
Severity: serious
Tags: sid
Justification: fails to build from source
Usertags: ftbfs

Dear Maintainer,

The package fails to build.  First(?), Qt doesn't get found:
configure:17847: g++ -c -g -O2 -fstack-protector-strong -Wformat 
-Werror=format-security -D_REENTRANT  -Wdate-time -D_FORTIFY_SOURCE=2 
conftest.cpp >&5
conftest.cpp:30:57: fatal error: QtCore/qconfig.h: No such file or directory
 #    include <QtCore/qconfig.h> // QT_REDUCE_RELOCATIONS

.... then other things go wrong:

configure:17954: g++ -c -g -O2 -fstack-protector-strong -Wformat 
-Werror=format-security -D_REENTRANT  
-I/usr/include/x86_64-linux-gnu/qt5/QtCore -I/usr/include/x86_64-linux-gnu/qt5  
-Wdate-time -D_FORTIFY_SOURCE=2 conftest.cpp >&5
In file included from /usr/include/x86_64-linux-gnu/qt5/QtCore/qchar.h:37:0,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/qstring.h:37,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/QString:1,
                 from conftest.cpp:36:
/usr/include/x86_64-linux-gnu/qt5/QtCore/qglobal.h:1052:4: error: #error "You 
must build your code with position independent code if Qt was built with 
-reduce-relocations. " "Compile your code with -fPIC (-fPIE is not enough)."

Full build log:

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.19.0-21-generic (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reproducible-builds mailing list

Reply via email to