Source: transgui
Version: 5.0.1-1
Severity: serious
Tags: sid 
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs


Dear Maintainer,

The package fails to build.  It seems not to declare dependencies on a whole 
load of gnome,
which it then tries to link against:

/usr/bin/ld.bfd: warning: ./link.res contains output sections; did you forget 
-T?
/usr/bin/ld.bfd: cannot find -lX11
/usr/bin/ld.bfd: cannot find -lgdk_pixbuf-2.0
/usr/bin/ld.bfd: cannot find -lgtk-x11-2.0
/usr/bin/ld.bfd: cannot find -lgdk-x11-2.0
/usr/bin/ld.bfd: cannot find -lgobject-2.0
/usr/bin/ld.bfd: cannot find -lglib-2.0
/usr/bin/ld.bfd: cannot find -lgthread-2.0
/usr/bin/ld.bfd: cannot find -lgmodule-2.0
/usr/bin/ld.bfd: cannot find -lpango-1.0
/usr/bin/ld.bfd: cannot find -lcairo
/usr/bin/ld.bfd: cannot find -latk-1.0
transgui.lpr(50,1) Error: Error while linking
transgui.lpr(50,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
Makefile:1932: recipe for target 'transgui' failed
make[2]: *** [transgui] Error 1


It built in testing on 2015-05-19, so I'm guessing one of the dependencies 
dropped
a whole load of transitive dependencies.

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.19.0-21-generic (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to