On 07/12/2015 12:02 AM, Karl Berry wrote:
> Meanwhile, Thanh has already made changes in the pdftex source
> repository, revision 724 at
> https://foundry.supelec.fr/scm/viewvc.php/branches/stable/source/?root=pdftex
> (project page: https://foundry.supelec.fr/projects/pdftex/)
> I append his message about it (sent privately).  Will it suffice for
> you?  --karl

It suffices, but it now shifts the problem somewhere else. The
SOURCE_DATE_EPOCH environment variable is an easy way for distributions
like Debian, openSUSE, and Ubuntu to set that variable during all their
builds and immediately get the supporting packages reproducible.

If pdftex does not support that environment variable but instead only
offers latex macros to make the timestamps and ID field reproducible
then we now have to fix all tools that make use of pdflatex. In Debian
616 source packages directly or indirectly build-depend on pdflatex.

Surely many of them can be fixed by fixing other toolchain packages like
Doxygen-latex but others will have to be manually patched.

We also often get a response like "why do I have to patch my software?,
can't that other software be changed instead?". If you decide not to
integrate support for SOURCE_DATE_EPOCH then we would appreciate if you
could layout your reasoning for such decision so that we can refer other
package maintainers to that email.

Thank you for your consideration,


Reproducible-builds mailing list

Reply via email to