Source: zope.sqlalchemy
Version: 0.6.1-2
Severity: serious
Tags: sid stretch
Justification: fails to build from source
Usertags: ftbfs

Dear Maintainer,

The package fails to build:

pydeb: Working on python distribution zope.sqlalchemy
Traceback (most recent call last):
  File "/usr/bin/van-pydeb", line 9, in <module>
    load_entry_point('van.pydeb==1.3.3', 'console_scripts', 'van-pydeb')()
  File "/usr/lib/python2.7/dist-packages/pkg_resources/", line 552, 
in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/dist-packages/pkg_resources/", line 2672, 
in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/dist-packages/pkg_resources/", line 2345, 
in load
    return self.resolve()
  File "/usr/lib/python2.7/dist-packages/pkg_resources/", line 2351, 
in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python2.7/dist-packages/van/pydeb/", line 20, in 
    from pkg_resources import component_re # Is this a public interface?
ImportError: cannot import name component_re
pydeb: Working on binary package

Full build log:

Probably related:

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.19.0-22-generic (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reproducible-builds mailing list

Reply via email to