Source: cucumber
Version: 2.0.0-2
Severity: serious
Tags: sid stretch
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs

Dear Maintainer,

The package fails to build:

/usr/bin/ruby2.1 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb -r json
/usr/lib/ruby/vendor_ruby/pry/cli.rb:100:in `<top (required)>': undefined 
method `new' for Slop:Module (NoMethodError)
        from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /usr/lib/ruby/vendor_ruby/pry.rb:150:in `<top (required)>'
        from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /tmp/buildd/cucumber-2.0.0/spec/spec_helper.rb:9:in `<top 
(required)>'
        from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from 
/tmp/buildd/cucumber-2.0.0/spec/cucumber/cli/configuration_spec.rb:1:in `<top 
(required)>'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1327:in 
`load'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1327:in 
`block in load_spec_files'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1325:in 
`each'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1325:in 
`load_spec_files'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:103:in `setup'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:89:in `run'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:74:in `run'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:42:in `invoke'
        from /usr/bin/rspec:4:in `<main>'
/usr/bin/ruby2.1 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb -r json failed
ERROR: Test "ruby2.1" failed. Exiting.


Full build log:
https://reproducible.debian.net/rb-pkg/unstable/amd64/cucumber.html

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.19.0-23-generic (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to