On 2015-07-31, Guillem Jover wrote:
> On Fri, 2015-07-31 at 16:49:13 +0200, Holger Levsen wrote:
>> so yesterday I tried to build 
>> http://reproducible.alioth.debian.org/debian/dpkg_1.18.1.0~reproducible5.dsc 
>> with pbuilder on sid/armhf and that failed _exactly_ like 
>> https://reproducible.debian.net/rbuild/unstable/amd64/dpkg_1.18.1.0~reproducible5.rbuild.log
>> I then tried to build dpkg_1.18.1.dsc from sid proper and that built 
>> flawlessly on sid/armhf.
>> Thus I conclude our reproducible patches cause this, whatever this is. Yet I 
>> lack time atm to debug this, so this mail is merely a note to Guillem and a 
>> call for help to the reproducible folks.
> Right, I noticed this quite some time ago, but forgot to bring it up.
> W/o having checked anything, it might be that whoever prepared the
> release perhaps forgot to «autoreconf -f -i» the sources and prepared
> it from a previous .dsc instead of a git tree?

I *think* what's happening is the reproducible builds git tree doesn't
include tags for the version, and .dist-version isn't present, so
./get-version is returning an empty string (it can't get it from git or
From .dist-version), so "autoreconf -f -i" fails... running:

  echo > .dist-version
  autoreconf -f -i
  debuild -us -uc # or your build of choice

Seems to fix/workaround the issue.

live well,

Attachment: signature.asc
Description: PGP signature

Reproducible-builds mailing list

Reply via email to