Source: ruby-http
Version: 0.6.1-1
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

ruby-http fails to build from source on unstable/amd64:

  [..]
  [2015-07-17 07:37:49] INFO  WEBrick::HTTPProxyServer#start: pid=11508
  port=8080
  [2015-07-17 07:37:49] INFO  WEBrick::HTTPProxyServer#start: pid=11508
  port=8081
  [2015-07-17 07:37:49] INFO  going to shutdown ...
  [2015-07-17 07:37:49] INFO  WEBrick::HTTPProxyServer#start done.
  [2015-07-17 07:37:49] INFO  going to shutdown ...
  [2015-07-17 07:37:49] INFO  WEBrick::HTTPServer#start done.
  [2015-07-17 07:37:49] INFO  going to shutdown ...
  [2015-07-17 07:37:49] INFO  WEBrick::HTTPProxyServer#start done.
  /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:656:in
  `method_missing': undefined method `its' for
  RSpec::ExampleGroups::HTTPContentType::Parse::WithTextPlain:Class
  (NoMethodError)
        from
        /tmp/buildd/ruby-http-0.6.1/spec/http/content_type_spec.rb:7:in
        `block (3 levels) in <top (required)>'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in
        `module_exec'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in
        `subclass'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:254:in
        `block in define_example_group_method'
        from
        /tmp/buildd/ruby-http-0.6.1/spec/http/content_type_spec.rb:5:in
        `block (2 levels) in <top (required)>'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in
        `module_exec'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in
        `subclass'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:254:in
        `block in define_example_group_method'
        from
        /tmp/buildd/ruby-http-0.6.1/spec/http/content_type_spec.rb:4:in
        `block in <top (required)>'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in
        `module_exec'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in
        `subclass'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:254:in
        `block in define_example_group_method'
        from /usr/lib/ruby/vendor_ruby/rspec/core/dsl.rb:43:in `block in
        expose_example_group_alias'
        from /usr/lib/ruby/vendor_ruby/rspec/core/dsl.rb:82:in `block (2
        levels) in expose_example_group_alias_globally'
        from
        /tmp/buildd/ruby-http-0.6.1/spec/http/content_type_spec.rb:3:in
        `<top (required)>'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1327:in
        `load'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1327:in
        `block in load_spec_files'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1325:in
        `each'
        from
        /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1325:in
        `load_spec_files'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:103:in
        `setup'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:89:in `run'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:74:in `run'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:42:in
        `invoke'
        from /usr/bin/rspec:4:in `<main>'
  /usr/bin/ruby2.1 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb
  failed
  ERROR: Test "ruby2.1" failed. Exiting.
  dh_auto_install: dh_ruby --install
  /tmp/buildd/ruby-http-0.6.1/debian/ruby-http returned exit code 1
  debian/rules:15: recipe for target 'binary' failed
  make: *** [binary] Error 1
  dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit
  status 2

  [..]

The full build log is attached or can be viewed here:

  
https://reproducible.debian.net/logs/unstable/amd64/ruby-http_0.6.1-1.build1.log.gz


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-
I: using fakeroot in build.
I: pbuilder: network access will be disabled during build
I: Current time: Fri Jul 17 07:34:20 GMT+12 2015
I: pbuilder-time-stamp: 1437161660
I: Building the build Environment
I: extracting base tarball [/var/cache/pbuilder/unstable-reproducible-base.tgz]
I: creating local configuration
I: copying local configuration
I: mounting /proc filesystem
I: mounting /run/shm filesystem
I: mounting /dev/pts filesystem
I: Mounting /dev/shm
I: Mounting /sys
I: policy-rc.d already exists
I: Installing the build-deps
 -> Attempting to satisfy build-dependencies
 -> Creating pbuilder-satisfydepends-dummy package
Package: pbuilder-satisfydepends-dummy
Version: 0.invalid.0
Architecture: amd64
Maintainer: Debian Pbuilder Team <pbuilder-ma...@lists.alioth.debian.org>
Description: Dummy package to satisfy dependencies with aptitude - created by 
pbuilder
 This package was created automatically by pbuilder to satisfy the
 build-dependencies of the package being currently built.
Depends: debhelper (>= 7.0.50~), gem2deb (>= 0.7.4~), ruby-http-parser.rb, 
ruby-rspec, ruby-coveralls
dpkg-deb: building package 'pbuilder-satisfydepends-dummy' in 
'/tmp/satisfydepends-aptitude/pbuilder-satisfydepends-dummy.deb'.
Selecting previously unselected package pbuilder-satisfydepends-dummy.
(Reading database ... 20236 files and directories currently installed.)
Preparing to unpack .../pbuilder-satisfydepends-dummy.deb ...
Unpacking pbuilder-satisfydepends-dummy (0.invalid.0) ...
dpkg: pbuilder-satisfydepends-dummy: dependency problems, but configuring 
anyway as you requested:
 pbuilder-satisfydepends-dummy depends on gem2deb (>= 0.7.4~); however:
  Package gem2deb is not installed.
 pbuilder-satisfydepends-dummy depends on ruby-http-parser.rb; however:
  Package ruby-http-parser.rb is not installed.
 pbuilder-satisfydepends-dummy depends on ruby-rspec; however:
  Package ruby-rspec is not installed.
 pbuilder-satisfydepends-dummy depends on ruby-coveralls; however:
  Package ruby-coveralls is not installed.

Setting up pbuilder-satisfydepends-dummy (0.invalid.0) ...
Reading package lists...
Building dependency tree...
Reading state information...
Initializing package states...
Writing extended state information...
Building tag database...
The following NEW packages will be installed:
  ca-certificates{a} devscripts{a} dh-python{a} gem2deb{a} 
  gem2deb-test-runner{a} libexpat1{a} libgmp-dev{a} libgmpxx4ldbl{a} 
  libhttp-parser2.1{a} libmpdec2{a} libpython3-stdlib{a} 
  libpython3.4-minimal{a} libpython3.4-stdlib{a} libruby2.1{a} 
  libruby2.2{a} libssl1.0.0{a} libyaml-0-2{a} mime-support{a} openssl{a} 
  python3{a} python3-chardet{a} python3-debian{a} python3-minimal{a} 
  python3-pkg-resources{a} python3-six{a} python3.4{a} python3.4-minimal{a} 
  ruby{a} ruby-all-dev{a} ruby-coveralls{a} ruby-diff-lcs{a} 
  ruby-domain-name{a} ruby-http-cookie{a} ruby-http-parser.rb{a} 
  ruby-mime-types{a} ruby-minitest{a} ruby-multi-json{a} ruby-netrc{a} 
  ruby-power-assert{a} ruby-rest-client{a} ruby-rspec{a} ruby-rspec-core{a} 
  ruby-rspec-expectations{a} ruby-rspec-mocks{a} ruby-rspec-support{a} 
  ruby-setup{a} ruby-simplecov{a} ruby-term-ansicolor{a} ruby-test-unit{a} 
  ruby-thor{a} ruby-thread-order{a} ruby-tins{a} ruby-unf{a} 
  ruby-unf-ext{a} ruby2.1{a} ruby2.1-dev{a} ruby2.2{a} ruby2.2-dev{a} 
  rubygems-integration{a} 
0 packages upgraded, 59 newly installed, 0 to remove and 0 not upgraded.
Need to get 18.8 MB of archives. After unpacking 79.1 MB will be used.
Writing extended state information...
Get: 1 http://ftp.de.debian.org/debian/ unstable/main libexpat1 amd64 
2.1.0-6+b3 [80.3 kB]
Get: 2 http://ftp.de.debian.org/debian/ unstable/main libmpdec2 amd64 2.4.1-1 
[85.7 kB]
Get: 3 http://ftp.de.debian.org/debian/ unstable/main libssl1.0.0 amd64 
1.0.2d-1 [1274 kB]
Get: 4 http://ftp.de.debian.org/debian/ unstable/main libpython3.4-minimal 
amd64 3.4.3-7 [495 kB]
Get: 5 http://ftp.de.debian.org/debian/ unstable/main mime-support all 3.58 
[36.0 kB]
Get: 6 http://ftp.de.debian.org/debian/ unstable/main libpython3.4-stdlib amd64 
3.4.3-7 [2057 kB]
Get: 7 http://ftp.de.debian.org/debian/ unstable/main libyaml-0-2 amd64 0.1.6-3 
[50.4 kB]
Get: 8 http://ftp.de.debian.org/debian/ unstable/main python3.4-minimal amd64 
3.4.3-7 [1400 kB]
Get: 9 http://ftp.de.debian.org/debian/ unstable/main python3-minimal amd64 
3.4.3-4 [34.7 kB]
Get: 10 http://ftp.de.debian.org/debian/ unstable/main python3.4 amd64 3.4.3-7 
[219 kB]
Get: 11 http://ftp.de.debian.org/debian/ unstable/main libpython3-stdlib amd64 
3.4.3-4 [18.1 kB]
Get: 12 http://ftp.de.debian.org/debian/ unstable/main dh-python all 
1.20150705-1 [66.7 kB]
Get: 13 http://ftp.de.debian.org/debian/ unstable/main python3 amd64 3.4.3-4 
[21.1 kB]
Get: 14 http://ftp.de.debian.org/debian/ unstable/main libhttp-parser2.1 amd64 
2.1-2 [16.0 kB]
Get: 15 http://ftp.de.debian.org/debian/ unstable/main openssl amd64 1.0.2d-1 
[695 kB]
Get: 16 http://ftp.de.debian.org/debian/ unstable/main ca-certificates all 
20150426 [208 kB]
Get: 17 http://ftp.de.debian.org/debian/ unstable/main devscripts amd64 2.15.5 
[906 kB]
Get: 18 http://ftp.de.debian.org/debian/ unstable/main rubygems-integration all 
1.9 [4754 B]
Get: 19 http://ftp.de.debian.org/debian/ unstable/main libruby2.1 amd64 2.1.5-3 
[3281 kB]
Get: 20 http://ftp.de.debian.org/debian/ unstable/main ruby2.1 amd64 2.1.5-3 
[276 kB]
Get: 21 http://ftp.de.debian.org/debian/ unstable/main ruby all 1:2.1.5.1 [9756 
B]
Get: 22 http://ftp.de.debian.org/debian/ unstable/main libruby2.2 amd64 2.2.2-2 
[3102 kB]
Get: 23 http://ftp.de.debian.org/debian/ unstable/main ruby2.2 amd64 2.2.2-2 
[213 kB]
Get: 24 http://ftp.de.debian.org/debian/ unstable/main ruby-minitest all 
5.7.0-1 [49.5 kB]
Get: 25 http://ftp.de.debian.org/debian/ unstable/main ruby-power-assert all 
0.2.3-1 [7236 B]
Get: 26 http://ftp.de.debian.org/debian/ unstable/main ruby-test-unit all 
3.1.2-1 [60.0 kB]
Get: 27 http://ftp.de.debian.org/debian/ unstable/main gem2deb-test-runner all 
0.19 [16.2 kB]
Get: 28 http://ftp.de.debian.org/debian/ unstable/main python3-pkg-resources 
all 17.0-1 [43.7 kB]
Get: 29 http://ftp.de.debian.org/debian/ unstable/main python3-chardet all 
2.3.0-1 [96.1 kB]
Get: 30 http://ftp.de.debian.org/debian/ unstable/main python3-six all 1.9.0-3 
[13.7 kB]
Get: 31 http://ftp.de.debian.org/debian/ unstable/main python3-debian all 
0.1.27 [50.9 kB]
Get: 32 http://ftp.de.debian.org/debian/ unstable/main libgmpxx4ldbl amd64 
2:6.0.0+dfsg-7 [22.2 kB]
Get: 33 http://ftp.de.debian.org/debian/ unstable/main libgmp-dev amd64 
2:6.0.0+dfsg-7 [621 kB]
Get: 34 http://ftp.de.debian.org/debian/ unstable/main ruby2.1-dev amd64 
2.1.5-3 [1101 kB]
Get: 35 http://ftp.de.debian.org/debian/ unstable/main ruby2.2-dev amd64 
2.2.2-2 [1142 kB]
Get: 36 http://ftp.de.debian.org/debian/ unstable/main ruby-all-dev all 
1:2.1.5.1 [9188 B]
Get: 37 http://ftp.de.debian.org/debian/ unstable/main ruby-setup all 3.4.1-9 
[34.2 kB]
Get: 38 http://ftp.de.debian.org/debian/ unstable/main gem2deb all 0.19 [51.6 
kB]
Get: 39 http://ftp.de.debian.org/debian/ unstable/main ruby-unf-ext amd64 
0.0.7.1-1+b1 [96.4 kB]
Get: 40 http://ftp.de.debian.org/debian/ unstable/main ruby-unf all 0.1.0-2 
[4230 B]
Get: 41 http://ftp.de.debian.org/debian/ unstable/main ruby-domain-name all 
0.5.21-1 [66.8 kB]
Get: 42 http://ftp.de.debian.org/debian/ unstable/main ruby-http-cookie all 
1.0.2-1 [22.3 kB]
Get: 43 http://ftp.de.debian.org/debian/ unstable/main ruby-mime-types all 
2.6.1-1 [120 kB]
Get: 44 http://ftp.de.debian.org/debian/ unstable/main ruby-netrc all 0.10.3-1 
[6278 B]
Get: 45 http://ftp.de.debian.org/debian/ unstable/main ruby-rest-client all 
1.8.0-1 [29.5 kB]
Get: 46 http://ftp.de.debian.org/debian/ unstable/main ruby-tins all 1.1.0-1 
[26.9 kB]
Get: 47 http://ftp.de.debian.org/debian/ unstable/main ruby-term-ansicolor all 
1.3.0-1 [14.3 kB]
Get: 48 http://ftp.de.debian.org/debian/ unstable/main ruby-multi-json all 
1.11.0-1 [18.8 kB]
Get: 49 http://ftp.de.debian.org/debian/ unstable/main ruby-thor all 0.19.1-1 
[46.6 kB]
Get: 50 http://ftp.de.debian.org/debian/ unstable/main ruby-simplecov all 
0.7.1-2 [18.7 kB]
Get: 51 http://ftp.de.debian.org/debian/ unstable/main ruby-coveralls all 
0.7.0-1 [10.6 kB]
Get: 52 http://ftp.de.debian.org/debian/ unstable/main ruby-diff-lcs all 
1.2.5-1 [26.7 kB]
Get: 53 http://ftp.de.debian.org/debian/ unstable/main ruby-http-parser.rb 
amd64 0.6.0-2+b3 [9968 B]
Get: 54 http://ftp.de.debian.org/debian/ unstable/main ruby-rspec-support all 
3.3.0c0e0m0s0-1 [24.3 kB]
Get: 55 http://ftp.de.debian.org/debian/ unstable/main ruby-rspec-expectations 
all 3.3.0c0e0m0s0-1 [90.1 kB]
Get: 56 http://ftp.de.debian.org/debian/ unstable/main ruby-rspec-mocks all 
3.3.0c0e0m0s0-1 [87.0 kB]
Get: 57 http://ftp.de.debian.org/debian/ unstable/main ruby-thread-order all 
1.1.0-1 [5096 B]
Get: 58 http://ftp.de.debian.org/debian/ unstable/main ruby-rspec-core all 
3.3.0c0e0m0s0-1 [174 kB]
Get: 59 http://ftp.de.debian.org/debian/ unstable/main ruby-rspec all 
3.3.0c0e0m0s0-1 [6544 B]
Fetched 18.8 MB in 1s (9542 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package libexpat1:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 20236 files and directories currently installed.)
Preparing to unpack .../libexpat1_2.1.0-6+b3_amd64.deb ...
Unpacking libexpat1:amd64 (2.1.0-6+b3) ...
Selecting previously unselected package libmpdec2:amd64.
Preparing to unpack .../libmpdec2_2.4.1-1_amd64.deb ...
Unpacking libmpdec2:amd64 (2.4.1-1) ...
Selecting previously unselected package libssl1.0.0:amd64.
Preparing to unpack .../libssl1.0.0_1.0.2d-1_amd64.deb ...
Unpacking libssl1.0.0:amd64 (1.0.2d-1) ...
Selecting previously unselected package libpython3.4-minimal:amd64.
Preparing to unpack .../libpython3.4-minimal_3.4.3-7_amd64.deb ...
Unpacking libpython3.4-minimal:amd64 (3.4.3-7) ...
Selecting previously unselected package mime-support.
Preparing to unpack .../mime-support_3.58_all.deb ...
Unpacking mime-support (3.58) ...
Selecting previously unselected package libpython3.4-stdlib:amd64.
Preparing to unpack .../libpython3.4-stdlib_3.4.3-7_amd64.deb ...
Unpacking libpython3.4-stdlib:amd64 (3.4.3-7) ...
Selecting previously unselected package libyaml-0-2:amd64.
Preparing to unpack .../libyaml-0-2_0.1.6-3_amd64.deb ...
Unpacking libyaml-0-2:amd64 (0.1.6-3) ...
Selecting previously unselected package python3.4-minimal.
Preparing to unpack .../python3.4-minimal_3.4.3-7_amd64.deb ...
Unpacking python3.4-minimal (3.4.3-7) ...
Selecting previously unselected package python3-minimal.
Preparing to unpack .../python3-minimal_3.4.3-4_amd64.deb ...
Unpacking python3-minimal (3.4.3-4) ...
Selecting previously unselected package python3.4.
Preparing to unpack .../python3.4_3.4.3-7_amd64.deb ...
Unpacking python3.4 (3.4.3-7) ...
Selecting previously unselected package libpython3-stdlib:amd64.
Preparing to unpack .../libpython3-stdlib_3.4.3-4_amd64.deb ...
Unpacking libpython3-stdlib:amd64 (3.4.3-4) ...
Selecting previously unselected package dh-python.
Preparing to unpack .../dh-python_1.20150705-1_all.deb ...
Unpacking dh-python (1.20150705-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up libssl1.0.0:amd64 (1.0.2d-1) ...
Setting up libpython3.4-minimal:amd64 (3.4.3-7) ...
Setting up libexpat1:amd64 (2.1.0-6+b3) ...
Setting up python3.4-minimal (3.4.3-7) ...
Setting up python3-minimal (3.4.3-4) ...
Processing triggers for libc-bin (2.19-19) ...
Selecting previously unselected package python3.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 21198 files and directories currently installed.)
Preparing to unpack .../python3_3.4.3-4_amd64.deb ...
Unpacking python3 (3.4.3-4) ...
Selecting previously unselected package libhttp-parser2.1:amd64.
Preparing to unpack .../libhttp-parser2.1_2.1-2_amd64.deb ...
Unpacking libhttp-parser2.1:amd64 (2.1-2) ...
Selecting previously unselected package openssl.
Preparing to unpack .../openssl_1.0.2d-1_amd64.deb ...
Unpacking openssl (1.0.2d-1) ...
Selecting previously unselected package ca-certificates.
Preparing to unpack .../ca-certificates_20150426_all.deb ...
Unpacking ca-certificates (20150426) ...
Selecting previously unselected package devscripts.
Preparing to unpack .../devscripts_2.15.5_amd64.deb ...
Unpacking devscripts (2.15.5) ...
Selecting previously unselected package rubygems-integration.
Preparing to unpack .../rubygems-integration_1.9_all.deb ...
Unpacking rubygems-integration (1.9) ...
Selecting previously unselected package libruby2.1:amd64.
Preparing to unpack .../libruby2.1_2.1.5-3_amd64.deb ...
Unpacking libruby2.1:amd64 (2.1.5-3) ...
Selecting previously unselected package ruby2.1.
Preparing to unpack .../ruby2.1_2.1.5-3_amd64.deb ...
Unpacking ruby2.1 (2.1.5-3) ...
Selecting previously unselected package ruby.
Preparing to unpack .../ruby_1%3a2.1.5.1_all.deb ...
Unpacking ruby (1:2.1.5.1) ...
Selecting previously unselected package libruby2.2:amd64.
Preparing to unpack .../libruby2.2_2.2.2-2_amd64.deb ...
Unpacking libruby2.2:amd64 (2.2.2-2) ...
Selecting previously unselected package ruby2.2.
Preparing to unpack .../ruby2.2_2.2.2-2_amd64.deb ...
Unpacking ruby2.2 (2.2.2-2) ...
Selecting previously unselected package ruby-minitest.
Preparing to unpack .../ruby-minitest_5.7.0-1_all.deb ...
Unpacking ruby-minitest (5.7.0-1) ...
Selecting previously unselected package ruby-power-assert.
Preparing to unpack .../ruby-power-assert_0.2.3-1_all.deb ...
Unpacking ruby-power-assert (0.2.3-1) ...
Selecting previously unselected package ruby-test-unit.
Preparing to unpack .../ruby-test-unit_3.1.2-1_all.deb ...
Unpacking ruby-test-unit (3.1.2-1) ...
Selecting previously unselected package gem2deb-test-runner.
Preparing to unpack .../gem2deb-test-runner_0.19_all.deb ...
Unpacking gem2deb-test-runner (0.19) ...
Selecting previously unselected package python3-pkg-resources.
Preparing to unpack .../python3-pkg-resources_17.0-1_all.deb ...
Unpacking python3-pkg-resources (17.0-1) ...
Selecting previously unselected package python3-chardet.
Preparing to unpack .../python3-chardet_2.3.0-1_all.deb ...
Unpacking python3-chardet (2.3.0-1) ...
Selecting previously unselected package python3-six.
Preparing to unpack .../python3-six_1.9.0-3_all.deb ...
Unpacking python3-six (1.9.0-3) ...
Selecting previously unselected package python3-debian.
Preparing to unpack .../python3-debian_0.1.27_all.deb ...
Unpacking python3-debian (0.1.27) ...
Selecting previously unselected package libgmpxx4ldbl:amd64.
Preparing to unpack .../libgmpxx4ldbl_2%3a6.0.0+dfsg-7_amd64.deb ...
Unpacking libgmpxx4ldbl:amd64 (2:6.0.0+dfsg-7) ...
Selecting previously unselected package libgmp-dev:amd64.
Preparing to unpack .../libgmp-dev_2%3a6.0.0+dfsg-7_amd64.deb ...
Unpacking libgmp-dev:amd64 (2:6.0.0+dfsg-7) ...
Selecting previously unselected package ruby2.1-dev:amd64.
Preparing to unpack .../ruby2.1-dev_2.1.5-3_amd64.deb ...
Unpacking ruby2.1-dev:amd64 (2.1.5-3) ...
Selecting previously unselected package ruby2.2-dev:amd64.
Preparing to unpack .../ruby2.2-dev_2.2.2-2_amd64.deb ...
Unpacking ruby2.2-dev:amd64 (2.2.2-2) ...
Selecting previously unselected package ruby-all-dev.
Preparing to unpack .../ruby-all-dev_1%3a2.1.5.1_all.deb ...
Unpacking ruby-all-dev (1:2.1.5.1) ...
Selecting previously unselected package ruby-setup.
Preparing to unpack .../ruby-setup_3.4.1-9_all.deb ...
Unpacking ruby-setup (3.4.1-9) ...
Selecting previously unselected package gem2deb.
Preparing to unpack .../archives/gem2deb_0.19_all.deb ...
Unpacking gem2deb (0.19) ...
Selecting previously unselected package ruby-unf-ext.
Preparing to unpack .../ruby-unf-ext_0.0.7.1-1+b1_amd64.deb ...
Unpacking ruby-unf-ext (0.0.7.1-1+b1) ...
Selecting previously unselected package ruby-unf.
Preparing to unpack .../ruby-unf_0.1.0-2_all.deb ...
Unpacking ruby-unf (0.1.0-2) ...
Selecting previously unselected package ruby-domain-name.
Preparing to unpack .../ruby-domain-name_0.5.21-1_all.deb ...
Unpacking ruby-domain-name (0.5.21-1) ...
Selecting previously unselected package ruby-http-cookie.
Preparing to unpack .../ruby-http-cookie_1.0.2-1_all.deb ...
Unpacking ruby-http-cookie (1.0.2-1) ...
Selecting previously unselected package ruby-mime-types.
Preparing to unpack .../ruby-mime-types_2.6.1-1_all.deb ...
Unpacking ruby-mime-types (2.6.1-1) ...
Selecting previously unselected package ruby-netrc.
Preparing to unpack .../ruby-netrc_0.10.3-1_all.deb ...
Unpacking ruby-netrc (0.10.3-1) ...
Selecting previously unselected package ruby-rest-client.
Preparing to unpack .../ruby-rest-client_1.8.0-1_all.deb ...
Unpacking ruby-rest-client (1.8.0-1) ...
Selecting previously unselected package ruby-tins.
Preparing to unpack .../ruby-tins_1.1.0-1_all.deb ...
Unpacking ruby-tins (1.1.0-1) ...
Selecting previously unselected package ruby-term-ansicolor.
Preparing to unpack .../ruby-term-ansicolor_1.3.0-1_all.deb ...
Unpacking ruby-term-ansicolor (1.3.0-1) ...
Selecting previously unselected package ruby-multi-json.
Preparing to unpack .../ruby-multi-json_1.11.0-1_all.deb ...
Unpacking ruby-multi-json (1.11.0-1) ...
Selecting previously unselected package ruby-thor.
Preparing to unpack .../ruby-thor_0.19.1-1_all.deb ...
Unpacking ruby-thor (0.19.1-1) ...
Selecting previously unselected package ruby-simplecov.
Preparing to unpack .../ruby-simplecov_0.7.1-2_all.deb ...
Unpacking ruby-simplecov (0.7.1-2) ...
Selecting previously unselected package ruby-coveralls.
Preparing to unpack .../ruby-coveralls_0.7.0-1_all.deb ...
Unpacking ruby-coveralls (0.7.0-1) ...
Selecting previously unselected package ruby-diff-lcs.
Preparing to unpack .../ruby-diff-lcs_1.2.5-1_all.deb ...
Unpacking ruby-diff-lcs (1.2.5-1) ...
Selecting previously unselected package ruby-http-parser.rb.
Preparing to unpack .../ruby-http-parser.rb_0.6.0-2+b3_amd64.deb ...
Unpacking ruby-http-parser.rb (0.6.0-2+b3) ...
Selecting previously unselected package ruby-rspec-support.
Preparing to unpack .../ruby-rspec-support_3.3.0c0e0m0s0-1_all.deb ...
Unpacking ruby-rspec-support (3.3.0c0e0m0s0-1) ...
Selecting previously unselected package ruby-rspec-expectations.
Preparing to unpack .../ruby-rspec-expectations_3.3.0c0e0m0s0-1_all.deb ...
Unpacking ruby-rspec-expectations (3.3.0c0e0m0s0-1) ...
Selecting previously unselected package ruby-rspec-mocks.
Preparing to unpack .../ruby-rspec-mocks_3.3.0c0e0m0s0-1_all.deb ...
Unpacking ruby-rspec-mocks (3.3.0c0e0m0s0-1) ...
Selecting previously unselected package ruby-thread-order.
Preparing to unpack .../ruby-thread-order_1.1.0-1_all.deb ...
Unpacking ruby-thread-order (1.1.0-1) ...
Selecting previously unselected package ruby-rspec-core.
Preparing to unpack .../ruby-rspec-core_3.3.0c0e0m0s0-1_all.deb ...
Unpacking ruby-rspec-core (3.3.0c0e0m0s0-1) ...
Selecting previously unselected package ruby-rspec.
Preparing to unpack .../ruby-rspec_3.3.0c0e0m0s0-1_all.deb ...
Unpacking ruby-rspec (3.3.0c0e0m0s0-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up libmpdec2:amd64 (2.4.1-1) ...
Setting up mime-support (3.58) ...
Setting up libpython3.4-stdlib:amd64 (3.4.3-7) ...
Setting up libyaml-0-2:amd64 (0.1.6-3) ...
Setting up python3.4 (3.4.3-7) ...
Setting up libpython3-stdlib:amd64 (3.4.3-4) ...
Setting up libhttp-parser2.1:amd64 (2.1-2) ...
Setting up openssl (1.0.2d-1) ...
Setting up ca-certificates (20150426) ...
Setting up rubygems-integration (1.9) ...
Setting up libruby2.1:amd64 (2.1.5-3) ...
Setting up ruby2.1 (2.1.5-3) ...
Setting up ruby (1:2.1.5.1) ...
Setting up libruby2.2:amd64 (2.2.2-2) ...
Setting up ruby2.2 (2.2.2-2) ...
Setting up ruby-minitest (5.7.0-1) ...
Setting up ruby-power-assert (0.2.3-1) ...
Setting up ruby-test-unit (3.1.2-1) ...
Setting up gem2deb-test-runner (0.19) ...
Setting up libgmpxx4ldbl:amd64 (2:6.0.0+dfsg-7) ...
Setting up libgmp-dev:amd64 (2:6.0.0+dfsg-7) ...
Setting up ruby2.1-dev:amd64 (2.1.5-3) ...
Setting up ruby2.2-dev:amd64 (2.2.2-2) ...
Setting up ruby-all-dev (1:2.1.5.1) ...
Setting up ruby-setup (3.4.1-9) ...
Setting up ruby-unf-ext (0.0.7.1-1+b1) ...
Setting up ruby-unf (0.1.0-2) ...
Setting up ruby-domain-name (0.5.21-1) ...
Setting up ruby-http-cookie (1.0.2-1) ...
Setting up ruby-mime-types (2.6.1-1) ...
Setting up ruby-netrc (0.10.3-1) ...
Setting up ruby-rest-client (1.8.0-1) ...
Setting up ruby-tins (1.1.0-1) ...
Setting up ruby-term-ansicolor (1.3.0-1) ...
Setting up ruby-multi-json (1.11.0-1) ...
Setting up ruby-thor (0.19.1-1) ...
Setting up ruby-simplecov (0.7.1-2) ...
Setting up ruby-coveralls (0.7.0-1) ...
Setting up ruby-diff-lcs (1.2.5-1) ...
Setting up ruby-http-parser.rb (0.6.0-2+b3) ...
Setting up ruby-rspec-support (3.3.0c0e0m0s0-1) ...
Setting up ruby-rspec-expectations (3.3.0c0e0m0s0-1) ...
Setting up ruby-rspec-mocks (3.3.0c0e0m0s0-1) ...
Setting up ruby-thread-order (1.1.0-1) ...
Setting up ruby-rspec-core (3.3.0c0e0m0s0-1) ...
Setting up ruby-rspec (3.3.0c0e0m0s0-1) ...
Setting up python3 (3.4.3-4) ...
Setting up devscripts (2.15.5) ...
Setting up python3-pkg-resources (17.0-1) ...
Setting up python3-chardet (2.3.0-1) ...
Setting up python3-six (1.9.0-3) ...
Setting up python3-debian (0.1.27) ...
Setting up gem2deb (0.19) ...
Setting up dh-python (1.20150705-1) ...
Processing triggers for libc-bin (2.19-19) ...
Processing triggers for ca-certificates (20150426) ...
Updating certificates in /etc/ssl/certs...
180 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.
Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Writing extended state information...
Building tag database...
 -> Finished parsing the build-deps
Reading package lists...
Building dependency tree...
Reading state information...
fakeroot is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
I: Copying source file
I: copying [ruby-http_0.6.1-1.dsc]
I: copying [./ruby-http_0.6.1.orig.tar.gz]
I: copying [./ruby-http_0.6.1-1.debian.tar.xz]
I: Extracting source
gpgv: keyblock resource `/tmp/buildd/.gnupg/trustedkeys.gpg': file open error
gpgv: Signature made Thu Jun  5 05:21:21 2014 GMT+12 using RSA key ID 39CD217A
gpgv: Can't check signature: public key not found
dpkg-source: warning: failed to verify signature on ./ruby-http_0.6.1-1.dsc
dpkg-source: info: extracting ruby-http in ruby-http-0.6.1
dpkg-source: info: unpacking ruby-http_0.6.1.orig.tar.gz
dpkg-source: info: unpacking ruby-http_0.6.1-1.debian.tar.xz
dpkg-source: info: applying removing_simplecov_html.patch
I: Building the package
I: Running cd tmp/buildd/*/ && env 
PATH="/usr/sbin:/usr/bin:/sbin:/bin:/usr/games" dpkg-buildpackage -us -uc  -b 
-rfakeroot
dpkg-buildpackage: source package ruby-http
dpkg-buildpackage: source version 0.6.1-1
dpkg-buildpackage: source distribution unstable
dpkg-buildpackage: source changed by Nitesh A Jain <niteshjai...@gmail.com>
 dpkg-source --before-build ruby-http-0.6.1
dpkg-buildpackage: host architecture amd64
 fakeroot debian/rules clean
dh clean
   dh_testdir
   dh_auto_clean
   dh_clean
rm -rf coverage
 debian/rules build
dh build --buildsystem=ruby --with ruby
   dh_testdir -O--buildsystem=ruby
   dh_auto_configure -O--buildsystem=ruby
        dh_ruby --configure
   dh_auto_build -O--buildsystem=ruby
        dh_ruby --build
   dh_ruby --build
   dh_auto_test -O--buildsystem=ruby
        dh_ruby --test
 fakeroot debian/rules binary
dh binary --buildsystem=ruby --with ruby
   dh_testroot -O--buildsystem=ruby
   dh_prep -O--buildsystem=ruby
   dh_auto_install -O--buildsystem=ruby
        dh_ruby --install /tmp/buildd/ruby-http-0.6.1/debian/ruby-http
   dh_ruby --install
install -d /tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/request/writer.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/request/writer.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/backports/uri.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/backports/uri.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/backports/base64.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/backports/base64.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/authorization_header.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/authorization_header.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/chainable.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/chainable.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/headers/mixin.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/headers/mixin.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/version.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/version.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/backports.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/backports.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/request.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/request.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/client.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/client.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/content_type.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/content_type.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/mime_type/adapter.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/mime_type/adapter.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/mime_type/json.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/mime_type/json.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/options.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/options.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/response/body.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/response/body.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/response/parser.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/response/parser.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/mime_type.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/mime_type.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/response.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/response.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/errors.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/errors.rb
install -D -m644 
/tmp/buildd/ruby-http-0.6.1/lib/http/authorization_header/bearer_token.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/authorization_header/bearer_token.rb
install -D -m644 
/tmp/buildd/ruby-http-0.6.1/lib/http/authorization_header/basic_auth.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/authorization_header/basic_auth.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/redirector.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/redirector.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http/headers.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http/headers.rb
install -D -m644 /tmp/buildd/ruby-http-0.6.1/lib/http.rb 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby/http.rb
generating gemspec at 
/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/share/rubygems-integration/all/specifications/http-0.6.1.gemspec
/usr/bin/ruby2.1 /usr/bin/gem2deb-test-runner
Running tests for ruby2.1 using debian/ruby-tests.rake ...
RUBYLIB=/tmp/buildd/ruby-http-0.6.1/debian/ruby-http/usr/lib/ruby/vendor_ruby:. 
ruby2.1 -rrake -e ARGV.unshift\(\"-f\",\ \"debian/ruby-tests.rake\"\)\;\ 
Rake.application.run
/usr/bin/ruby2.1 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb
[2015-07-17 07:37:49] INFO  WEBrick 1.3.1
[2015-07-17 07:37:49] INFO  ruby 2.1.5 (2014-11-13) [x86_64-linux-gnu]
[2015-07-17 07:37:49] INFO  WEBrick::HTTPServer#start: pid=11508 port=65432
[2015-07-17 07:37:49] INFO  WEBrick 1.3.1
[2015-07-17 07:37:49] INFO  ruby 2.1.5 (2014-11-13) [x86_64-linux-gnu]
[2015-07-17 07:37:49] INFO  WEBrick 1.3.1
[2015-07-17 07:37:49] INFO  ruby 2.1.5 (2014-11-13) [x86_64-linux-gnu]
[2015-07-17 07:37:49] INFO  WEBrick::HTTPProxyServer#start: pid=11508 port=8080
[2015-07-17 07:37:49] INFO  WEBrick::HTTPProxyServer#start: pid=11508 port=8081
[2015-07-17 07:37:49] INFO  going to shutdown ...
[2015-07-17 07:37:49] INFO  WEBrick::HTTPProxyServer#start done.
[2015-07-17 07:37:49] INFO  going to shutdown ...
[2015-07-17 07:37:49] INFO  WEBrick::HTTPServer#start done.
[2015-07-17 07:37:49] INFO  going to shutdown ...
[2015-07-17 07:37:49] INFO  WEBrick::HTTPProxyServer#start done.
/usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:656:in `method_missing': 
undefined method `its' for 
RSpec::ExampleGroups::HTTPContentType::Parse::WithTextPlain:Class 
(NoMethodError)
        from /tmp/buildd/ruby-http-0.6.1/spec/http/content_type_spec.rb:7:in 
`block (3 levels) in <top (required)>'
        from /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in 
`module_exec'
        from /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in 
`subclass'
        from /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:254:in 
`block in define_example_group_method'
        from /tmp/buildd/ruby-http-0.6.1/spec/http/content_type_spec.rb:5:in 
`block (2 levels) in <top (required)>'
        from /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in 
`module_exec'
        from /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in 
`subclass'
        from /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:254:in 
`block in define_example_group_method'
        from /tmp/buildd/ruby-http-0.6.1/spec/http/content_type_spec.rb:4:in 
`block in <top (required)>'
        from /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in 
`module_exec'
        from /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:363:in 
`subclass'
        from /usr/lib/ruby/vendor_ruby/rspec/core/example_group.rb:254:in 
`block in define_example_group_method'
        from /usr/lib/ruby/vendor_ruby/rspec/core/dsl.rb:43:in `block in 
expose_example_group_alias'
        from /usr/lib/ruby/vendor_ruby/rspec/core/dsl.rb:82:in `block (2 
levels) in expose_example_group_alias_globally'
        from /tmp/buildd/ruby-http-0.6.1/spec/http/content_type_spec.rb:3:in 
`<top (required)>'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1327:in 
`load'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1327:in 
`block in load_spec_files'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1325:in 
`each'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1325:in 
`load_spec_files'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:103:in `setup'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:89:in `run'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:74:in `run'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:42:in `invoke'
        from /usr/bin/rspec:4:in `<main>'
/usr/bin/ruby2.1 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb failed
ERROR: Test "ruby2.1" failed. Exiting.
dh_auto_install: dh_ruby --install /tmp/buildd/ruby-http-0.6.1/debian/ruby-http 
returned exit code 1
debian/rules:15: recipe for target 'binary' failed
make: *** [binary] Error 1
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
E: Failed autobuilding of package
I: unmounting /sys filesystem
I: unmounting /dev/shm filesystem
I: unmounting dev/pts filesystem
I: unmounting run/shm filesystem
I: unmounting proc filesystem
I: cleaning the build env 
I: removing directory /var/cache/pbuilder/build//7227 and its subdirectories
_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to