Source: libbuffy-bindings
Version: 0.16
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

libbuffy-bindings fails to build from source in unstable/amd64:

  [..]

  cd tests && ./test.pl
  1..90
  Can't load '../perl/blib/arch/auto/Buffy/Buffy.so' for module Buffy:
  ../perl/blib/arch/auto/Buffy/Buffy.so: undefined symbol:
  _ZN6wibble9exception10AddContext9s_contextE at
  /usr/lib/x86_64-linux-gnu/perl/5.20/DynaLoader.pm line 187.
   at ../perl/Buffy.pm line 11.
  Compilation failed in require at ./test.pl line 7.
  BEGIN failed--compilation aborted at ./test.pl line 7.
  # Looks like your test exited with 255 before it could output
  anything.
  debian/rules:36: recipe for target 'override_dh_auto_test' failed
  make[1]: *** [override_dh_auto_test] Error 255
  make[1]: Leaving directory '/tmp/buildd/libbuffy-bindings-0.16'
  debian/rules:9: recipe for target 'build' failed
  make: *** [build] Error 2
  dpkg-buildpackage: error: debian/rules build gave error exit status 2

  [..]

The full build log is attached or can be viewed here:

    
https://reproducible.debian.net/logs/unstable/amd64/libbuffy-bindings_0.16.build1.log.gz


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-
I: using fakeroot in build.
I: pbuilder: network access will be disabled during build
I: Current time: Fri Aug 21 06:26:27 GMT+12 2015
I: pbuilder-time-stamp: 1440181587
I: Building the build Environment
I: extracting base tarball [/var/cache/pbuilder/unstable-reproducible-base.tgz]
I: creating local configuration
I: copying local configuration
I: mounting /proc filesystem
I: mounting /run/shm filesystem
I: mounting /dev/pts filesystem
I: Mounting /dev/shm
I: Mounting /sys
I: policy-rc.d already exists
I: Installing the build-deps
 -> Attempting to satisfy build-dependencies
 -> Creating pbuilder-satisfydepends-dummy package
Package: pbuilder-satisfydepends-dummy
Version: 0.invalid.0
Architecture: amd64
Maintainer: Debian Pbuilder Team <pbuilder-ma...@lists.alioth.debian.org>
Description: Dummy package to satisfy dependencies with aptitude - created by 
pbuilder
 This package was created automatically by pbuilder to satisfy the
 build-dependencies of the package being currently built.
Depends: debhelper (>= 9), libbuffy-dev (>= 1.9), libwibble-dev (>= 1.0), 
libglib2.0-dev, zlib1g-dev, swig (>= 2.0), perl (>= 5.6.0-16), python-all-dev 
(>= 2.6.6-3~), dh-python, pkg-config
dpkg-deb: building package 'pbuilder-satisfydepends-dummy' in 
'/tmp/satisfydepends-aptitude/pbuilder-satisfydepends-dummy.deb'.
Selecting previously unselected package pbuilder-satisfydepends-dummy.
(Reading database ... 20247 files and directories currently installed.)
Preparing to unpack .../pbuilder-satisfydepends-dummy.deb ...
Unpacking pbuilder-satisfydepends-dummy (0.invalid.0) ...
dpkg: pbuilder-satisfydepends-dummy: dependency problems, but configuring 
anyway as you requested:
 pbuilder-satisfydepends-dummy depends on libbuffy-dev (>= 1.9); however:
  Package libbuffy-dev is not installed.
 pbuilder-satisfydepends-dummy depends on libwibble-dev (>= 1.0); however:
  Package libwibble-dev is not installed.
 pbuilder-satisfydepends-dummy depends on libglib2.0-dev; however:
  Package libglib2.0-dev is not installed.
 pbuilder-satisfydepends-dummy depends on zlib1g-dev; however:
  Package zlib1g-dev is not installed.
 pbuilder-satisfydepends-dummy depends on swig (>= 2.0); however:
  Package swig is not installed.
 pbuilder-satisfydepends-dummy depends on python-all-dev (>= 2.6.6-3~); however:
  Package python-all-dev is not installed.
 pbuilder-satisfydepends-dummy depends on dh-python; however:
  Package dh-python is not installed.
 pbuilder-satisfydepends-dummy depends on pkg-config; however:
  Package pkg-config is not installed.

Setting up pbuilder-satisfydepends-dummy (0.invalid.0) ...
Reading package lists...
Building dependency tree...
Reading state information...
Initializing package states...
Writing extended state information...
Building tag database...
The following NEW packages will be installed:
  dh-python{a} libbuffy-dev{a} libelf1{a} libexpat1{a} libexpat1-dev{a} 
  libglib2.0-bin{a} libglib2.0-data{a} libglib2.0-dev{a} libmpdec2{a} 
  libpcre16-3{a} libpcre3-dev{a} libpcre32-3{a} libpcrecpp0v5{a} 
  libpython-all-dev{a} libpython-dev{a} libpython-stdlib{a} libpython2.7{a} 
  libpython2.7-dev{a} libpython2.7-minimal{a} libpython2.7-stdlib{a} 
  libpython3-stdlib{a} libpython3.4-minimal{a} libpython3.4-stdlib{a} 
  libssl1.0.0{a} libwibble-dev{a} mime-support{a} pkg-config{a} python{a} 
  python-all{a} python-all-dev{a} python-dev{a} python-minimal{a} 
  python2.7{a} python2.7-dev{a} python2.7-minimal{a} python3{a} 
  python3-minimal{a} python3.4{a} python3.4-minimal{a} swig{a} swig2.0{a} 
  zlib1g-dev{a} 
0 packages upgraded, 42 newly installed, 0 to remove and 0 not upgraded.
Need to get 40.6 MB of archives. After unpacking 126 MB will be used.
Writing extended state information...
Get: 1 http://ftp.de.debian.org/debian/ unstable/main libpython2.7-minimal 
amd64 2.7.10-3 [382 kB]
Get: 2 http://ftp.de.debian.org/debian/ unstable/main python2.7-minimal amd64 
2.7.10-3 [1418 kB]
Get: 3 http://ftp.de.debian.org/debian/ unstable/main python-minimal amd64 
2.7.9-1 [40.3 kB]
Get: 4 http://ftp.de.debian.org/debian/ unstable/main mime-support all 3.59 
[36.4 kB]
Get: 5 http://ftp.de.debian.org/debian/ unstable/main libexpat1 amd64 2.1.0-7 
[80.0 kB]
Get: 6 http://ftp.de.debian.org/debian/ unstable/main libssl1.0.0 amd64 
1.0.2d-1 [1274 kB]
Get: 7 http://ftp.de.debian.org/debian/ unstable/main libpython2.7-stdlib amd64 
2.7.10-3 [1854 kB]
Get: 8 http://ftp.de.debian.org/debian/ unstable/main python2.7 amd64 2.7.10-3 
[258 kB]
Get: 9 http://ftp.de.debian.org/debian/ unstable/main libpython-stdlib amd64 
2.7.9-1 [19.5 kB]
Get: 10 http://ftp.de.debian.org/debian/ unstable/main python amd64 2.7.9-1 
[151 kB]
Get: 11 http://ftp.de.debian.org/debian/ unstable/main libmpdec2 amd64 2.4.1-1 
[85.7 kB]
Get: 12 http://ftp.de.debian.org/debian/ unstable/main libpcrecpp0v5 amd64 
2:8.35-7.1 [143 kB]
Get: 13 http://ftp.de.debian.org/debian/ unstable/main libpython2.7 amd64 
2.7.10-3 [1083 kB]
Get: 14 http://ftp.de.debian.org/debian/ unstable/main libexpat1-dev amd64 
2.1.0-7 [126 kB]
Get: 15 http://ftp.de.debian.org/debian/ unstable/main libpython2.7-dev amd64 
2.7.10-3 [18.7 MB]
Get: 16 http://ftp.de.debian.org/debian/ unstable/main libpython3.4-minimal 
amd64 3.4.3-8 [495 kB]
Get: 17 http://ftp.de.debian.org/debian/ unstable/main libpython3.4-stdlib 
amd64 3.4.3-8 [2057 kB]
Get: 18 http://ftp.de.debian.org/debian/ unstable/main python3.4-minimal amd64 
3.4.3-8 [1401 kB]
Get: 19 http://ftp.de.debian.org/debian/ unstable/main python3-minimal amd64 
3.4.3-4 [34.7 kB]
Get: 20 http://ftp.de.debian.org/debian/ unstable/main python3.4 amd64 3.4.3-8 
[219 kB]
Get: 21 http://ftp.de.debian.org/debian/ unstable/main libpython3-stdlib amd64 
3.4.3-4 [18.1 kB]
Get: 22 http://ftp.de.debian.org/debian/ unstable/main dh-python all 2.20150728 
[71.3 kB]
Get: 23 http://ftp.de.debian.org/debian/ unstable/main python3 amd64 3.4.3-4 
[21.1 kB]
Get: 24 http://ftp.de.debian.org/debian/ unstable/main libbuffy-dev amd64 
1.9.2-2 [78.3 kB]
Get: 25 http://ftp.de.debian.org/debian/ unstable/main libelf1 amd64 0.163-5.1 
[163 kB]
Get: 26 http://ftp.de.debian.org/debian/ unstable/main libglib2.0-data all 
2.44.1-1.1 [2241 kB]
Get: 27 http://ftp.de.debian.org/debian/ unstable/main libglib2.0-bin amd64 
2.44.1-1.1 [1391 kB]
Get: 28 http://ftp.de.debian.org/debian/ unstable/main libpcre16-3 amd64 
2:8.35-7.1 [242 kB]
Get: 29 http://ftp.de.debian.org/debian/ unstable/main libpcre32-3 amd64 
2:8.35-7.1 [233 kB]
Get: 30 http://ftp.de.debian.org/debian/ unstable/main libpcre3-dev amd64 
2:8.35-7.1 [622 kB]
Get: 31 http://ftp.de.debian.org/debian/ unstable/main pkg-config amd64 0.28-1 
[57.5 kB]
Get: 32 http://ftp.de.debian.org/debian/ unstable/main zlib1g-dev amd64 
1:1.2.8.dfsg-2+b1 [206 kB]
Get: 33 http://ftp.de.debian.org/debian/ unstable/main libglib2.0-dev amd64 
2.44.1-1.1 [2715 kB]
Get: 34 http://ftp.de.debian.org/debian/ unstable/main libpython-dev amd64 
2.7.9-1 [19.6 kB]
Get: 35 http://ftp.de.debian.org/debian/ unstable/main libpython-all-dev amd64 
2.7.9-1 [1008 B]
Get: 36 http://ftp.de.debian.org/debian/ unstable/main libwibble-dev amd64 
1.1-1+b1 [977 kB]
Get: 37 http://ftp.de.debian.org/debian/ unstable/main python-all amd64 2.7.9-1 
[996 B]
Get: 38 http://ftp.de.debian.org/debian/ unstable/main python2.7-dev amd64 
2.7.10-3 [279 kB]
Get: 39 http://ftp.de.debian.org/debian/ unstable/main python-dev amd64 2.7.9-1 
[1182 B]
Get: 40 http://ftp.de.debian.org/debian/ unstable/main python-all-dev amd64 
2.7.9-1 [1024 B]
Get: 41 http://ftp.de.debian.org/debian/ unstable/main swig2.0 amd64 2.0.12-1 
[1150 kB]
Get: 42 http://ftp.de.debian.org/debian/ unstable/main swig amd64 2.0.12-1 [285 
kB]
Fetched 40.6 MB in 1s (22.5 MB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package libpython2.7-minimal:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 20247 files and directories currently installed.)
Preparing to unpack .../libpython2.7-minimal_2.7.10-3_amd64.deb ...
Unpacking libpython2.7-minimal:amd64 (2.7.10-3) ...
Selecting previously unselected package python2.7-minimal.
Preparing to unpack .../python2.7-minimal_2.7.10-3_amd64.deb ...
Unpacking python2.7-minimal (2.7.10-3) ...
Selecting previously unselected package python-minimal.
Preparing to unpack .../python-minimal_2.7.9-1_amd64.deb ...
Unpacking python-minimal (2.7.9-1) ...
Selecting previously unselected package mime-support.
Preparing to unpack .../mime-support_3.59_all.deb ...
Unpacking mime-support (3.59) ...
Selecting previously unselected package libexpat1:amd64.
Preparing to unpack .../libexpat1_2.1.0-7_amd64.deb ...
Unpacking libexpat1:amd64 (2.1.0-7) ...
Selecting previously unselected package libssl1.0.0:amd64.
Preparing to unpack .../libssl1.0.0_1.0.2d-1_amd64.deb ...
Unpacking libssl1.0.0:amd64 (1.0.2d-1) ...
Selecting previously unselected package libpython2.7-stdlib:amd64.
Preparing to unpack .../libpython2.7-stdlib_2.7.10-3_amd64.deb ...
Unpacking libpython2.7-stdlib:amd64 (2.7.10-3) ...
Selecting previously unselected package python2.7.
Preparing to unpack .../python2.7_2.7.10-3_amd64.deb ...
Unpacking python2.7 (2.7.10-3) ...
Selecting previously unselected package libpython-stdlib:amd64.
Preparing to unpack .../libpython-stdlib_2.7.9-1_amd64.deb ...
Unpacking libpython-stdlib:amd64 (2.7.9-1) ...
Processing triggers for man-db (2.7.2-1) ...
Setting up libpython2.7-minimal:amd64 (2.7.10-3) ...
Setting up python2.7-minimal (2.7.10-3) ...
Setting up python-minimal (2.7.9-1) ...
Selecting previously unselected package python.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 21049 files and directories currently installed.)
Preparing to unpack .../python_2.7.9-1_amd64.deb ...
Unpacking python (2.7.9-1) ...
Selecting previously unselected package libmpdec2:amd64.
Preparing to unpack .../libmpdec2_2.4.1-1_amd64.deb ...
Unpacking libmpdec2:amd64 (2.4.1-1) ...
Selecting previously unselected package libpcrecpp0v5:amd64.
Preparing to unpack .../libpcrecpp0v5_2%3a8.35-7.1_amd64.deb ...
Unpacking libpcrecpp0v5:amd64 (2:8.35-7.1) ...
Selecting previously unselected package libpython2.7:amd64.
Preparing to unpack .../libpython2.7_2.7.10-3_amd64.deb ...
Unpacking libpython2.7:amd64 (2.7.10-3) ...
Selecting previously unselected package libexpat1-dev:amd64.
Preparing to unpack .../libexpat1-dev_2.1.0-7_amd64.deb ...
Unpacking libexpat1-dev:amd64 (2.1.0-7) ...
Selecting previously unselected package libpython2.7-dev:amd64.
Preparing to unpack .../libpython2.7-dev_2.7.10-3_amd64.deb ...
Unpacking libpython2.7-dev:amd64 (2.7.10-3) ...
Selecting previously unselected package libpython3.4-minimal:amd64.
Preparing to unpack .../libpython3.4-minimal_3.4.3-8_amd64.deb ...
Unpacking libpython3.4-minimal:amd64 (3.4.3-8) ...
Selecting previously unselected package libpython3.4-stdlib:amd64.
Preparing to unpack .../libpython3.4-stdlib_3.4.3-8_amd64.deb ...
Unpacking libpython3.4-stdlib:amd64 (3.4.3-8) ...
Selecting previously unselected package python3.4-minimal.
Preparing to unpack .../python3.4-minimal_3.4.3-8_amd64.deb ...
Unpacking python3.4-minimal (3.4.3-8) ...
Selecting previously unselected package python3-minimal.
Preparing to unpack .../python3-minimal_3.4.3-4_amd64.deb ...
Unpacking python3-minimal (3.4.3-4) ...
Selecting previously unselected package python3.4.
Preparing to unpack .../python3.4_3.4.3-8_amd64.deb ...
Unpacking python3.4 (3.4.3-8) ...
Selecting previously unselected package libpython3-stdlib:amd64.
Preparing to unpack .../libpython3-stdlib_3.4.3-4_amd64.deb ...
Unpacking libpython3-stdlib:amd64 (3.4.3-4) ...
Selecting previously unselected package dh-python.
Preparing to unpack .../dh-python_2.20150728_all.deb ...
Unpacking dh-python (2.20150728) ...
Processing triggers for man-db (2.7.2-1) ...
Setting up libssl1.0.0:amd64 (1.0.2d-1) ...
Setting up libpython3.4-minimal:amd64 (3.4.3-8) ...
Setting up libexpat1:amd64 (2.1.0-7) ...
Setting up python3.4-minimal (3.4.3-8) ...
Setting up python3-minimal (3.4.3-4) ...
Processing triggers for libc-bin (2.19-19) ...
Selecting previously unselected package python3.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 22164 files and directories currently installed.)
Preparing to unpack .../python3_3.4.3-4_amd64.deb ...
Unpacking python3 (3.4.3-4) ...
Selecting previously unselected package libbuffy-dev.
Preparing to unpack .../libbuffy-dev_1.9.2-2_amd64.deb ...
Unpacking libbuffy-dev (1.9.2-2) ...
Selecting previously unselected package libelf1:amd64.
Preparing to unpack .../libelf1_0.163-5.1_amd64.deb ...
Unpacking libelf1:amd64 (0.163-5.1) ...
Selecting previously unselected package libglib2.0-data.
Preparing to unpack .../libglib2.0-data_2.44.1-1.1_all.deb ...
Unpacking libglib2.0-data (2.44.1-1.1) ...
Selecting previously unselected package libglib2.0-bin.
Preparing to unpack .../libglib2.0-bin_2.44.1-1.1_amd64.deb ...
Unpacking libglib2.0-bin (2.44.1-1.1) ...
Selecting previously unselected package libpcre16-3:amd64.
Preparing to unpack .../libpcre16-3_2%3a8.35-7.1_amd64.deb ...
Unpacking libpcre16-3:amd64 (2:8.35-7.1) ...
Selecting previously unselected package libpcre32-3:amd64.
Preparing to unpack .../libpcre32-3_2%3a8.35-7.1_amd64.deb ...
Unpacking libpcre32-3:amd64 (2:8.35-7.1) ...
Selecting previously unselected package libpcre3-dev:amd64.
Preparing to unpack .../libpcre3-dev_2%3a8.35-7.1_amd64.deb ...
Unpacking libpcre3-dev:amd64 (2:8.35-7.1) ...
Selecting previously unselected package pkg-config.
Preparing to unpack .../pkg-config_0.28-1_amd64.deb ...
Unpacking pkg-config (0.28-1) ...
Selecting previously unselected package zlib1g-dev:amd64.
Preparing to unpack .../zlib1g-dev_1%3a1.2.8.dfsg-2+b1_amd64.deb ...
Unpacking zlib1g-dev:amd64 (1:1.2.8.dfsg-2+b1) ...
Selecting previously unselected package libglib2.0-dev.
Preparing to unpack .../libglib2.0-dev_2.44.1-1.1_amd64.deb ...
Unpacking libglib2.0-dev (2.44.1-1.1) ...
Selecting previously unselected package libpython-dev:amd64.
Preparing to unpack .../libpython-dev_2.7.9-1_amd64.deb ...
Unpacking libpython-dev:amd64 (2.7.9-1) ...
Selecting previously unselected package libpython-all-dev:amd64.
Preparing to unpack .../libpython-all-dev_2.7.9-1_amd64.deb ...
Unpacking libpython-all-dev:amd64 (2.7.9-1) ...
Selecting previously unselected package libwibble-dev.
Preparing to unpack .../libwibble-dev_1.1-1+b1_amd64.deb ...
Unpacking libwibble-dev (1.1-1+b1) ...
Selecting previously unselected package python-all.
Preparing to unpack .../python-all_2.7.9-1_amd64.deb ...
Unpacking python-all (2.7.9-1) ...
Selecting previously unselected package python2.7-dev.
Preparing to unpack .../python2.7-dev_2.7.10-3_amd64.deb ...
Unpacking python2.7-dev (2.7.10-3) ...
Selecting previously unselected package python-dev.
Preparing to unpack .../python-dev_2.7.9-1_amd64.deb ...
Unpacking python-dev (2.7.9-1) ...
Selecting previously unselected package python-all-dev.
Preparing to unpack .../python-all-dev_2.7.9-1_amd64.deb ...
Unpacking python-all-dev (2.7.9-1) ...
Selecting previously unselected package swig2.0.
Preparing to unpack .../swig2.0_2.0.12-1_amd64.deb ...
Unpacking swig2.0 (2.0.12-1) ...
Selecting previously unselected package swig.
Preparing to unpack .../swig_2.0.12-1_amd64.deb ...
Unpacking swig (2.0.12-1) ...
Processing triggers for man-db (2.7.2-1) ...
Processing triggers for libglib2.0-0:amd64 (2.44.1-1.1) ...
No schema files found: doing nothing.
Setting up mime-support (3.59) ...
Setting up libpython2.7-stdlib:amd64 (2.7.10-3) ...
Setting up python2.7 (2.7.10-3) ...
Setting up libpython-stdlib:amd64 (2.7.9-1) ...
Setting up python (2.7.9-1) ...
Setting up libmpdec2:amd64 (2.4.1-1) ...
Setting up libpcrecpp0v5:amd64 (2:8.35-7.1) ...
Setting up libpython2.7:amd64 (2.7.10-3) ...
Setting up libexpat1-dev:amd64 (2.1.0-7) ...
Setting up libpython2.7-dev:amd64 (2.7.10-3) ...
Setting up libpython3.4-stdlib:amd64 (3.4.3-8) ...
Setting up python3.4 (3.4.3-8) ...
Setting up libpython3-stdlib:amd64 (3.4.3-4) ...
Setting up libbuffy-dev (1.9.2-2) ...
Setting up libelf1:amd64 (0.163-5.1) ...
Setting up libglib2.0-data (2.44.1-1.1) ...
Setting up libglib2.0-bin (2.44.1-1.1) ...
Setting up libpcre16-3:amd64 (2:8.35-7.1) ...
Setting up libpcre32-3:amd64 (2:8.35-7.1) ...
Setting up libpcre3-dev:amd64 (2:8.35-7.1) ...
Setting up pkg-config (0.28-1) ...
Setting up zlib1g-dev:amd64 (1:1.2.8.dfsg-2+b1) ...
Setting up libglib2.0-dev (2.44.1-1.1) ...
Setting up libpython-dev:amd64 (2.7.9-1) ...
Setting up libpython-all-dev:amd64 (2.7.9-1) ...
Setting up libwibble-dev (1.1-1+b1) ...
Setting up python-all (2.7.9-1) ...
Setting up python2.7-dev (2.7.10-3) ...
Setting up python-dev (2.7.9-1) ...
Setting up python-all-dev (2.7.9-1) ...
Setting up swig2.0 (2.0.12-1) ...
Setting up swig (2.0.12-1) ...
Setting up python3 (3.4.3-4) ...
Setting up dh-python (2.20150728) ...
Processing triggers for libc-bin (2.19-19) ...
Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Writing extended state information...
Building tag database...
 -> Finished parsing the build-deps
Reading package lists...
Building dependency tree...
Reading state information...
fakeroot is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
I: Copying source file
I: copying [libbuffy-bindings_0.16.dsc]
I: copying [./libbuffy-bindings_0.16.tar.xz]
I: Extracting source
gpgv: keyblock resource `/tmp/buildd/.gnupg/trustedkeys.gpg': file open error
gpgv: Signature made Fri Oct 24 09:29:05 2014 GMT+12 using RSA key ID 837275A9
gpgv: Can't check signature: public key not found
dpkg-source: warning: failed to verify signature on ./libbuffy-bindings_0.16.dsc
dpkg-source: info: extracting libbuffy-bindings in libbuffy-bindings-0.16
dpkg-source: info: unpacking libbuffy-bindings_0.16.tar.xz
I: Building the package
I: Running cd tmp/buildd/*/ && env 
PATH="/usr/sbin:/usr/bin:/sbin:/bin:/usr/games" dpkg-buildpackage -us -uc  -b 
-rfakeroot
dpkg-buildpackage: source package libbuffy-bindings
dpkg-buildpackage: source version 0.16
dpkg-buildpackage: source distribution unstable
dpkg-buildpackage: source changed by Enrico Zini <enr...@debian.org>
 dpkg-source --before-build libbuffy-bindings-0.16
dpkg-buildpackage: host architecture amd64
 fakeroot debian/rules clean
dh clean --with python2
   dh_testdir
   debian/rules override_dh_auto_clean
make[1]: Entering directory '/tmp/buildd/libbuffy-bindings-0.16'
dh_auto_clean -Dperl
dh_auto_clean -Dpython
pyversions: missing X(S)-Python-Version in control file, fall back to 
debian/pyversions
pyversions: missing debian/pyversions file, fall back to supported versions
        python setup.py clean -a
running clean
'build/lib.linux-x86_64-2.7' does not exist -- can't clean it
'build/bdist.linux-x86_64' does not exist -- can't clean it
'build/scripts-2.7' does not exist -- can't clean it
        find . -name \*.pyc -exec rm {} \+
dh_auto_clean
rm -f python/buffy_wrap.cpp python/Buffy.py
make[1]: Leaving directory '/tmp/buildd/libbuffy-bindings-0.16'
   dh_clean
 debian/rules build
dh build --with python2
   dh_testdir
   debian/rules override_dh_auto_configure
make[1]: Entering directory '/tmp/buildd/libbuffy-bindings-0.16'
dh_auto_configure -Dperl
        perl Makefile.PL INSTALLDIRS=vendor "OPTIMIZE=-g -O2 
-fstack-protector-strong -Wformat -Werror=format-security -Wdate-time 
-D_FORTIFY_SOURCE=2" "LD=cc -g -O2 -fstack-protector-strong -Wformat 
-Werror=format-security -Wl,-z,relro"
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Buffy
Writing MYMETA.yml and MYMETA.json
dh_auto_configure -Dpython
make[1]: Leaving directory '/tmp/buildd/libbuffy-bindings-0.16'
   debian/rules override_dh_auto_build
make[1]: Entering directory '/tmp/buildd/libbuffy-bindings-0.16'
dh_auto_build -Dperl
        make -j1
make[2]: Entering directory '/tmp/buildd/libbuffy-bindings-0.16/perl'
swig -perl -c++ -I/usr/include -o buffy_wrap.cc ../buffy.i
/usr/include/buffy/utils/smartpointer.h:61: Warning 362: operator= ignored
/usr/include/buffy/utils/smartpointer.h:75: Warning 314: 'ref' is a perl keyword
/usr/include/buffy/config/config.h:171: Warning 314: 'dump' is a perl keyword
/usr/include/buffy/mailfolder.h:50: Warning 401: Base class 'SmartPointer< 
MailFolderImpl >' has no name as it is an empty template instantiated with 
'%template()'. Ignored.
../buffy.i:28: Warning 401: The %template directive must be written before 
'SmartPointer< MailFolderImpl >' is used as a base class and be declared with a 
name.
cp Buffy.pm blib/lib/Buffy.pm
Running Mkbootstrap for Buffy ()
chmod 644 Buffy.bs
cc -c   -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fwrapv -fno-strict-aliasing -pipe 
-I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -g -O2 
-fstack-protector-strong -Wformat -Werror=format-security -Wdate-time 
-D_FORTIFY_SOURCE=2   -DVERSION=\"0.16\" -DXS_VERSION=\"0.16\" -fPIC 
"-I/usr/lib/x86_64-linux-gnu/perl/5.20/CORE"   buffy_wrap.cc
rm -f blib/arch/auto/Buffy/Buffy.so
cc -g -O2 -fstack-protector-strong -Wformat -Werror=format-security 
-Wl,-z,relro  -shared -L/usr/local/lib -fstack-protector buffy_wrap.o  -o 
blib/arch/auto/Buffy/Buffy.so     \
   -L/usr/lib/x86_64-linux-gnu -lbuffy -lstdc++ -lwibble -lglib-2.0 -lz         
\
  
chmod 755 blib/arch/auto/Buffy/Buffy.so
/usr/bin/perl -MExtUtils::Command::MM -e 'cp_nonempty' -- Buffy.bs 
blib/arch/auto/Buffy/Buffy.bs 644
Manifying blib/man3/Buffy.3pm
make[2]: Leaving directory '/tmp/buildd/libbuffy-bindings-0.16/perl'
dh_auto_build -Dpython
pyversions: missing X(S)-Python-Version in control file, fall back to 
debian/pyversions
pyversions: missing debian/pyversions file, fall back to supported versions
        python setup.py build --force
running build
running build_ext
building '_Buffy' extension
swigging buffy.i to buffy_wrap.cpp
swig -python -c++ -I/usr/include -o buffy_wrap.cpp buffy.i
/usr/include/buffy/utils/smartpointer.h:61: Warning 362: operator= ignored
/usr/include/buffy/config/config.h:54: Warning 314: 'def' is a python keyword, 
renaming to '_def'
/usr/include/buffy/mailfolder.h:50: Warning 401: Base class 'SmartPointer< 
MailFolderImpl >' has no name as it is an empty template instantiated with 
'%template()'. Ignored.
buffy.i:28: Warning 401: The %template directive must be written before 
'SmartPointer< MailFolderImpl >' is used as a base class and be declared with a 
name.
creating build
creating build/temp.linux-x86_64-2.7
x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes 
-fno-strict-aliasing -g -O2 -fstack-protector-strong -Wformat 
-Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC 
-I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include 
-I/usr/include/python2.7 -c buffy_wrap.cpp -o 
build/temp.linux-x86_64-2.7/buffy_wrap.o
cc1plus: warning: command line option '-Wstrict-prototypes' is valid for C/ObjC 
but not for C++
creating build/lib.linux-x86_64-2.7
c++ -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z,relro 
-fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes 
-D_FORTIFY_SOURCE=2 -g -fstack-protector-strong -Wformat 
-Werror=format-security -Wl,-z,relro -g -O2 -fstack-protector-strong -Wformat 
-Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 
build/temp.linux-x86_64-2.7/buffy_wrap.o -L/usr/lib/x86_64-linux-gnu -lbuffy 
-lstdc++ -lwibble -lglib-2.0 -lz -o build/lib.linux-x86_64-2.7/_Buffy.so
running build_py
copying Buffy.py -> build/lib.linux-x86_64-2.7
make[1]: Leaving directory '/tmp/buildd/libbuffy-bindings-0.16'
   debian/rules override_dh_auto_test
make[1]: Entering directory '/tmp/buildd/libbuffy-bindings-0.16'
pyversions: missing X(S)-Python-Version in control file, fall back to 
debian/pyversions
pyversions: missing debian/pyversions file, fall back to supported versions
cd tests && ./test.pl
1..90
Can't load '../perl/blib/arch/auto/Buffy/Buffy.so' for module Buffy: 
../perl/blib/arch/auto/Buffy/Buffy.so: undefined symbol: 
_ZN6wibble9exception10AddContext9s_contextE at 
/usr/lib/x86_64-linux-gnu/perl/5.20/DynaLoader.pm line 187.
 at ../perl/Buffy.pm line 11.
Compilation failed in require at ./test.pl line 7.
BEGIN failed--compilation aborted at ./test.pl line 7.
# Looks like your test exited with 255 before it could output anything.
debian/rules:36: recipe for target 'override_dh_auto_test' failed
make[1]: *** [override_dh_auto_test] Error 255
make[1]: Leaving directory '/tmp/buildd/libbuffy-bindings-0.16'
debian/rules:9: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
E: Failed autobuilding of package
I: unmounting /sys filesystem
I: unmounting /dev/shm filesystem
I: unmounting dev/pts filesystem
I: unmounting run/shm filesystem
I: unmounting proc filesystem
I: cleaning the build env 
I: removing directory /var/cache/pbuilder/build//44072 and its subdirectories
_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to