Source: php-zipstreamer
Version: 0.5-1
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

php-zipstreamer fails to build from source in unstable/amd64:

  [..]

  make[1]: Entering directory '/tmp/buildd/php-zipstreamer-0.5'
  phpunit --configuration test/phpunit.xml
  PHPUnit 4.7.6 by Sebastian Bergmann and contributors.
  
  Runtime:        PHP 5.6.12-1
  Configuration:  /tmp/buildd/php-zipstreamer-0.5/test/phpunit.xml
  Warning:        Deprecated configuration setting "strict" used
  
  EE........................................................
  
  Time: 278 ms, Memory: 5.75Mb
  
  There were 2 errors:
  
  1) TestZipStreamer::testSendHeadersOK with data set #0 (array(),
  'application/zip', 'archive.zip', 'default headers')
  PHPUnit_Framework_Exception: PHP Fatal error:  Call to undefined
  function xdebug_get_headers() in
  /tmp/buildd/php-zipstreamer-0.5/test/ZipStreamerTest.php on line 56
  Fatal error: Call to undefined function xdebug_get_headers() in
  /tmp/buildd/php-zipstreamer-0.5/test/ZipStreamerTest.php on line 56
  
  2) TestZipStreamer::testSendHeadersOK with data set #1
  (array('file.zip', 'application/octet-stream'),
  'application/octet-stream', 'file.zip', 'specific headers')
  PHPUnit_Framework_Exception: PHP Fatal error:  Call to undefined
  function xdebug_get_headers() in
  /tmp/buildd/php-zipstreamer-0.5/test/ZipStreamerTest.php on line 56
  Fatal error: Call to undefined function xdebug_get_headers() in
  /tmp/buildd/php-zipstreamer-0.5/test/ZipStreamerTest.php on line 56
  
  FAILURES!
  Tests: 58, Assertions: 94, Errors: 2.
  debian/rules:11: recipe for target 'override_dh_auto_test' failed
  make[1]: *** [override_dh_auto_test] Error 2
  make[1]: Leaving directory '/tmp/buildd/php-zipstreamer-0.5'
  debian/rules:3: recipe for target 'build' failed
  make: *** [build] Error 2
  dpkg-buildpackage: error: debian/rules build gave error exit status 2

  [..]

The full build log is attached or can be viewed here:

    
https://reproducible.debian.net/logs/unstable/amd64/php-zipstreamer_0.5-1.build1.log.gz


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-
I: using fakeroot in build.
I: pbuilder: network access will be disabled during build
I: Current time: Fri Aug 21 06:00:32 GMT+12 2015
I: pbuilder-time-stamp: 1440180032
I: Building the build Environment
I: extracting base tarball [/var/cache/pbuilder/unstable-reproducible-base.tgz]
I: creating local configuration
I: copying local configuration
I: mounting /proc filesystem
I: mounting /run/shm filesystem
I: mounting /dev/pts filesystem
I: Mounting /dev/shm
I: Mounting /sys
I: policy-rc.d already exists
I: Installing the build-deps
 -> Attempting to satisfy build-dependencies
 -> Creating pbuilder-satisfydepends-dummy package
Package: pbuilder-satisfydepends-dummy
Version: 0.invalid.0
Architecture: amd64
Maintainer: Debian Pbuilder Team <pbuilder-ma...@lists.alioth.debian.org>
Description: Dummy package to satisfy dependencies with aptitude - created by 
pbuilder
 This package was created automatically by pbuilder to satisfy the
 build-dependencies of the package being currently built.
Depends: debhelper (>= 9), php5-xdebug, phpab, phpunit, pkg-php-tools (>= 1.7~)
dpkg-deb: building package 'pbuilder-satisfydepends-dummy' in 
'/tmp/satisfydepends-aptitude/pbuilder-satisfydepends-dummy.deb'.
Selecting previously unselected package pbuilder-satisfydepends-dummy.
(Reading database ... 20247 files and directories currently installed.)
Preparing to unpack .../pbuilder-satisfydepends-dummy.deb ...
Unpacking pbuilder-satisfydepends-dummy (0.invalid.0) ...
dpkg: pbuilder-satisfydepends-dummy: dependency problems, but configuring 
anyway as you requested:
 pbuilder-satisfydepends-dummy depends on php5-xdebug; however:
  Package php5-xdebug is not installed.
 pbuilder-satisfydepends-dummy depends on phpab; however:
  Package phpab is not installed.
 pbuilder-satisfydepends-dummy depends on phpunit; however:
  Package phpunit is not installed.
 pbuilder-satisfydepends-dummy depends on pkg-php-tools (>= 1.7~); however:
  Package pkg-php-tools is not installed.

Setting up pbuilder-satisfydepends-dummy (0.invalid.0) ...
Reading package lists...
Building dependency tree...
Reading state information...
Initializing package states...
Writing extended state information...
Building tag database...
The following NEW packages will be installed:
  libbsd0{a} libedit2{a} libgssapi-krb5-2{a} libjs-bootstrap{a} 
  libjs-jquery{a} libjs-twitter-bootstrap{a} libjson-c2{a} libk5crypto3{a} 
  libkeyutils1{a} libkrb5-3{a} libkrb5support0{a} libonig2{a} 
  libperl4-corelibs-perl{a} libqdbm14{a} libssl1.0.0{a} lsof{a} 
  mime-support{a} php-codecoverage{a} php-directory-scanner{a} 
  php-doctrine-instantiator{a} php-file-iterator{a} php-pear{a} 
  php-phpdocumentor-reflection-docblock{a} php-phpspec-prophecy{a} 
  php-symfony-yaml{a} php-text-template{a} php-timer{a} php-token-stream{a} 
  php-zeta-base{a} php-zeta-console-tools{a} php5-cli{a} php5-common{a} 
  php5-json{a} php5-xdebug{a} phpab{a} phpunit{a} phpunit-comparator{a} 
  phpunit-diff{a} phpunit-environment{a} phpunit-exporter{a} 
  phpunit-global-state{a} phpunit-mock-object{a} 
  phpunit-recursion-context{a} phpunit-version{a} pkg-php-tools{a} 
  psmisc{a} ucf{a} 
0 packages upgraded, 47 newly installed, 0 to remove and 0 not upgraded.
Need to get 8306 kB of archives. After unpacking 29.8 MB will be used.
Writing extended state information...
Get: 1 http://ftp.de.debian.org/debian/ unstable/main libjson-c2 amd64 0.11-4 
[24.8 kB]
Get: 2 http://ftp.de.debian.org/debian/ unstable/main libbsd0 amd64 0.7.0-2 
[67.9 kB]
Get: 3 http://ftp.de.debian.org/debian/ unstable/main libedit2 amd64 
3.1-20150325-1 [86.2 kB]
Get: 4 http://ftp.de.debian.org/debian/ unstable/main libkeyutils1 amd64 
1.5.9-5+b1 [12.0 kB]
Get: 5 http://ftp.de.debian.org/debian/ unstable/main libonig2 amd64 5.9.6-1 
[118 kB]
Get: 6 http://ftp.de.debian.org/debian/ unstable/main libjs-bootstrap all 
3.3.5+dfsg-1 [258 kB]
Get: 7 http://ftp.de.debian.org/debian/ unstable/main libjs-jquery all 
1.7.2+dfsg-3.2 [97.5 kB]
Get: 8 http://ftp.de.debian.org/debian/ unstable/main libjs-twitter-bootstrap 
all 2.0.2+dfsg-5 [98.2 kB]
Get: 9 http://ftp.de.debian.org/debian/ unstable/main psmisc amd64 22.21-2 [119 
kB]
Get: 10 http://ftp.de.debian.org/debian/ unstable/main libperl4-corelibs-perl 
all 0.003-2 [38.0 kB]
Get: 11 http://ftp.de.debian.org/debian/ unstable/main lsof amd64 4.86+dfsg-1 
[316 kB]
Get: 12 http://ftp.de.debian.org/debian/ unstable/main ucf all 3.0030 [69.7 kB]
Get: 13 http://ftp.de.debian.org/debian/ unstable/main php5-common amd64 
5.6.12+dfsg-1 [718 kB]
Get: 14 http://ftp.de.debian.org/debian/ unstable/main phpunit-environment all 
1.2.2-2 [5684 B]
Get: 15 http://ftp.de.debian.org/debian/ unstable/main php-file-iterator all 
1.4.0-2 [5682 B]
Get: 16 http://ftp.de.debian.org/debian/ unstable/main php-token-stream all 
1.4.3-1 [10.4 kB]
Get: 17 http://ftp.de.debian.org/debian/ unstable/main libkrb5support0 amd64 
1.13.2+dfsg-2 [59.8 kB]
Get: 18 http://ftp.de.debian.org/debian/ unstable/main libk5crypto3 amd64 
1.13.2+dfsg-2 [115 kB]
Get: 19 http://ftp.de.debian.org/debian/ unstable/main libkrb5-3 amd64 
1.13.2+dfsg-2 [308 kB]
Get: 20 http://ftp.de.debian.org/debian/ unstable/main libgssapi-krb5-2 amd64 
1.13.2+dfsg-2 [152 kB]
Get: 21 http://ftp.de.debian.org/debian/ unstable/main libqdbm14 amd64 
1.8.78-5+b3 [118 kB]
Get: 22 http://ftp.de.debian.org/debian/ unstable/main libssl1.0.0 amd64 
1.0.2d-1 [1274 kB]
Get: 23 http://ftp.de.debian.org/debian/ unstable/main mime-support all 3.59 
[36.4 kB]
Get: 24 http://ftp.de.debian.org/debian/ unstable/main php5-json amd64 1.3.7-1 
[18.5 kB]
Get: 25 http://ftp.de.debian.org/debian/ unstable/main php5-cli amd64 
5.6.12+dfsg-1 [2177 kB]
Get: 26 http://ftp.de.debian.org/debian/ unstable/main php-pear all 
5.6.12+dfsg-1 [268 kB]
Get: 27 http://ftp.de.debian.org/debian/ unstable/main php-text-template all 
1.2.0-1 [5800 B]
Get: 28 http://ftp.de.debian.org/debian/ unstable/main phpunit-version all 
1.0.6-1 [4360 B]
Get: 29 http://ftp.de.debian.org/debian/ unstable/main php-codecoverage all 
2.1.7+dfsg-1 [134 kB]
Get: 30 http://ftp.de.debian.org/debian/ unstable/main php-directory-scanner 
all 1.3.1-2 [7536 B]
Get: 31 http://ftp.de.debian.org/debian/ unstable/main 
php-doctrine-instantiator all 1.0.5-1 [7072 B]
Get: 32 http://ftp.de.debian.org/debian/ unstable/main 
php-phpdocumentor-reflection-docblock all 2.0.4-1 [17.8 kB]
Get: 33 http://ftp.de.debian.org/debian/ unstable/main phpunit-diff all 1.3.0-2 
[8310 B]
Get: 34 http://ftp.de.debian.org/debian/ unstable/main 
phpunit-recursion-context all 1.0.0-1 [3782 B]
Get: 35 http://ftp.de.debian.org/debian/ unstable/main phpunit-exporter all 
1.2.0-2 [6102 B]
Get: 36 http://ftp.de.debian.org/debian/ unstable/main phpunit-comparator all 
1.1.1-2 [8644 B]
Get: 37 http://ftp.de.debian.org/debian/ unstable/main php-phpspec-prophecy all 
1.4.1-1 [34.3 kB]
Get: 38 http://ftp.de.debian.org/debian/ unstable/main php-symfony-yaml all 
2.7.1+dfsg-1 [25.1 kB]
Get: 39 http://ftp.de.debian.org/debian/ unstable/main php-timer all 1.0.6-1 
[4360 B]
Get: 40 http://ftp.de.debian.org/debian/ unstable/main php-zeta-base all 1.9-1 
[218 kB]
Get: 41 http://ftp.de.debian.org/debian/ unstable/main php-zeta-console-tools 
all 1.7-1 [759 kB]
Get: 42 http://ftp.de.debian.org/debian/ unstable/main php5-xdebug amd64 
2.3.3-1 [298 kB]
Get: 43 http://ftp.de.debian.org/debian/ unstable/main phpab all 1.19.0-1 [25.0 
kB]
Get: 44 http://ftp.de.debian.org/debian/ unstable/main phpunit-mock-object all 
2.3.5-1 [21.7 kB]
Get: 45 http://ftp.de.debian.org/debian/ unstable/main phpunit-global-state all 
1.0.0-1 [5440 B]
Get: 46 http://ftp.de.debian.org/debian/ unstable/main phpunit all 4.7.6-1 
[99.7 kB]
Get: 47 http://ftp.de.debian.org/debian/ unstable/main pkg-php-tools all 1.30 
[37.5 kB]
Fetched 8306 kB in 0s (16.1 MB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package libjson-c2:amd64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 20247 files and directories currently installed.)
Preparing to unpack .../libjson-c2_0.11-4_amd64.deb ...
Unpacking libjson-c2:amd64 (0.11-4) ...
Selecting previously unselected package libbsd0:amd64.
Preparing to unpack .../libbsd0_0.7.0-2_amd64.deb ...
Unpacking libbsd0:amd64 (0.7.0-2) ...
Selecting previously unselected package libedit2:amd64.
Preparing to unpack .../libedit2_3.1-20150325-1_amd64.deb ...
Unpacking libedit2:amd64 (3.1-20150325-1) ...
Selecting previously unselected package libkeyutils1:amd64.
Preparing to unpack .../libkeyutils1_1.5.9-5+b1_amd64.deb ...
Unpacking libkeyutils1:amd64 (1.5.9-5+b1) ...
Selecting previously unselected package libonig2:amd64.
Preparing to unpack .../libonig2_5.9.6-1_amd64.deb ...
Unpacking libonig2:amd64 (5.9.6-1) ...
Selecting previously unselected package libjs-bootstrap.
Preparing to unpack .../libjs-bootstrap_3.3.5+dfsg-1_all.deb ...
Unpacking libjs-bootstrap (3.3.5+dfsg-1) ...
Selecting previously unselected package libjs-jquery.
Preparing to unpack .../libjs-jquery_1.7.2+dfsg-3.2_all.deb ...
Unpacking libjs-jquery (1.7.2+dfsg-3.2) ...
Selecting previously unselected package libjs-twitter-bootstrap.
Preparing to unpack .../libjs-twitter-bootstrap_2.0.2+dfsg-5_all.deb ...
Unpacking libjs-twitter-bootstrap (2.0.2+dfsg-5) ...
Selecting previously unselected package psmisc.
Preparing to unpack .../psmisc_22.21-2_amd64.deb ...
Unpacking psmisc (22.21-2) ...
Selecting previously unselected package libperl4-corelibs-perl.
Preparing to unpack .../libperl4-corelibs-perl_0.003-2_all.deb ...
Unpacking libperl4-corelibs-perl (0.003-2) ...
Selecting previously unselected package lsof.
Preparing to unpack .../lsof_4.86+dfsg-1_amd64.deb ...
Unpacking lsof (4.86+dfsg-1) ...
Selecting previously unselected package ucf.
Preparing to unpack .../archives/ucf_3.0030_all.deb ...
Moving old data out of the way
Unpacking ucf (3.0030) ...
Selecting previously unselected package php5-common.
Preparing to unpack .../php5-common_5.6.12+dfsg-1_amd64.deb ...
Unpacking php5-common (5.6.12+dfsg-1) ...
Selecting previously unselected package phpunit-environment.
Preparing to unpack .../phpunit-environment_1.2.2-2_all.deb ...
Unpacking phpunit-environment (1.2.2-2) ...
Selecting previously unselected package php-file-iterator.
Preparing to unpack .../php-file-iterator_1.4.0-2_all.deb ...
Unpacking php-file-iterator (1.4.0-2) ...
Selecting previously unselected package php-token-stream.
Preparing to unpack .../php-token-stream_1.4.3-1_all.deb ...
Unpacking php-token-stream (1.4.3-1) ...
Selecting previously unselected package libkrb5support0:amd64.
Preparing to unpack .../libkrb5support0_1.13.2+dfsg-2_amd64.deb ...
Unpacking libkrb5support0:amd64 (1.13.2+dfsg-2) ...
Selecting previously unselected package libk5crypto3:amd64.
Preparing to unpack .../libk5crypto3_1.13.2+dfsg-2_amd64.deb ...
Unpacking libk5crypto3:amd64 (1.13.2+dfsg-2) ...
Selecting previously unselected package libkrb5-3:amd64.
Preparing to unpack .../libkrb5-3_1.13.2+dfsg-2_amd64.deb ...
Unpacking libkrb5-3:amd64 (1.13.2+dfsg-2) ...
Selecting previously unselected package libgssapi-krb5-2:amd64.
Preparing to unpack .../libgssapi-krb5-2_1.13.2+dfsg-2_amd64.deb ...
Unpacking libgssapi-krb5-2:amd64 (1.13.2+dfsg-2) ...
Selecting previously unselected package libqdbm14.
Preparing to unpack .../libqdbm14_1.8.78-5+b3_amd64.deb ...
Unpacking libqdbm14 (1.8.78-5+b3) ...
Selecting previously unselected package libssl1.0.0:amd64.
Preparing to unpack .../libssl1.0.0_1.0.2d-1_amd64.deb ...
Unpacking libssl1.0.0:amd64 (1.0.2d-1) ...
Selecting previously unselected package mime-support.
Preparing to unpack .../mime-support_3.59_all.deb ...
Unpacking mime-support (3.59) ...
Selecting previously unselected package php5-json.
Preparing to unpack .../php5-json_1.3.7-1_amd64.deb ...
Unpacking php5-json (1.3.7-1) ...
Selecting previously unselected package php5-cli.
Preparing to unpack .../php5-cli_5.6.12+dfsg-1_amd64.deb ...
Unpacking php5-cli (5.6.12+dfsg-1) ...
Selecting previously unselected package php-pear.
Preparing to unpack .../php-pear_5.6.12+dfsg-1_all.deb ...
Unpacking php-pear (5.6.12+dfsg-1) ...
Selecting previously unselected package php-text-template.
Preparing to unpack .../php-text-template_1.2.0-1_all.deb ...
Unpacking php-text-template (1.2.0-1) ...
Selecting previously unselected package phpunit-version.
Preparing to unpack .../phpunit-version_1.0.6-1_all.deb ...
Unpacking phpunit-version (1.0.6-1) ...
Selecting previously unselected package php-codecoverage.
Preparing to unpack .../php-codecoverage_2.1.7+dfsg-1_all.deb ...
Unpacking php-codecoverage (2.1.7+dfsg-1) ...
Selecting previously unselected package php-directory-scanner.
Preparing to unpack .../php-directory-scanner_1.3.1-2_all.deb ...
Unpacking php-directory-scanner (1.3.1-2) ...
Selecting previously unselected package php-doctrine-instantiator.
Preparing to unpack .../php-doctrine-instantiator_1.0.5-1_all.deb ...
Unpacking php-doctrine-instantiator (1.0.5-1) ...
Selecting previously unselected package php-phpdocumentor-reflection-docblock.
Preparing to unpack .../php-phpdocumentor-reflection-docblock_2.0.4-1_all.deb 
...
Unpacking php-phpdocumentor-reflection-docblock (2.0.4-1) ...
Selecting previously unselected package phpunit-diff.
Preparing to unpack .../phpunit-diff_1.3.0-2_all.deb ...
Unpacking phpunit-diff (1.3.0-2) ...
Selecting previously unselected package phpunit-recursion-context.
Preparing to unpack .../phpunit-recursion-context_1.0.0-1_all.deb ...
Unpacking phpunit-recursion-context (1.0.0-1) ...
Selecting previously unselected package phpunit-exporter.
Preparing to unpack .../phpunit-exporter_1.2.0-2_all.deb ...
Unpacking phpunit-exporter (1.2.0-2) ...
Selecting previously unselected package phpunit-comparator.
Preparing to unpack .../phpunit-comparator_1.1.1-2_all.deb ...
Unpacking phpunit-comparator (1.1.1-2) ...
Selecting previously unselected package php-phpspec-prophecy.
Preparing to unpack .../php-phpspec-prophecy_1.4.1-1_all.deb ...
Unpacking php-phpspec-prophecy (1.4.1-1) ...
Selecting previously unselected package php-symfony-yaml.
Preparing to unpack .../php-symfony-yaml_2.7.1+dfsg-1_all.deb ...
Unpacking php-symfony-yaml (2.7.1+dfsg-1) ...
Selecting previously unselected package php-timer.
Preparing to unpack .../php-timer_1.0.6-1_all.deb ...
Unpacking php-timer (1.0.6-1) ...
Selecting previously unselected package php-zeta-base.
Preparing to unpack .../php-zeta-base_1.9-1_all.deb ...
Unpacking php-zeta-base (1.9-1) ...
Selecting previously unselected package php-zeta-console-tools.
Preparing to unpack .../php-zeta-console-tools_1.7-1_all.deb ...
Unpacking php-zeta-console-tools (1.7-1) ...
Selecting previously unselected package php5-xdebug.
Preparing to unpack .../php5-xdebug_2.3.3-1_amd64.deb ...
Unpacking php5-xdebug (2.3.3-1) ...
Selecting previously unselected package phpab.
Preparing to unpack .../phpab_1.19.0-1_all.deb ...
Unpacking phpab (1.19.0-1) ...
Selecting previously unselected package phpunit-mock-object.
Preparing to unpack .../phpunit-mock-object_2.3.5-1_all.deb ...
Unpacking phpunit-mock-object (2.3.5-1) ...
Selecting previously unselected package phpunit-global-state.
Preparing to unpack .../phpunit-global-state_1.0.0-1_all.deb ...
Unpacking phpunit-global-state (1.0.0-1) ...
Selecting previously unselected package phpunit.
Preparing to unpack .../phpunit_4.7.6-1_all.deb ...
Unpacking phpunit (4.7.6-1) ...
Selecting previously unselected package pkg-php-tools.
Preparing to unpack .../pkg-php-tools_1.30_all.deb ...
Unpacking pkg-php-tools (1.30) ...
Processing triggers for man-db (2.7.2-1) ...
Setting up libjson-c2:amd64 (0.11-4) ...
Setting up libbsd0:amd64 (0.7.0-2) ...
Setting up libedit2:amd64 (3.1-20150325-1) ...
Setting up libkeyutils1:amd64 (1.5.9-5+b1) ...
Setting up libonig2:amd64 (5.9.6-1) ...
Setting up libjs-bootstrap (3.3.5+dfsg-1) ...
Setting up libjs-jquery (1.7.2+dfsg-3.2) ...
Setting up libjs-twitter-bootstrap (2.0.2+dfsg-5) ...
Setting up psmisc (22.21-2) ...
Setting up libperl4-corelibs-perl (0.003-2) ...
Setting up lsof (4.86+dfsg-1) ...
Setting up ucf (3.0030) ...
Setting up php5-common (5.6.12+dfsg-1) ...

Creating config file /etc/php5/mods-available/pdo.ini with new version
php5_invoke: Enable module pdo for cli SAPI

Creating config file /etc/php5/mods-available/opcache.ini with new version
php5_invoke: Enable module opcache for cli SAPI
Setting up phpunit-environment (1.2.2-2) ...
Setting up php-file-iterator (1.4.0-2) ...
Setting up php-token-stream (1.4.3-1) ...
Setting up libkrb5support0:amd64 (1.13.2+dfsg-2) ...
Setting up libk5crypto3:amd64 (1.13.2+dfsg-2) ...
Setting up libkrb5-3:amd64 (1.13.2+dfsg-2) ...
Setting up libgssapi-krb5-2:amd64 (1.13.2+dfsg-2) ...
Setting up libqdbm14 (1.8.78-5+b3) ...
Setting up libssl1.0.0:amd64 (1.0.2d-1) ...
Setting up mime-support (3.59) ...
Setting up php5-json (1.3.7-1) ...
php5_invoke: Enable module json for cli SAPI
Setting up php5-cli (5.6.12+dfsg-1) ...
update-alternatives: using /usr/bin/php5 to provide /usr/bin/php (php) in auto 
mode

Creating config file /etc/php5/cli/php.ini with new version
Setting up php-pear (5.6.12+dfsg-1) ...
Setting up php-text-template (1.2.0-1) ...
Setting up phpunit-version (1.0.6-1) ...
Setting up php-codecoverage (2.1.7+dfsg-1) ...
Setting up php-directory-scanner (1.3.1-2) ...
Setting up php-doctrine-instantiator (1.0.5-1) ...
Setting up php-phpdocumentor-reflection-docblock (2.0.4-1) ...
Setting up phpunit-diff (1.3.0-2) ...
Setting up phpunit-recursion-context (1.0.0-1) ...
Setting up phpunit-exporter (1.2.0-2) ...
Setting up phpunit-comparator (1.1.1-2) ...
Setting up php-phpspec-prophecy (1.4.1-1) ...
Setting up php-symfony-yaml (2.7.1+dfsg-1) ...
Setting up php-timer (1.0.6-1) ...
Setting up php-zeta-base (1.9-1) ...
Setting up php-zeta-console-tools (1.7-1) ...
Setting up php5-xdebug (2.3.3-1) ...
Setting up phpab (1.19.0-1) ...
Setting up phpunit-mock-object (2.3.5-1) ...
Setting up phpunit-global-state (1.0.0-1) ...
Setting up phpunit (4.7.6-1) ...
Setting up pkg-php-tools (1.30) ...
Processing triggers for libc-bin (2.19-19) ...
Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Writing extended state information...
Building tag database...
 -> Finished parsing the build-deps
Reading package lists...
Building dependency tree...
Reading state information...
fakeroot is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
I: Copying source file
I: copying [php-zipstreamer_0.5-1.dsc]
I: copying [./php-zipstreamer_0.5.orig.tar.gz]
I: copying [./php-zipstreamer_0.5-1.debian.tar.xz]
I: Extracting source
gpgv: keyblock resource `/tmp/buildd/.gnupg/trustedkeys.gpg': file open error
gpgv: Signature made Tue Mar 31 06:50:06 2015 GMT+12 using RSA key ID 44F6BD3C
gpgv: Can't check signature: public key not found
dpkg-source: warning: failed to verify signature on ./php-zipstreamer_0.5-1.dsc
dpkg-source: info: extracting php-zipstreamer in php-zipstreamer-0.5
dpkg-source: info: unpacking php-zipstreamer_0.5.orig.tar.gz
dpkg-source: info: unpacking php-zipstreamer_0.5-1.debian.tar.xz
I: Building the package
I: Running cd tmp/buildd/*/ && env 
PATH="/usr/sbin:/usr/bin:/sbin:/bin:/usr/games" dpkg-buildpackage -us -uc  -b 
-rfakeroot
dpkg-buildpackage: source package php-zipstreamer
dpkg-buildpackage: source version 0.5-1
dpkg-buildpackage: source distribution unstable
dpkg-buildpackage: source changed by David Prévot <taf...@debian.org>
 dpkg-source --before-build php-zipstreamer-0.5
dpkg-buildpackage: host architecture amd64
 fakeroot debian/rules clean
dh clean --with phpcomposer
   dh_testdir
   dh_auto_clean
   dh_clean
 debian/rules build
dh build --with phpcomposer
   dh_testdir
   dh_auto_configure
   debian/rules override_dh_auto_build
make[1]: Entering directory '/tmp/buildd/php-zipstreamer-0.5'
dh_auto_build
phpab --output src/autoload.php src
phpab %development% - Copyright (C) 2009 - 2015 by Arne Blankerts

Scanning directory src

Autoload file src/autoload.php generated.

make[1]: Leaving directory '/tmp/buildd/php-zipstreamer-0.5'
   debian/rules override_dh_auto_test
make[1]: Entering directory '/tmp/buildd/php-zipstreamer-0.5'
phpunit --configuration test/phpunit.xml
PHPUnit 4.7.6 by Sebastian Bergmann and contributors.

Runtime:        PHP 5.6.12-1
Configuration:  /tmp/buildd/php-zipstreamer-0.5/test/phpunit.xml
Warning:        Deprecated configuration setting "strict" used

EE........................................................

Time: 278 ms, Memory: 5.75Mb

There were 2 errors:

1) TestZipStreamer::testSendHeadersOK with data set #0 (array(), 
'application/zip', 'archive.zip', 'default headers')
PHPUnit_Framework_Exception: PHP Fatal error:  Call to undefined function 
xdebug_get_headers() in 
/tmp/buildd/php-zipstreamer-0.5/test/ZipStreamerTest.php on line 56
Fatal error: Call to undefined function xdebug_get_headers() in 
/tmp/buildd/php-zipstreamer-0.5/test/ZipStreamerTest.php on line 56

2) TestZipStreamer::testSendHeadersOK with data set #1 (array('file.zip', 
'application/octet-stream'), 'application/octet-stream', 'file.zip', 'specific 
headers')
PHPUnit_Framework_Exception: PHP Fatal error:  Call to undefined function 
xdebug_get_headers() in 
/tmp/buildd/php-zipstreamer-0.5/test/ZipStreamerTest.php on line 56
Fatal error: Call to undefined function xdebug_get_headers() in 
/tmp/buildd/php-zipstreamer-0.5/test/ZipStreamerTest.php on line 56

FAILURES!
Tests: 58, Assertions: 94, Errors: 2.
debian/rules:11: recipe for target 'override_dh_auto_test' failed
make[1]: *** [override_dh_auto_test] Error 2
make[1]: Leaving directory '/tmp/buildd/php-zipstreamer-0.5'
debian/rules:3: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
E: Failed autobuilding of package
I: unmounting /sys filesystem
I: unmounting /dev/shm filesystem
I: unmounting dev/pts filesystem
I: unmounting run/shm filesystem
I: unmounting proc filesystem
I: cleaning the build env 
I: removing directory /var/cache/pbuilder/build//12443 and its subdirectories
_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to