Package: libmail-gnupg-perl
Version: 0.21-1
Severity: serious
Tags: upstream sid stretch
Usertags: ftbfs

As detected by the reproducible builds CI system, this package fails to
build on current sid. It regressed with the upgrade of gnupg-agent
from 2.0.28-3 to 2.1.7-2.

The test gets skipped at least on my sbuild instance because of a
nonexistent HOME, but I can reproduce the failure when building

This is
which has a proposed patch.

When this is fixed, gnupg-agent should probably gain a Breaks entry for
the earlier versions to make sure partial upgrades work.

   t/agent.t ................ 
   gpg: keyring `mgtVSdM_/secring.gpg' created
   gpg: keyring `mgtVSdM_/pubring.gpg' created
   gpg: key EFEA4EAD: secret key imported
   gpg: mgtVSdM_/trustdb.gpg: trustdb created
   gpg: key EFEA4EAD marked as ultimately trusted
   gpg: key EFEA4EAD: public key "Mail::GnuPG Test Key <m...@gnupg.dom>" 
   gpg: key EFEA4EAD: "Mail::GnuPG Test Key <m...@gnupg.dom>" 1 new signature
   gpg: Total number processed: 2
   gpg:               imported: 1
   gpg:         new signatures: 1
   gpg:       secret keys read: 1
   gpg:   secret keys imported: 1
   gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
   gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
   ok 1 - An object of class 'Mail::GnuPG' isa 'Mail::GnuPG'
   not ok 2
   #   Failed test at t/agent.t line 78.
   #          got: '2'
   #     expected: '0'
   not ok 3
   #   Failed test at t/agent.t line 81.
   #          got: '2'
   #     expected: '0'
   not ok 4
   #   Failed test at t/agent.t line 82.
   #          got: undef
   #     expected: 'EFEA4EAD'
   not ok 5
   #   Failed test at t/agent.t line 83.
   #          got: undef
   #     expected: 'Mail::GnuPG Test Key <m...@gnupg.dom>'
   ok 6
   ok 7
   not ok 8
   #   Failed test at t/agent.t line 92.
   #          got: '2'
   #     expected: '0'
   Unknown Content-Type or no PGP message in body at 
/home/niko/tmp/libmail-gnupg-perl-0.21/blib/lib/Mail/ line 402.
   # Looks like you planned 20 tests but ran 8.
   # Looks like you failed 5 tests of 8 run.
   # Looks like your test exited with 2 just after 8.
   Dubious, test returned 2 (wstat 512, 0x200)
   Failed 17/20 subtests 
Niko Tyni

Reproducible-builds mailing list

Reply via email to