Package: bochs
Version: 2.6-4
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org
Tags: patch

Hi,

The configure script checks `uname -r` and checks for 2.6 or 3.x, etc.,
rejecting any others. but the latest kernel version at the time of
writing is 4.2.3. Severity serious as this therefore will FTBFS under
your typical developer system running sid.

A patch is attached that reverses this logic, rejecting 2.2 and
essentially allowing anything 2.6+.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-
diff --git a/configure.in b/configure.in
index f6f1513..aadb82b 100644
--- a/configure.in
+++ b/configure.in
@@ -713,17 +713,17 @@ AC_ARG_ENABLE(pcidev,
           AC_MSG_NOTICE([Linux detected as host for PCI host device mapping])
           linux_version=`uname -r`
          case "$linux_version" in
+               2.2*)
+                       AC_MSG_ERROR([Linux kernel 2.4, 2.6 or 3.x is required 
for PCI host device mapping])
+               ;;
                2.4*)
                        PCIDEV_MODULE_MAKE_ALL="all-kernel24"
                        KERNEL_MODULE_SUFFIX="o"
                ;;
-               2.6*|3.*)
+               *)
                        PCIDEV_MODULE_MAKE_ALL="all-kernel26"
                        KERNEL_MODULE_SUFFIX="ko"
                ;;
-               *)
-                       AC_MSG_ERROR([Linux kernel 2.4, 2.6 or 3.x is required 
for PCI host device mapping])
-               ;;
          esac
          KERNELDIR="/lib/modules/$linux_version/build"
          LSMOD="lsmod"
_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to