Source: ruby-state-machines
Version: 0.4.0-1
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

ruby-state-machines fails to build from source in unstable/amd64:

  [..]

  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/matcher_helpers.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/matcher_helpers.rb
  install -D -m644
  
/build/ruby-state-machines-0.4.0/lib/state_machines/core_ext/class/state_machine.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/core_ext/class/state_machine.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/event_collection.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/event_collection.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/callback.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/callback.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/error.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/error.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/eval_helpers.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/eval_helpers.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/integrations/base.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/integrations/base.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/event.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/event.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/node_collection.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/node_collection.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/core.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/core.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/path_collection.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/path_collection.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/state_context.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/state_context.rb
  install -D -m644
  /build/ruby-state-machines-0.4.0/lib/state_machines/state.rb
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby/state_machines/state.rb
  
  
┌──────────────────────────────────────────────────────────────────────────────â”
  │ Install Rubygems integration metadata                             
            │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  generating gemspec at
  
/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/share/rubygems-integration/all/specifications/state_machines-0.4.0.gemspec
  /usr/bin/ruby2.2 /usr/bin/gem2deb-test-runner
  
  
┌──────────────────────────────────────────────────────────────────────────────â”
  │ Run tests for ruby2.2 from debian/ruby-tests.rake                 
            │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  
RUBYLIB=/build/ruby-state-machines-0.4.0/debian/ruby-state-machines/usr/lib/ruby/vendor_ruby:.
  rake2.2 -f debian/ruby-tests.rake
  /usr/bin/ruby2.2 -I"test" 
  "/usr/lib/ruby/vendor_ruby/rake/rake_test_loader.rb"
  "test/functional/auto_shop_available_test.rb"
  "test/functional/auto_shop_busy_test.rb"
  "test/functional/car_backing_up_test.rb" "test/functional/car_test.rb"
  "test/functional/motorcycle_test.rb"
  "test/functional/traffic_light_caution_test.rb"
  "test/functional/traffic_light_proceed_test.rb"
  "test/functional/traffic_light_stop_test.rb"
  "test/functional/vehicle_first_gear_test.rb"
  "test/functional/vehicle_idling_test.rb"
  "test/functional/vehicle_locked_test.rb"
  "test/functional/vehicle_parked_test.rb"
  "test/functional/vehicle_repaired_test.rb"
  "test/functional/vehicle_second_gear_test.rb"
  "test/functional/vehicle_stalled_test.rb"
  "test/functional/vehicle_test.rb"
  "test/functional/vehicle_third_gear_test.rb"
  "test/functional/vehicle_unsaved_test.rb"
  "test/functional/vehicle_with_event_attributes_test.rb"
  "test/functional/vehicle_with_parallel_events_test.rb" -v
  /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
  `require': cannot load such file -- minitest/reporters (LoadError)
        from
        /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
        `require'
        from /build/ruby-state-machines-0.4.0/test/test_helper.rb:7:in
        `<top (required)>'
        from
        
/build/ruby-state-machines-0.4.0/test/functional/auto_shop_available_test.rb:1:in
        `require_relative'
        from
        
/build/ruby-state-machines-0.4.0/test/functional/auto_shop_available_test.rb:1:in
        `<top (required)>'
        from
        /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
        `require'
        from
        /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in
        `require'
        from /usr/lib/ruby/vendor_ruby/rake/rake_test_loader.rb:15:in
        `block in <main>'
        from /usr/lib/ruby/vendor_ruby/rake/rake_test_loader.rb:4:in
        `select'
        from /usr/lib/ruby/vendor_ruby/rake/rake_test_loader.rb:4:in
        `<main>'
  rake aborted!
  Command failed with status (1): [ruby -I"test" 
  "/usr/lib/ruby/vendor_ruby/rake/rake_test_loader.rb"
  "test/functional/auto_shop_available_test.rb"
  "test/functional/auto_shop_busy_test.rb"
  "test/functional/car_backing_up_test.rb" "test/functional/car_test.rb"
  "test/functional/motorcycle_test.rb"
  "test/functional/traffic_light_caution_test.rb"
  "test/functional/traffic_light_proceed_test.rb"
  "test/functional/traffic_light_stop_test.rb"
  "test/functional/vehicle_first_gear_test.rb"
  "test/functional/vehicle_idling_test.rb"
  "test/functional/vehicle_locked_test.rb"
  "test/functional/vehicle_parked_test.rb"
  "test/functional/vehicle_repaired_test.rb"
  "test/functional/vehicle_second_gear_test.rb"
  "test/functional/vehicle_stalled_test.rb"
  "test/functional/vehicle_test.rb"
  "test/functional/vehicle_third_gear_test.rb"
  "test/functional/vehicle_unsaved_test.rb"
  "test/functional/vehicle_with_event_attributes_test.rb"
  "test/functional/vehicle_with_parallel_events_test.rb" -v]
  /usr/bin/rake2.2:33:in `<main>'
  Tasks: TOP => default
  (See full trace by running task with --trace)
  ERROR: Test "ruby2.2" failed. Exiting.
  dh_auto_install: dh_ruby --install
  /build/ruby-state-machines-0.4.0/debian/ruby-state-machines returned
  exit code 1
  debian/rules:5: recipe for target 'binary' failed
  make: *** [binary] Error 1
  dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit
  status 2

  [..]

The full build log is attached or can be viewed here:

    
https://reproducible.debian.net/logs/unstable/amd64/ruby-state-machines_0.4.0-1.build1.log.gz


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to