On Tue, Dec 01, 2015 at 02:13:07PM -0800, Vagrant Cascadian wrote:
> Hey, I think all of the second builds on armhf are failing to set up the
> build environment:
> 
>   https://reproducible.debian.net/logs/unstable/armhf/gb_0.3.2-1.build2.log.gz
> 
>   I: Installing the build-deps
>   I: user script 
> /srv/workspace/pbuilder/5651/tmp/hooks/D01_modify_environment starting
>   FATAL: kernel too old

Interesting... According to codesearch this comes from glibc [1].
It could be related to "linux64 --uname-2.6", which we use use to fake a 
different
kernel version.

[1]: 
https://sources.debian.net/src/glibc/2.19-18/sysdeps/unix/sysv/linux/dl-osinfo.h/?hl=45#L45

> 
> 
> Also saw this message on an amd64/experimental build, although much
> later in the build environment setup:
> 
>   
> https://reproducible.debian.net/logs/experimental/amd64/python-letsencrypt_0.0.0.dev20151123-1.build2.log.gz
> 
>   Traitement des actions différées (« triggers ») pour libc-bin (2.21-1)...
>   FATAL: kernel too old
>   Segmentation fault
>   FATAL: kernel too old
>   Segmentation fault
>   dpkg: erreur de traitement du paquet libc-bin (--unpack)

Attachment: signature.asc
Description: Digital signature

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to