We've set LC_ALL to UTF-8 for the tests in pyuca/1.1-3 to fix a FTBFS problem
in the reproducible build env [1]:

<cut>
override_dh_auto_test:
        PYBUILD_SYSTEM=custom \
        PYBUILD_TEST_ARGS="{interpreter} test.py && LC_ALL=C.UTF-8 
{interpreter} full_test.py" \
        dh_auto_test
</cut>

Strangely, somehow the changes doesn't came through, buildlog of 1.1-3 [2]:

<cut>
I: pybuild base:184: python2.7 test.py && python2.7 full_test.py
s.s.s.s.s.........
----------------------------------------------------------------------
Ran 18 tests in 0.456s

OK (skipped=5)
Traceback (most recent call last):
  File "full_test.py", line 25, in <module>
    for i, line in enumerate(f.readlines()):
  File "/usr/lib/python2.7/encodings/ascii.py", line 26, in decode
    return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xcc in position 149: 
ordinal not in range(128)
</cut>

LC_ALL in PYBUILD_TEST_ARGS should be in effect. Do I've missed something?

Best,
DS

[1] https://sources.debian.net/src/pyuca/1.1-3/debian/rules/

[2] https://tests.reproducible-builds.org/rb-pkg/unstable/amd64/pyuca.html

-- 
4096R/DF5182C8
46CB 1CA8 9EA3 B743 7676 1DB9 15E0 9AF4 DF51 82C8
LPI certified Linux admin (LPI000329859 64mz6f7kt4)
http://www.danielstender.com/blog/


_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to