Source: ruby-versionomy
Version: 0.4.4-1
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

ruby-versionomy fails to build from source in unstable/amd64:

  [..]
  
  
RUBYLIB=/home/lamby/temp/cdt.20160229080839.yx3VvECwEf/ruby-versionomy-0.4.4/debian/ruby-versionomy/usr/lib/ruby/vendor_ruby:.
 
GEM_PATH=debian/ruby-versionomy/usr/share/rubygems-integration/all:/home/lamby/.gem/ruby/2.3.0:/var/lib/gems/2.3.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.3.0:/usr/share/rubygems-integration/2.3.0:/usr/share/rubygems-integration/all
 ruby2.3 -ryaml -e YAML.load_file\(\"debian/ruby-test-files.yaml\"\).each\ \{\ 
\|f\|\ require\ f\ \}
  /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': 
cannot load such file -- blockenspiel/unmixer_mri (LoadError)
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /usr/lib/ruby/vendor_ruby/blockenspiel.rb:48:in `<top (required)>'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from 
/home/lamby/temp/cdt.20160229080839.yx3VvECwEf/ruby-versionomy-0.4.4/debian/ruby-versionomy/usr/lib/ruby/vendor_ruby/versionomy.rb:37:in
 `<top (required)>'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from 
/home/lamby/temp/cdt.20160229080839.yx3VvECwEf/ruby-versionomy-0.4.4/test/tc_custom_format.rb:39:in
 `<top (required)>'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from -e:1:in `block in <main>'
        from -e:1:in `each'
        from -e:1:in `<main>'
  ERROR: Test "ruby2.3" failed. Exiting.
  dh_auto_install: dh_ruby --install 
/home/lamby/temp/cdt.20160229080839.yx3VvECwEf/ruby-versionomy-0.4.4/debian/ruby-versionomy
 returned exit code 1
  debian/rules:19: recipe for target 'override_dh_auto_install' failed
  make[1]: *** [override_dh_auto_install] Error 1
  make[1]: Leaving directory 
'/home/lamby/temp/cdt.20160229080839.yx3VvECwEf/ruby-versionomy-0.4.4'
  debian/rules:15: recipe for target 'binary' failed
  make: *** [binary] Error 2

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: ruby-versionomy.0.4.4-1.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to