Source: trocla
Version: 0.1.2-1
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

trocla fails to build from source in unstable/amd64:

  [..]

  Failures:
  
    1) Trocla password x509 password format should return a password hashed in 
the x509 format
       Failure/Error: 
@trocla.password('some_test',format,format_options[format]).should_not be_empty
       RuntimeError:
         Self-signed certificate /CN=test creation failed: wrong argument 
(OpenSSL::X509::Certificate)! (Expected kind of OpenSSL::X509::Name)
       # ./lib/trocla/formats/x509.rb:66:in `rescue in format'
       # ./lib/trocla/formats/x509.rb:61:in `format'
       # ./lib/trocla.rb:31:in `password'
       # ./spec/trocla_spec.rb:22:in `block (5 levels) in <top (required)>'
  
    2) Trocla password x509 password format should return the same hashed for 
the x509 format on multiple invocations
       Failure/Error: 
(round1=@trocla.password('some_test',format,format_options[format])).should_not 
be_empty
       RuntimeError:
         Self-signed certificate /CN=test creation failed: wrong argument 
(OpenSSL::X509::Certificate)! (Expected kind of OpenSSL::X509::Name)
       # ./lib/trocla/formats/x509.rb:66:in `rescue in format'
       # ./lib/trocla/formats/x509.rb:61:in `format'
       # ./lib/trocla.rb:31:in `password'
       # ./spec/trocla_spec.rb:26:in `block (5 levels) in <top (required)>'
  
  Deprecation Warnings:
  
  Using `should` from rspec-expectations' old `:should` syntax without 
explicitly enabling the syntax is deprecated. Use the new `:expect` syntax or 
explicitly enable `:should` with `config.expect_with(:rspec) { |c| c.syntax = 
:should }` instead. Called from 
/home/lamby/temp/cdt.20160229080919.Psq5c9dxod/trocla-0.1.2/spec/trocla/encryptions/ssl_spec.rb:24:in
 `block (3 levels) in <top (required)>'.
  
  
  If you need more of the backtrace for any of these deprecations to
  identify where to make the necessary changes, you can configure
  `config.raise_errors_for_deprecations!`, and it will turn the
  deprecation warnings into errors, giving you the full backtrace.
  
  1 deprecation warning total
  
  Finished in 1.24 seconds (files took 0.12851 seconds to load)
  63 examples, 2 failures
  
  Failed examples:
  
  rspec './spec/trocla_spec.rb[1:1:10:1]' # Trocla password x509 password 
format should return a password hashed in the x509 format
  rspec './spec/trocla_spec.rb[1:1:10:2]' # Trocla password x509 password 
format should return the same hashed for the x509 format on multiple invocations
  
  /usr/bin/ruby2.3 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb failed
  ERROR: Test "ruby2.3" failed. Exiting.
  dh_auto_install: dh_ruby --install 
/home/lamby/temp/cdt.20160229080919.Psq5c9dxod/trocla-0.1.2/debian/trocla 
returned exit code 1
  debian/rules:21: recipe for target 'override_dh_auto_install' failed
  make[1]: *** [override_dh_auto_install] Error 1
  make[1]: Leaving directory 
'/home/lamby/temp/cdt.20160229080919.Psq5c9dxod/trocla-0.1.2'
  debian/rules:18: recipe for target 'binary' failed
  make: *** [binary] Error 2

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to