On Wed, 2016-03-16 at 23:10:13 +0100, Guillem Jover wrote:
> Package: diffoscope
> Version: 51
> Severity: wishlist

> It seems diffoscope does not fully support the deb(5) format as
> specified in the man page. At least control.tar.xz members, and
> probably neither control.tar nor data.tar.
> 
> It would be nice if these could be supported, as I might try to
> get these accepted by dak.

It was mentioned off-bts that this was not entirely clear, so let
me fix that.

The program was added to <https://wiki.debian.org/Teams/Dpkg/DebSupport>
as not supporting the aforementioned .deb ar members, which is
implemented in diffoscope/comparators/deb.py. The full .deb format
is specified in the deb(5) man page, and anything there should ideally
be supported by 3rd-party parsers, as otherwise they might fail to
process binaries that can be generated now or have been in the past by
dpkg-deb or other tools.

Thanks,
Guillem

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to