Source: ruby-albino
Version: 1.3.3-4
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

ruby-albino fails to build from source in unstable/amd64:

  [..]

  Reading state information...
  Correcting dependencies... Done
  The following additional packages will be installed:
    ca-certificates gem2deb gem2deb-test-runner libgmp-dev libgmpxx4ldbl
    libruby2.3 libyaml-0-2 openssl python-pygments python3-chardet
    python3-debian python3-pkg-resources python3-six rake ruby ruby-all-dev
    ruby-did-you-mean ruby-metaclass ruby-minitest ruby-mocha ruby-net-telnet
    ruby-posix-spawn ruby-power-assert ruby-setup ruby-test-unit ruby2.3
    ruby2.3-dev rubygems-integration
  Suggested packages:
    gmp-doc libgmp10-doc libmpfr-dev ttf-bitstream-vera python3-setuptools ri
    ruby-dev ruby-mocha-doc bundler
  Recommended packages:
    apt-file python-chardet python3-apt zip fonts-lato libjs-jquery
  The following NEW packages will be installed:
    ca-certificates gem2deb gem2deb-test-runner libgmp-dev libgmpxx4ldbl
    libruby2.3 libyaml-0-2 openssl python-pygments python3-chardet
    python3-debian python3-pkg-resources python3-six rake ruby ruby-all-dev
    ruby-did-you-mean ruby-metaclass ruby-minitest ruby-mocha ruby-net-telnet
    ruby-posix-spawn ruby-power-assert ruby-setup ruby-test-unit ruby2.3
    ruby2.3-dev rubygems-integration
  0 upgraded, 28 newly installed, 0 to remove and 0 not upgraded.
  1 not fully installed or removed.
  Need to get 7249 kB of archives.
  After this operation, 28.8 MB of additional disk space will be used.
  Get:1 http://httpredir.debian.org/debian sid/main amd64 openssl amd64 
1.0.2h-1 [681 kB]
  Get:2 http://httpredir.debian.org/debian sid/main amd64 ca-certificates all 
20160104 [200 kB]
  Get:3 http://httpredir.debian.org/debian sid/main amd64 rubygems-integration 
all 1.10 [4882 B]
  Get:4 http://httpredir.debian.org/debian sid/main amd64 ruby-did-you-mean all 
1.0.0-2 [11.2 kB]
  Get:5 http://httpredir.debian.org/debian sid/main amd64 ruby-minitest all 
5.8.4-2 [50.3 kB]
  Get:6 http://httpredir.debian.org/debian sid/main amd64 ruby-net-telnet all 
0.1.1-2 [12.5 kB]
  Get:7 http://httpredir.debian.org/debian sid/main amd64 ruby-power-assert all 
0.2.7-1 [7578 B]
  Get:8 http://httpredir.debian.org/debian sid/main amd64 ruby-test-unit all 
3.1.7-2 [69.6 kB]
  Get:9 http://httpredir.debian.org/debian sid/main amd64 libyaml-0-2 amd64 
0.1.6-3 [50.4 kB]
  Get:10 http://httpredir.debian.org/debian sid/main amd64 libruby2.3 amd64 
2.3.1-1 [3098 kB]
  Get:11 http://httpredir.debian.org/debian sid/main amd64 ruby2.3 amd64 
2.3.1-1 [177 kB]
  Get:12 http://httpredir.debian.org/debian sid/main amd64 ruby amd64 1:2.3.0+4 
[10.5 kB]
  Get:13 http://httpredir.debian.org/debian sid/main amd64 rake all 10.5.0-2 
[49.4 kB]
  Get:14 http://httpredir.debian.org/debian sid/main amd64 gem2deb-test-runner 
all 0.30.1 [19.4 kB]
  Get:15 http://httpredir.debian.org/debian sid/main amd64 
python3-pkg-resources all 20.10.1-1 [112 kB]
  Get:16 http://httpredir.debian.org/debian sid/main amd64 python3-chardet all 
2.3.0-2 [96.0 kB]
  Get:17 http://httpredir.debian.org/debian sid/main amd64 python3-six all 
1.10.0-3 [14.4 kB]
  Get:18 http://httpredir.debian.org/debian sid/main amd64 python3-debian all 
0.1.27 [50.9 kB]
  Get:19 http://httpredir.debian.org/debian sid/main amd64 libgmpxx4ldbl amd64 
2:6.1.0+dfsg-2 [22.2 kB]
  Get:20 http://httpredir.debian.org/debian sid/main amd64 libgmp-dev amd64 
2:6.1.0+dfsg-2 [628 kB]
  Get:21 http://httpredir.debian.org/debian sid/main amd64 ruby2.3-dev amd64 
2.3.1-1 [1169 kB]
  Get:22 http://httpredir.debian.org/debian sid/main amd64 ruby-all-dev amd64 
1:2.3.0+4 [9996 B]
  Get:23 http://httpredir.debian.org/debian sid/main amd64 ruby-setup all 
3.4.1-9 [34.2 kB]
  Get:24 http://httpredir.debian.org/debian sid/main amd64 gem2deb all 0.30.1 
[55.3 kB]
  Get:25 http://httpredir.debian.org/debian sid/main amd64 python-pygments all 
2.1.3+dfsg-1 [535 kB]
  Get:26 http://httpredir.debian.org/debian sid/main amd64 ruby-metaclass all 
0.0.4-1 [3768 B]
  Get:27 http://httpredir.debian.org/debian sid/main amd64 ruby-mocha all 
1.1.0-2 [52.7 kB]
  Get:28 http://httpredir.debian.org/debian sid/main amd64 ruby-posix-spawn 
amd64 0.3.11-1+b2 [24.6 kB]
  Fetched 7249 kB in 0s (54.1 MB/s)
  Selecting previously unselected package openssl.
  (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 23085 files and directories currently installed.)
  Preparing to unpack .../openssl_1.0.2h-1_amd64.deb ...
  Unpacking openssl (1.0.2h-1) ...
  Selecting previously unselected package ca-certificates.
  Preparing to unpack .../ca-certificates_20160104_all.deb ...
  Unpacking ca-certificates (20160104) ...
  Selecting previously unselected package rubygems-integration.
  Preparing to unpack .../rubygems-integration_1.10_all.deb ...
  Unpacking rubygems-integration (1.10) ...
  Selecting previously unselected package ruby-did-you-mean.
  Preparing to unpack .../ruby-did-you-mean_1.0.0-2_all.deb ...
  Unpacking ruby-did-you-mean (1.0.0-2) ...
  Selecting previously unselected package ruby-minitest.
  Preparing to unpack .../ruby-minitest_5.8.4-2_all.deb ...
  Unpacking ruby-minitest (5.8.4-2) ...
  Selecting previously unselected package ruby-net-telnet.
  Preparing to unpack .../ruby-net-telnet_0.1.1-2_all.deb ...
  Unpacking ruby-net-telnet (0.1.1-2) ...
  Selecting previously unselected package ruby-power-assert.
  Preparing to unpack .../ruby-power-assert_0.2.7-1_all.deb ...
  Unpacking ruby-power-assert (0.2.7-1) ...
  Selecting previously unselected package ruby-test-unit.
  Preparing to unpack .../ruby-test-unit_3.1.7-2_all.deb ...
  Unpacking ruby-test-unit (3.1.7-2) ...
  Selecting previously unselected package libyaml-0-2:amd64.
  Preparing to unpack .../libyaml-0-2_0.1.6-3_amd64.deb ...
  Unpacking libyaml-0-2:amd64 (0.1.6-3) ...
  Selecting previously unselected package libruby2.3:amd64.
  Preparing to unpack .../libruby2.3_2.3.1-1_amd64.deb ...
  Unpacking libruby2.3:amd64 (2.3.1-1) ...
  Selecting previously unselected package ruby2.3.
  Preparing to unpack .../ruby2.3_2.3.1-1_amd64.deb ...
  Unpacking ruby2.3 (2.3.1-1) ...
  Selecting previously unselected package ruby.
  Preparing to unpack .../ruby_1%3a2.3.0+4_amd64.deb ...
  Unpacking ruby (1:2.3.0+4) ...
  Selecting previously unselected package rake.
  Preparing to unpack .../archives/rake_10.5.0-2_all.deb ...
  Unpacking rake (10.5.0-2) ...
  Selecting previously unselected package gem2deb-test-runner.
  Preparing to unpack .../gem2deb-test-runner_0.30.1_all.deb ...
  Unpacking gem2deb-test-runner (0.30.1) ...
  Selecting previously unselected package python3-pkg-resources.
  Preparing to unpack .../python3-pkg-resources_20.10.1-1_all.deb ...
  Unpacking python3-pkg-resources (20.10.1-1) ...
  Selecting previously unselected package python3-chardet.
  Preparing to unpack .../python3-chardet_2.3.0-2_all.deb ...
  Unpacking python3-chardet (2.3.0-2) ...
  Selecting previously unselected package python3-six.
  Preparing to unpack .../python3-six_1.10.0-3_all.deb ...
  Unpacking python3-six (1.10.0-3) ...
  Selecting previously unselected package python3-debian.
  Preparing to unpack .../python3-debian_0.1.27_all.deb ...
  Unpacking python3-debian (0.1.27) ...
  Selecting previously unselected package libgmpxx4ldbl:amd64.
  Preparing to unpack .../libgmpxx4ldbl_2%3a6.1.0+dfsg-2_amd64.deb ...
  Unpacking libgmpxx4ldbl:amd64 (2:6.1.0+dfsg-2) ...
  Selecting previously unselected package libgmp-dev:amd64.
  Preparing to unpack .../libgmp-dev_2%3a6.1.0+dfsg-2_amd64.deb ...
  Unpacking libgmp-dev:amd64 (2:6.1.0+dfsg-2) ...
  Selecting previously unselected package ruby2.3-dev:amd64.
  Preparing to unpack .../ruby2.3-dev_2.3.1-1_amd64.deb ...
  Unpacking ruby2.3-dev:amd64 (2.3.1-1) ...
  Selecting previously unselected package ruby-all-dev:amd64.
  Preparing to unpack .../ruby-all-dev_1%3a2.3.0+4_amd64.deb ...
  Unpacking ruby-all-dev:amd64 (1:2.3.0+4) ...
  Selecting previously unselected package ruby-setup.
  Preparing to unpack .../ruby-setup_3.4.1-9_all.deb ...
  Unpacking ruby-setup (3.4.1-9) ...
  Selecting previously unselected package gem2deb.
  Preparing to unpack .../gem2deb_0.30.1_all.deb ...
  Unpacking gem2deb (0.30.1) ...
  Selecting previously unselected package python-pygments.
  Preparing to unpack .../python-pygments_2.1.3+dfsg-1_all.deb ...
  Unpacking python-pygments (2.1.3+dfsg-1) ...
  Selecting previously unselected package ruby-metaclass.
  Preparing to unpack .../ruby-metaclass_0.0.4-1_all.deb ...
  Unpacking ruby-metaclass (0.0.4-1) ...
  Selecting previously unselected package ruby-mocha.
  Preparing to unpack .../ruby-mocha_1.1.0-2_all.deb ...
  Unpacking ruby-mocha (1.1.0-2) ...
  Selecting previously unselected package ruby-posix-spawn.
  Preparing to unpack .../ruby-posix-spawn_0.3.11-1+b2_amd64.deb ...
  Unpacking ruby-posix-spawn (0.3.11-1+b2) ...
  Processing triggers for man-db (2.7.5-1) ...
  Processing triggers for libc-bin (2.22-9) ...
  Setting up openssl (1.0.2h-1) ...
  Setting up ca-certificates (20160104) ...
  Setting up rubygems-integration (1.10) ...
  Setting up ruby-did-you-mean (1.0.0-2) ...
  Setting up ruby-minitest (5.8.4-2) ...
  Setting up ruby-net-telnet (0.1.1-2) ...
  Setting up ruby-power-assert (0.2.7-1) ...
  Setting up ruby-test-unit (3.1.7-2) ...
  Setting up libyaml-0-2:amd64 (0.1.6-3) ...
  Setting up python3-pkg-resources (20.10.1-1) ...
  Setting up python3-chardet (2.3.0-2) ...
  Setting up python3-six (1.10.0-3) ...
  Setting up python3-debian (0.1.27) ...
  Setting up libgmpxx4ldbl:amd64 (2:6.1.0+dfsg-2) ...
  Setting up libgmp-dev:amd64 (2:6.1.0+dfsg-2) ...
  Setting up python-pygments (2.1.3+dfsg-1) ...
  Setting up rake (10.5.0-2) ...
  Setting up libruby2.3:amd64 (2.3.1-1) ...
  Setting up ruby2.3 (2.3.1-1) ...
  Setting up gem2deb-test-runner (0.30.1) ...
  Setting up ruby2.3-dev:amd64 (2.3.1-1) ...
  Setting up ruby-all-dev:amd64 (1:2.3.0+4) ...
  Setting up ruby-setup (3.4.1-9) ...
  Setting up ruby-metaclass (0.0.4-1) ...
  Setting up ruby-mocha (1.1.0-2) ...
  Setting up ruby (1:2.3.0+4) ...
  Setting up gem2deb (0.30.1) ...
  Setting up ruby-posix-spawn (0.3.11-1+b2) ...
  Setting up ruby-albino-build-deps (1.3.3-4) ...
  Processing triggers for ca-certificates (20160104) ...
  Updating certificates in /etc/ssl/certs...
  173 added, 0 removed; done.
  Running hooks in /etc/ca-certificates/update.d...
  done.
  Processing triggers for libc-bin (2.22-9) ...
   dpkg-buildpackage -rfakeroot -D -us -uc -b
  dpkg-buildpackage: info: source package ruby-albino
  dpkg-buildpackage: info: source version 1.3.3-4
  dpkg-buildpackage: info: source distribution unstable
  dpkg-buildpackage: info: source changed by Sebastien Badia <s...@sebian.fr>
   dpkg-source --before-build ruby-albino-1.3.3
  dpkg-buildpackage: info: host architecture amd64
   fakeroot debian/rules clean
  dh clean --buildsystem=ruby --with ruby
     dh_testdir -O--buildsystem=ruby
     dh_auto_clean -O--buildsystem=ruby
        dh_ruby --clean
     dh_ruby --clean
     dh_clean -O--buildsystem=ruby
   debian/rules build
  dh build --buildsystem=ruby --with ruby
     dh_testdir -O--buildsystem=ruby
     dh_update_autotools_config -O--buildsystem=ruby
     dh_auto_configure -O--buildsystem=ruby
        dh_ruby --configure
     dh_auto_build -O--buildsystem=ruby
        dh_ruby --build
     dh_ruby --build
     dh_auto_test -O--buildsystem=ruby
        dh_ruby --test
   fakeroot debian/rules binary
  dh binary --buildsystem=ruby --with ruby
     dh_testroot -O--buildsystem=ruby
     dh_prep -O--buildsystem=ruby
     dh_auto_install -O--buildsystem=ruby
        dh_ruby --install 
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/debian/ruby-albino
     dh_ruby --install
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Install files                                                               
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  install -d 
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/debian/ruby-albino/usr/lib/ruby/vendor_ruby
  install -D -m644 
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/lib/albino.rb
 
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/debian/ruby-albino/usr/lib/ruby/vendor_ruby/albino.rb
  install -D -m644 
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/lib/albino/multi.rb
 
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/debian/ruby-albino/usr/lib/ruby/vendor_ruby/albino/multi.rb
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Install Rubygems integration metadata                                       
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  generating gemspec at 
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/debian/ruby-albino/usr/share/rubygems-integration/all/specifications/albino-1.3.3.gemspec
  /usr/bin/ruby2.3 /usr/bin/gem2deb-test-runner
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Checking Rubygems dependency resolution on ruby2.3                          
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  
GEM_PATH=debian/ruby-albino/usr/share/rubygems-integration/all:/home/lamby/.gem/ruby/2.3.0:/var/lib/gems/2.3.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.3.0:/usr/share/rubygems-integration/2.3.0:/usr/share/rubygems-integration/all
 ruby2.3 -e gem\ \"albino\"
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Run tests for ruby2.3 from debian/ruby-tests.rake                           
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  
RUBYLIB=/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/debian/ruby-albino/usr/lib/ruby/vendor_ruby:.
 
GEM_PATH=debian/ruby-albino/usr/share/rubygems-integration/all:/home/lamby/.gem/ruby/2.3.0:/var/lib/gems/2.3.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.3.0:/usr/share/rubygems-integration/2.3.0:/usr/share/rubygems-integration/all
 ruby2.3 -S rake -f debian/ruby-tests.rake
  /usr/bin/ruby2.3 -I"lib"  
"/usr/lib/ruby/vendor_ruby/rake/rake_test_loader.rb" "test/**/*_test.rb" 
  Loaded suite /usr/lib/ruby/vendor_ruby/rake/rake_test_loader
  Started
  .......F
  
===============================================================================
  Failure:
    </span/> expected to not match
    <"<div class=\"highlight\"><pre><span></span>abc\n</pre>\n</div>\n">.
  test_defaults_to_text(AlbinoTest)
  
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/test/albino_test.rb:17:in
 `test_defaults_to_text'
       14:   def test_defaults_to_text
       15:     syntaxer = Albino.new('abc')
       16:     regex    = /span/
    => 17:     assert_no_match regex, syntaxer.colorize
       18:   end
       19: 
       20:   def test_accepts_options
  
===============================================================================
  ......F
  
===============================================================================
  Failure:
    <"<div 
class=\"highlight\"><pre><span></span>\u00E9\u00F8\u00FC\n</pre>\n</div>\n"> 
expected to include
    <"<pre>\u00E9\u00F8\u00FC\n</pre>">.
  test_accepts_utf8(MultiTest)
  
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/test/multi_albino_test.rb:34:in
 `test_accepts_utf8'
       31: 
       32:   def test_accepts_utf8
       33:     code = Albino::Multi.colorize('éøü', :html)
    => 34:     assert_includes code, "<pre>éøü\n</pre>"
       35:   end
       36: 
       37:   def test_works_with_strings
  
===============================================================================
  ..F
  
===============================================================================
  Failure:
    </span/> expected to not match
    <"<div class=\"highlight\"><pre><span></span>abc\n</pre>\n</div>\n">.
  test_defaults_to_text(MultiTest)
  
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/test/multi_albino_test.rb:17:in
 `test_defaults_to_text'
       14:   def test_defaults_to_text
       15:     syntaxer = Albino::Multi.new('abc')
       16:     regex    = /span/
    => 17:     assert_no_match regex, syntaxer.colorize
       18:   end
       19: 
       20:   def test_markdown_compatible
  
===============================================================================
  .....
  
  Finished in 3.550537347 seconds.
  ------
  23 tests, 31 assertions, 3 failures, 0 errors, 0 pendings, 0 omissions, 0 
notifications
  86.9565% passed
  ------
  6.48 tests/s, 8.73 assertions/s
  rake aborted!
  Command failed with status (1): [ruby -I"lib"  
"/usr/lib/ruby/vendor_ruby/rake/rake_test_loader.rb" "test/**/*_test.rb" ]
  
  Tasks: TOP => default => test
  (See full trace by running task with --trace)
  ERROR: Test "ruby2.3" failed. Exiting.
  dh_auto_install: dh_ruby --install 
/home/lamby/temp/cdt.20160519114438.fNxRDakZko.ruby-albino/ruby-albino-1.3.3/debian/ruby-albino
 returned exit code 1
  debian/rules:6: recipe for target 'binary' failed
  make: *** [binary] Error 1

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: ruby-albino.1.3.3-4.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to