Source: octave-epstk
Version: 2.4-3
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

octave-epstk fails to build from source in unstable/amd64:

  [..]

  Setting up libarpack2 (3.3.0-1+b1) ...
  Setting up libcamd2:amd64 (1:4.5.3-1) ...
  Setting up libccolamd2:amd64 (1:4.5.3-1) ...
  Setting up libcolamd2:amd64 (1:4.5.3-1) ...
  Setting up libmetis5:amd64 (5.1.0.dfsg-4) ...
  Setting up libcholmod3:amd64 (1:4.5.3-1) ...
  Setting up libcxsparse3:amd64 (1:4.5.3-1) ...
  Setting up libfftw3-double3:amd64 (3.3.4-2+b1) ...
  Setting up libfftw3-single3:amd64 (3.3.4-2+b1) ...
  Setting up libdrm2:amd64 (2.4.68-1) ...
  Setting up libglapi-mesa:amd64 (11.2.2-1) ...
  Setting up libxau6:amd64 (1:1.0.8-1) ...
  Setting up libxdmcp6:amd64 (1:1.1.2-1.1) ...
  Setting up libxcb1:amd64 (1.11.1-1) ...
  Setting up libx11-data (2:1.6.3-1) ...
  Setting up libx11-6:amd64 (2:1.6.3-1) ...
  Setting up libx11-xcb1:amd64 (2:1.6.3-1) ...
  Setting up libxcb-dri2-0:amd64 (1.11.1-1) ...
  Setting up libxcb-dri3-0:amd64 (1.11.1-1) ...
  Setting up libxcb-glx0:amd64 (1.11.1-1) ...
  Setting up libxcb-present0:amd64 (1.11.1-1) ...
  Setting up libxcb-randr0:amd64 (1.11.1-1) ...
  Setting up libxcb-render0:amd64 (1.11.1-1) ...
  Setting up libxcb-shape0:amd64 (1.11.1-1) ...
  Setting up libxcb-sync1:amd64 (1.11.1-1) ...
  Setting up libxcb-xfixes0:amd64 (1.11.1-1) ...
  Setting up libxfixes3:amd64 (1:5.0.1-2+b2) ...
  Setting up libxdamage1:amd64 (1:1.1.4-2+b1) ...
  Setting up libxext6:amd64 (2:1.3.3-1) ...
  Setting up libxshmfence1:amd64 (1.2-1) ...
  Setting up libxxf86vm1:amd64 (1:1.1.4-1) ...
  Setting up libgl1-mesa-glx:amd64 (11.2.2-1) ...
  Setting up libgl2ps1 (1.3.9-1) ...
  Setting up libglu1-mesa:amd64 (9.0.0-2.1) ...
  Setting up libaec0:amd64 (0.3.2-1) ...
  Setting up libsz2:amd64 (0.3.2-1) ...
  Setting up libhdf5-10:amd64 (1.8.16+docs-8) ...
  Setting up libqrupdate1:amd64 (1.1.2-1) ...
  Setting up libumfpack5:amd64 (1:4.5.3-1) ...
  Setting up liboctave3v5:amd64 (4.0.2-1+b3) ...
  Setting up libasound2-data (1.1.0-1) ...
  Setting up libasound2:amd64 (1.1.0-1) ...
  Setting up libxrender1:amd64 (1:0.9.9-2) ...
  Setting up libxft2:amd64 (2.3.2-1) ...
  Setting up libxinerama1:amd64 (2:1.1.3-1+b1) ...
  Setting up libfltk1.3:amd64 (1.3.3-8+b1) ...
  Setting up libfltk-gl1.3:amd64 (1.3.3-8+b1) ...
  Setting up libltdl7:amd64 (2.4.6-0.1) ...
  Setting up libglpk40:amd64 (4.60-2+b1) ...
  Setting up x11-common (1:7.7+15) ...
  update-rc.d: warning: start and stop actions are no longer supported; falling 
back to defaults
  invoke-rc.d: could not determine current runlevel
  invoke-rc.d: policy-rc.d denied execution of start.
  Setting up libice6:amd64 (2:1.0.9-1+b1) ...
  Setting up libsm6:amd64 (2:1.2.2-1+b1) ...
  Setting up libwebp5:amd64 (0.4.4-1+b2) ...
  Setting up shared-mime-info (1.6-1) ...
  Setting up libgdk-pixbuf2.0-common (2.34.0-1) ...
  Setting up libgdk-pixbuf2.0-0:amd64 (2.34.0-1) ...
  Setting up libwmf0.2-7:amd64 (0.2.8.4-10.5+b1) ...
  Setting up libgraphicsmagick-q16-3 (1.3.24-1) ...
  Setting up libgraphicsmagick++-q16-12 (1.3.24-1) ...
  Setting up libosmesa6:amd64 (11.2.2-1) ...
  Setting up libopus0:amd64 (1.1.2-1) ...
  Setting up libsamplerate0:amd64 (0.1.8-8) ...
  Setting up libjack-jackd2-0:amd64 (1.9.10+20150825git1ed50c92~dfsg-1) ...
  Setting up libportaudio2:amd64 (19+svn20140130-1) ...
  Setting up libqhull7:amd64 (2015.2-1) ...
  Setting up libqscintilla2-l10n (2.9.2+dfsg-1) ...
  Setting up qtcore4-l10n (4:4.8.7+dfsg-8) ...
  Setting up libqtcore4:amd64 (4:4.8.7+dfsg-8) ...
  Setting up fontconfig (2.11.0-6.4) ...
  Regenerating fonts cache... done.
  Setting up libxt6:amd64 (1:1.1.5-1) ...
  Setting up libaudio2:amd64 (1.9.4-4) ...
  Setting up libmng1:amd64 (1.0.10+dfsg-3.1+b3) ...
  Setting up libqtgui4:amd64 (4:4.8.7+dfsg-8) ...
  Setting up libqscintilla2-12v5 (2.9.2+dfsg-1) ...
  Setting up libqt4-xml:amd64 (4:4.8.7+dfsg-8) ...
  Setting up libqtdbus4:amd64 (4:4.8.7+dfsg-8) ...
  Setting up libqt4-network:amd64 (4:4.8.7+dfsg-8) ...
  Setting up libqt4-opengl:amd64 (4:4.8.7+dfsg-8) ...
  Setting up libogg0:amd64 (1.3.2-1) ...
  Setting up libflac8:amd64 (1.3.1-4) ...
  Setting up libvorbis0a:amd64 (1.3.5-3) ...
  Setting up libvorbisenc2:amd64 (1.3.5-3) ...
  Setting up libsndfile1:amd64 (1.0.25-10) ...
  Setting up libtext-unidecode-perl (1.27-1) ...
  Setting up libxml-namespacesupport-perl (1.11-1) ...
  Setting up libxml-sax-base-perl (1.07-1) ...
  Setting up libxml-sax-perl (0.99+dfsg-2) ...
  update-perl-sax-parsers: Registering Perl SAX parser XML::SAX::PurePerl with 
priority 10...
  update-perl-sax-parsers: Updating overall Perl SAX parser modules info file...
  
  Creating config file /etc/perl/XML/SAX/ParserDetails.ini with new version
  Setting up libxml-libxml-perl (2.0123+dfsg-1+b1) ...
  update-perl-sax-parsers: Registering Perl SAX parser XML::LibXML::SAX::Parser 
with priority 50...
  update-perl-sax-parsers: Registering Perl SAX parser XML::LibXML::SAX with 
priority 50...
  update-perl-sax-parsers: Updating overall Perl SAX parser modules info file...
  Replacing config file /etc/perl/XML/SAX/ParserDetails.ini with new version
  Setting up tex-common (6.05) ...
  update-language: texlive-base not installed and configured, doing nothing!
  Setting up texinfo (6.1.0.dfsg.1-8) ...
  Setting up octave-common (4.0.2-1) ...
  Setting up octave (4.0.2-1+b3) ...
  No protocol specified
  Setting up libtinfo-dev:amd64 (6.0+20160319-1) ...
  Setting up libreadline6-dev:amd64 (6.3-8+b4) ...
  Setting up libreadline-dev:amd64 (6.3-8+b4) ...
  Setting up libncurses5-dev:amd64 (6.0+20160319-1) ...
  Setting up zlib1g-dev:amd64 (1:1.2.8.dfsg-2+b1) ...
  Setting up libjpeg62-turbo-dev:amd64 (1:1.4.2-2) ...
  Setting up libjpeg-dev (1:1.4.2-2) ...
  Setting up libaec-dev:amd64 (0.3.2-1) ...
  Setting up hdf5-helpers (1.8.16+docs-8) ...
  Setting up libhdf5-cpp-11:amd64 (1.8.16+docs-8) ...
  Setting up libhdf5-dev (1.8.16+docs-8) ...
  update-alternatives: using /usr/lib/x86_64-linux-gnu/pkgconfig/hdf5-serial.pc 
to provide /usr/lib/x86_64-linux-gnu/pkgconfig/hdf5.pc (hdf5.pc) in auto mode
  Setting up xorg-sgml-doctools (1:1.11-1) ...
  Setting up x11proto-core-dev (7.0.29-1) ...
  Setting up libxau-dev:amd64 (1:1.0.8-1) ...
  Setting up libxdmcp-dev:amd64 (1:1.1.2-1.1) ...
  Setting up x11proto-input-dev (2.3.2-1) ...
  Setting up x11proto-kb-dev (1.0.7-1) ...
  Setting up xtrans-dev (1.3.5-1) ...
  Setting up libpthread-stubs0-dev:amd64 (0.3-4) ...
  Setting up libxcb1-dev:amd64 (1.11.1-1) ...
  Setting up libx11-dev:amd64 (2:1.6.3-1) ...
  Setting up libpciaccess0:amd64 (0.13.4-1) ...
  Setting up libdrm-intel1:amd64 (2.4.68-1) ...
  Setting up libdrm-radeon1:amd64 (2.4.68-1) ...
  Setting up libdrm-nouveau2:amd64 (2.4.68-1) ...
  Setting up libdrm-amdgpu1:amd64 (2.4.68-1) ...
  Setting up libdrm-dev:amd64 (2.4.68-1) ...
  Setting up mesa-common-dev:amd64 (11.2.2-1) ...
  Setting up libx11-xcb-dev:amd64 (2:1.6.3-1) ...
  Setting up libxcb-dri3-dev:amd64 (1.11.1-1) ...
  Setting up libxcb-render0-dev:amd64 (1.11.1-1) ...
  Setting up libxcb-randr0-dev:amd64 (1.11.1-1) ...
  Setting up libxcb-shape0-dev:amd64 (1.11.1-1) ...
  Setting up libxcb-xfixes0-dev:amd64 (1.11.1-1) ...
  Setting up libxcb-sync-dev:amd64 (1.11.1-1) ...
  Setting up libxcb-present-dev:amd64 (1.11.1-1) ...
  Setting up libxshmfence-dev:amd64 (1.2-1) ...
  Setting up libxcb-dri2-0-dev:amd64 (1.11.1-1) ...
  Setting up libxcb-glx0-dev:amd64 (1.11.1-1) ...
  Setting up x11proto-xext-dev (7.3.0-1) ...
  Setting up x11proto-fixes-dev (1:5.0-2) ...
  Setting up libxfixes-dev:amd64 (1:5.0.1-2+b2) ...
  Setting up x11proto-damage-dev (1:1.2.1-2) ...
  Setting up libxdamage-dev:amd64 (1:1.1.4-2+b1) ...
  Setting up libxext-dev:amd64 (2:1.3.3-1) ...
  Setting up x11proto-xf86vidmode-dev (2.3.1-2) ...
  Setting up libxxf86vm-dev:amd64 (1:1.1.4-1) ...
  Setting up x11proto-dri2-dev (2.8-2) ...
  Setting up x11proto-gl-dev (1.4.17-1) ...
  Setting up libgl1-mesa-dev:amd64 (11.2.2-1) ...
  Setting up libgfortran-5-dev:amd64 (5.3.1-21) ...
  Setting up gfortran-5 (5.3.1-21) ...
  Setting up gfortran (4:5.3.1-3) ...
  update-alternatives: using /usr/bin/gfortran to provide /usr/bin/f95 (f95) in 
auto mode
  update-alternatives: using /usr/bin/gfortran to provide /usr/bin/f77 (f77) in 
auto mode
  Setting up libblas-dev (3.6.0-2) ...
  update-alternatives: using /usr/lib/libblas/libblas.so to provide 
/usr/lib/libblas.so (libblas.so) in auto mode
  Setting up liblapack-dev (3.6.0-2) ...
  update-alternatives: using /usr/lib/lapack/liblapack.so to provide 
/usr/lib/liblapack.so (liblapack.so) in auto mode
  Setting up libfftw3-long3:amd64 (3.3.4-2+b1) ...
  Setting up libfftw3-quad3:amd64 (3.3.4-2+b1) ...
  Setting up libfftw3-bin (3.3.4-2+b1) ...
  Setting up libfftw3-dev:amd64 (3.3.4-2+b1) ...
  Setting up liboctave-dev (4.0.2-1+b3) ...
  Setting up libconvert-binhex-perl (1.125-1) ...
  Setting up libmime-tools-perl (5.507-1) ...
  Setting up octave-pkg-dev (1.4.0) ...
  Setting up libcupsimage2:amd64 (2.1.3-5) ...
  Setting up libgs9 (9.19~dfsg-1+b1) ...
  Setting up ghostscript (9.19~dfsg-1+b1) ...
  Setting up octave-epstk-build-deps (2.4-3) ...
  Setting up libcupsfilters1:amd64 (1.8.3-2+b2) ...
  Processing triggers for libc-bin (2.22-10) ...
  Processing triggers for systemd (230-2) ...
  
  
**************************************************************************************
  ** Environment                                                                
      **
  
**************************************************************************************
  
  
PATH=/home/lamby/git/projects/dotfiles/dotfiles/..//bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
  HOSTNAME=10b4533c53d0
  TERM=xterm
  EVAL=db octave-epstk; ret="${?}"; if [ "${ret}" = 29 ]; then ft . 300; echo 
octave-epstk >> /tmp/tmp.llWZH34BLE; fi; echo octave-epstk >> 
/home/lamby/unfiled/get-ftbfs-logs/.unreproducible; exit ${ret}
  PAGER=more
  DISPLAY=:0
  DOCKER_IMAGE=lamby-debian-sid
  DEB_BUILD_OPTIONS=parallel=9
  PIP_DOWNLOAD_CACHE=/home/lamby/.cache/pip
  HOME=/home/lamby
  LOGNAME=lamby
  SHLVL=1
  
PWD=/home/lamby/temp/cdt.20160605084716.D53riPbbIT.octave-epstk/octave-epstk-2.4
  OLDPWD=/home/lamby/temp/cdt.20160605084716.D53riPbbIT.octave-epstk
  GPG_TTY=/dev/console
  QUILT_PATCHES=debian/patches
  QUILT_NO_DIFF_INDEX=1
  QUILT_REFRESH_ARGS=-p ab --no-timestamps --no-index
  DEBEMAIL=la...@debian.org
  DEBFULLNAME=Chris Lamb
  EDITOR=vim
  LESS=-cgiFx4M
  BLASTER=A220 I5 D1 H5 P330 T6
  _=/usr/bin/env
  
  
**************************************************************************************
  ** Building octave-epstk 2.4-3 on amd64                                       
      **
  
**************************************************************************************
  
   dpkg-buildpackage -rfakeroot -D -us -uc -b
  dpkg-buildpackage: info: source package octave-epstk
  dpkg-buildpackage: info: source version 2.4-3
  dpkg-buildpackage: info: source distribution unstable
  dpkg-buildpackage: info: source changed by Sbastien Villemot 
<sebast...@debian.org>
   dpkg-source --before-build octave-epstk-2.4
  dpkg-buildpackage: info: host architecture amd64
   fakeroot debian/rules clean
  test -x debian/rules
  dh_clean 
   debian/rules build
  test -x debian/rules
  mkdir -p "."
  # Rename einit.m to epstk.conf, as dh_install cannot rename files when moving 
them 
  # And the file name should really end up as /etc/epstk.conf
  cp m/einit.m m/epstk.conf
  echo "### Running demos with octave"  ;               \
  ( cd m ;                                              \
    echo 'global eConfigFile;                           \
        eConfigFile = "../debian/epstk.conf-demos";     \
        ehelp = "No call to ehelp in demo batch";       \
        edemos;'                                        \
        | octave --silent --no-init-file ) ;            \
  touch build-stamp
  ### Running demos with octave
  warning: using continuation marker \ outside of double quoted strings is 
deprecated and will be removed in a future version of Octave
  warning: using continuation marker \ outside of double quoted strings is 
deprecated and will be removed in a future version of Octave
  warning: using continuation marker \ outside of double quoted strings is 
deprecated and will be removed in a future version of Octave
  Create demos ...
  demo1.eps is written
  demo2.eps is written
  demo3.eps is written
  demo4.eps is written
  demo5.eps is written
  demo6.eps is written
  demo7.eps is written
  demo8.eps is written
  demo9.eps is written
  demo10.eps is written
  demo11.eps is written
  demo12.eps is written
  Writing 1 eps-file(s) with 12 images ...
  demo1.jpg with 629x536 Pixel loaded
  demo2.jpg with 985x708 Pixel loaded
  demo3.jpg with 985x708 Pixel loaded
  demo4.jpg with 863x664 Pixel loaded
  demo5.jpg with 985x708 Pixel loaded
  demo6.jpg with 783x618 Pixel loaded
  demo7.jpg with 846x724 Pixel loaded
  demo8.jpg with 985x708 Pixel loaded
  demo9.jpg with 985x708 Pixel loaded
  demo10.jpg with 933x714 Pixel loaded
  demo11.jpg with 985x708 Pixel loaded
  demo12.jpg with 985x708 Pixel loaded
  demo13.eps is written
  demo14.eps is written
  demo15.eps is written
  demo16.eps is written
  done in 13.3977 sec.
  Show demos ...
  Couldn't find a suitable web browser!
  Set the BROWSER environment variable to your desired browser.
  demo3.eps is written
  demo17.html is written
  Couldn't find a suitable web browser!
  Set the BROWSER environment variable to your desired browser.
  Show documentation ...
  ehelp = No call to ehelp in demo batch
  
   fakeroot debian/rules binary
  test -x debian/rules
  dh_testroot
  dh_prep 
  dh_installdirs -A 
  mkdir -p "."
  # Rename einit.m to epstk.conf, as dh_install cannot rename files when moving 
them 
  # And the file name should really end up as /etc/epstk.conf
  cp m/einit.m m/epstk.conf
  Adding cdbs dependencies to debian/octave-epstk.substvars
  dh_installdirs -poctave-epstk \
        
  /usr/share/octave/debian/dh/octave-pkg-helper
  Can't call method "get" on an undefined value at 
/usr/share/octave/debian/dh/octave-pkg-helper line 38.
  debian/rules:37: recipe for target 'install/octave-epstk' failed
  make: *** [install/octave-epstk] Error 2

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: octave-epstk.2.4-3.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to