Source: aplpy
Version: 1.0-3
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

aplpy fails to build from source in unstable/amd64:

  [..]

  Unpacking python3-tz (2015.7+dfsg-0.1) ...
  Selecting previously unselected package python3-cycler.
  Preparing to unpack .../python3-cycler_0.10.0-1_all.deb ...
  Unpacking python3-cycler (0.10.0-1) ...
  Selecting previously unselected package python3-matplotlib.
  Preparing to unpack .../python3-matplotlib_1.5.2~rc2-1_amd64.deb ...
  Unpacking python3-matplotlib (1.5.2~rc2-1) ...
  Selecting previously unselected package python3-pkg-resources.
  Preparing to unpack .../python3-pkg-resources_20.10.1-1_all.deb ...
  Unpacking python3-pkg-resources (20.10.1-1) ...
  Selecting previously unselected package python3-setuptools.
  Preparing to unpack .../python3-setuptools_20.10.1-1_all.deb ...
  Unpacking python3-setuptools (20.10.1-1) ...
  Selecting previously unselected package python3-tk.
  Preparing to unpack .../python3-tk_3.5.1-1_amd64.deb ...
  Unpacking python3-tk (3.5.1-1) ...
  Selecting previously unselected package libxmuu1:amd64.
  Preparing to unpack .../libxmuu1_2%3a1.1.2-2_amd64.deb ...
  Unpacking libxmuu1:amd64 (2:1.1.2-2) ...
  Selecting previously unselected package xauth.
  Preparing to unpack .../xauth_1%3a1.0.9-1_amd64.deb ...
  Unpacking xauth (1:1.0.9-1) ...
  Selecting previously unselected package xkb-data.
  Preparing to unpack .../xkb-data_2.17-1_all.deb ...
  Unpacking xkb-data (2.17-1) ...
  Selecting previously unselected package libice6:amd64.
  Preparing to unpack .../libice6_2%3a1.0.9-1+b1_amd64.deb ...
  Unpacking libice6:amd64 (2:1.0.9-1+b1) ...
  Selecting previously unselected package libsm6:amd64.
  Preparing to unpack .../libsm6_2%3a1.2.2-1+b1_amd64.deb ...
  Unpacking libsm6:amd64 (2:1.2.2-1+b1) ...
  Selecting previously unselected package libxt6:amd64.
  Preparing to unpack .../libxt6_1%3a1.1.5-1_amd64.deb ...
  Unpacking libxt6:amd64 (1:1.1.5-1) ...
  Selecting previously unselected package libxmu6:amd64.
  Preparing to unpack .../libxmu6_2%3a1.1.2-2_amd64.deb ...
  Unpacking libxmu6:amd64 (2:1.1.2-2) ...
  Selecting previously unselected package libxpm4:amd64.
  Preparing to unpack .../libxpm4_1%3a3.5.11-1+b1_amd64.deb ...
  Unpacking libxpm4:amd64 (1:3.5.11-1+b1) ...
  Selecting previously unselected package libxaw7:amd64.
  Preparing to unpack .../libxaw7_2%3a1.0.13-1_amd64.deb ...
  Unpacking libxaw7:amd64 (2:1.0.13-1) ...
  Selecting previously unselected package libxkbfile1:amd64.
  Preparing to unpack .../libxkbfile1_1%3a1.0.9-2_amd64.deb ...
  Unpacking libxkbfile1:amd64 (1:1.0.9-2) ...
  Selecting previously unselected package x11-xkb-utils.
  Preparing to unpack .../x11-xkb-utils_7.7+3_amd64.deb ...
  Unpacking x11-xkb-utils (7.7+3) ...
  Selecting previously unselected package xserver-common.
  Preparing to unpack .../xserver-common_2%3a1.18.3-1_all.deb ...
  Unpacking xserver-common (2:1.18.3-1) ...
  Selecting previously unselected package libdrm2:amd64.
  Preparing to unpack .../libdrm2_2.4.68-1_amd64.deb ...
  Unpacking libdrm2:amd64 (2.4.68-1) ...
  Selecting previously unselected package libglapi-mesa:amd64.
  Preparing to unpack .../libglapi-mesa_11.2.2-1_amd64.deb ...
  Unpacking libglapi-mesa:amd64 (11.2.2-1) ...
  Selecting previously unselected package libx11-xcb1:amd64.
  Preparing to unpack .../libx11-xcb1_2%3a1.6.3-1_amd64.deb ...
  Unpacking libx11-xcb1:amd64 (2:1.6.3-1) ...
  Selecting previously unselected package libxcb-dri2-0:amd64.
  Preparing to unpack .../libxcb-dri2-0_1.11.1-1_amd64.deb ...
  Unpacking libxcb-dri2-0:amd64 (1.11.1-1) ...
  Selecting previously unselected package libxcb-dri3-0:amd64.
  Preparing to unpack .../libxcb-dri3-0_1.11.1-1_amd64.deb ...
  Unpacking libxcb-dri3-0:amd64 (1.11.1-1) ...
  Selecting previously unselected package libxcb-glx0:amd64.
  Preparing to unpack .../libxcb-glx0_1.11.1-1_amd64.deb ...
  Unpacking libxcb-glx0:amd64 (1.11.1-1) ...
  Selecting previously unselected package libxcb-present0:amd64.
  Preparing to unpack .../libxcb-present0_1.11.1-1_amd64.deb ...
  Unpacking libxcb-present0:amd64 (1.11.1-1) ...
  Selecting previously unselected package libxcb-randr0:amd64.
  Preparing to unpack .../libxcb-randr0_1.11.1-1_amd64.deb ...
  Unpacking libxcb-randr0:amd64 (1.11.1-1) ...
  Selecting previously unselected package libxcb-shape0:amd64.
  Preparing to unpack .../libxcb-shape0_1.11.1-1_amd64.deb ...
  Unpacking libxcb-shape0:amd64 (1.11.1-1) ...
  Selecting previously unselected package libxcb-sync1:amd64.
  Preparing to unpack .../libxcb-sync1_1.11.1-1_amd64.deb ...
  Unpacking libxcb-sync1:amd64 (1.11.1-1) ...
  Selecting previously unselected package libxcb-xfixes0:amd64.
  Preparing to unpack .../libxcb-xfixes0_1.11.1-1_amd64.deb ...
  Unpacking libxcb-xfixes0:amd64 (1.11.1-1) ...
  Selecting previously unselected package libxshmfence1:amd64.
  Preparing to unpack .../libxshmfence1_1.2-1_amd64.deb ...
  Unpacking libxshmfence1:amd64 (1.2-1) ...
  Selecting previously unselected package libxxf86vm1:amd64.
  Preparing to unpack .../libxxf86vm1_1%3a1.1.4-1_amd64.deb ...
  Unpacking libxxf86vm1:amd64 (1:1.1.4-1) ...
  Selecting previously unselected package libgl1-mesa-glx:amd64.
  Preparing to unpack .../libgl1-mesa-glx_11.2.2-1_amd64.deb ...
  Unpacking libgl1-mesa-glx:amd64 (11.2.2-1) ...
  Selecting previously unselected package libfontenc1:amd64.
  Preparing to unpack .../libfontenc1_1%3a1.1.3-1_amd64.deb ...
  Unpacking libfontenc1:amd64 (1:1.1.3-1) ...
  Selecting previously unselected package libxfont1:amd64.
  Preparing to unpack .../libxfont1_1%3a1.5.1-1_amd64.deb ...
  Unpacking libxfont1:amd64 (1:1.5.1-1) ...
  Selecting previously unselected package xvfb.
  Preparing to unpack .../xvfb_2%3a1.18.3-1_amd64.deb ...
  Unpacking xvfb (2:1.18.3-1) ...
  Processing triggers for libc-bin (2.22-10) ...
  Processing triggers for man-db (2.7.5-1) ...
  Processing triggers for systemd (230-2) ...
  Setting up python-all (2.7.11-2) ...
  Setting up libgfortran3:amd64 (6.1.1-5) ...
  Setting up libblas-common (3.6.0-2) ...
  Setting up libblas3 (3.6.0-2) ...
  update-alternatives: using /usr/lib/libblas/libblas.so.3 to provide 
/usr/lib/libblas.so.3 (libblas.so.3) in auto mode
  Setting up liblapack3 (3.6.0-2) ...
  update-alternatives: using /usr/lib/lapack/liblapack.so.3 to provide 
/usr/lib/liblapack.so.3 (liblapack.so.3) in auto mode
  Setting up python-numpy (1:1.11.1~rc1-1) ...
  Setting up libcfitsio4:amd64 (3.380-2) ...
  Setting up liberfa1:amd64 (1.2.0-3) ...
  Setting up libwcs5:amd64 (5.15-1) ...
  Setting up python-astropy (1.1.2-1) ...
  Setting up python-astropy-helpers (1.1.2-1) ...
  Setting up fonts-lyx (2.1.4-2) ...
  Setting up ttf-bitstream-vera (1.10-8) ...
  Setting up python-matplotlib-data (1.5.2~rc2-1) ...
  Setting up python-pyparsing (2.1.4+dfsg1-1) ...
  Setting up python-tz (2015.7+dfsg-0.1) ...
  Setting up libjs-jquery (1.12.3-1) ...
  Setting up libjs-jquery-ui (1.10.1+dfsg-1) ...
  Setting up python-cycler (0.10.0-1) ...
  Setting up libatk1.0-data (2.20.0-1) ...
  Setting up libatk1.0-0:amd64 (2.20.0-1) ...
  Setting up libpng16-16:amd64 (1.6.21-5) ...
  Setting up libfreetype6:amd64 (2.6.3-3+b1) ...
  Setting up ucf (3.0036) ...
  Setting up fontconfig-config (2.11.0-6.4) ...
  Setting up libfontconfig1:amd64 (2.11.0-6.4) ...
  Setting up libpixman-1-0:amd64 (0.33.6-1) ...
  Setting up libxau6:amd64 (1:1.0.8-1) ...
  Setting up libxdmcp6:amd64 (1:1.1.2-1.1) ...
  Setting up libxcb1:amd64 (1.11.1-1) ...
  Setting up libx11-data (2:1.6.3-1) ...
  Setting up libx11-6:amd64 (2:1.6.3-1) ...
  Setting up libxcb-render0:amd64 (1.11.1-1) ...
  Setting up libxcb-shm0:amd64 (1.11.1-1) ...
  Setting up libxext6:amd64 (2:1.3.3-1) ...
  Setting up libxrender1:amd64 (1:0.9.9-2) ...
  Setting up libcairo2:amd64 (1.14.6-1+b1) ...
  Setting up libjpeg62-turbo:amd64 (1:1.4.2-2) ...
  Setting up libjbig0:amd64 (2.1-3.1) ...
  Setting up libtiff5:amd64 (4.0.6-1) ...
  Setting up shared-mime-info (1.6-1) ...
  wSetting up libgdk-pixbuf2.0-common (2.34.0-1) ...
  Setting up libgdk-pixbuf2.0-0:amd64 (2.34.0-1) ...
  Setting up libgtk2.0-common (2.24.30-2) ...
  Setting up libavahi-common-data:amd64 (0.6.32~rc+dfsg-1) ...
  Setting up libavahi-common3:amd64 (0.6.32~rc+dfsg-1) ...
  Setting up libdbus-1-3:amd64 (1.10.8-1) ...
  Setting up libavahi-client3:amd64 (0.6.32~rc+dfsg-1) ...
  Setting up libcups2:amd64 (2.1.3-5) ...
  Setting up fontconfig (2.11.0-6.4) ...
  Regenerating fonts cache... done.
  Setting up libthai-data (0.1.24-2) ...
  Setting up libdatrie1:amd64 (0.2.10-2) ...
  Setting up libthai0:amd64 (0.1.24-2) ...
  Setting up libpango-1.0-0:amd64 (1.40.1-1) ...
  Setting up libgraphite2-3:amd64 (1.3.8-1) ...
  Setting up libharfbuzz0b:amd64 (1.2.6-2) ...
  Setting up libpangoft2-1.0-0:amd64 (1.40.1-1) ...
  Setting up libpangocairo-1.0-0:amd64 (1.40.1-1) ...
  Setting up libxcomposite1:amd64 (1:0.4.4-1) ...
  Setting up libxfixes3:amd64 (1:5.0.1-2+b2) ...
  Setting up libxcursor1:amd64 (1:1.1.14-1+b1) ...
  Setting up libxdamage1:amd64 (1:1.1.4-2+b1) ...
  Setting up libxi6:amd64 (2:1.7.6-1) ...
  Setting up libxinerama1:amd64 (2:1.1.3-1+b1) ...
  Setting up libxrandr2:amd64 (2:1.5.0-1) ...
  Setting up libgtk2.0-0:amd64 (2.24.30-2) ...
  Setting up python-matplotlib (1.5.2~rc2-1) ...
  Setting up python-setuptools (20.10.1-1) ...
  Setting up libtcl8.6:amd64 (8.6.5+dfsg-2) ...
  Setting up libxft2:amd64 (2.3.2-1) ...
  Setting up x11-common (1:7.7+15) ...
  update-rc.d: warning: start and stop actions are no longer supported; falling 
back to defaults
  invoke-rc.d: could not determine current runlevel
  invoke-rc.d: policy-rc.d denied execution of start.
  Setting up libxss1:amd64 (1:1.2.2-1) ...
  Setting up libtk8.6:amd64 (8.6.5-1) ...
  Setting up tk8.6-blt2.5 (2.5.3+dfsg-3) ...
  Setting up blt (2.5.3+dfsg-3) ...
  Setting up python-tk (2.7.11-2) ...
  Setting up python3-all (3.5.1-4) ...
  Setting up python3-numpy (1:1.11.1~rc1-1) ...
  Setting up python3-astropy (1.1.2-1) ...
  Setting up python3-astropy-helpers (1.1.2-1) ...
  Setting up python3-six (1.10.0-3) ...
  Setting up python3-dateutil (2.4.2-1) ...
  Setting up python3-pyparsing (2.1.4+dfsg1-1) ...
  Setting up python3-tz (2015.7+dfsg-0.1) ...
  Setting up python3-cycler (0.10.0-1) ...
  Setting up python3-matplotlib (1.5.2~rc2-1) ...
  Setting up python3-pkg-resources (20.10.1-1) ...
  Setting up python3-setuptools (20.10.1-1) ...
  Setting up python3-tk (3.5.1-1) ...
  Setting up libxmuu1:amd64 (2:1.1.2-2) ...
  Setting up xauth (1:1.0.9-1) ...
  Setting up xkb-data (2.17-1) ...
  Setting up libice6:amd64 (2:1.0.9-1+b1) ...
  Setting up libsm6:amd64 (2:1.2.2-1+b1) ...
  Setting up libxt6:amd64 (1:1.1.5-1) ...
  Setting up libxmu6:amd64 (2:1.1.2-2) ...
  Setting up libxpm4:amd64 (1:3.5.11-1+b1) ...
  Setting up libxaw7:amd64 (2:1.0.13-1) ...
  Setting up libxkbfile1:amd64 (1:1.0.9-2) ...
  Setting up x11-xkb-utils (7.7+3) ...
  Setting up xserver-common (2:1.18.3-1) ...
  Setting up libdrm2:amd64 (2.4.68-1) ...
  Setting up libglapi-mesa:amd64 (11.2.2-1) ...
  Setting up libx11-xcb1:amd64 (2:1.6.3-1) ...
  Setting up libxcb-dri2-0:amd64 (1.11.1-1) ...
  Setting up libxcb-dri3-0:amd64 (1.11.1-1) ...
  Setting up libxcb-glx0:amd64 (1.11.1-1) ...
  Setting up libxcb-present0:amd64 (1.11.1-1) ...
  Setting up libxcb-randr0:amd64 (1.11.1-1) ...
  Setting up libxcb-shape0:amd64 (1.11.1-1) ...
  Setting up libxcb-sync1:amd64 (1.11.1-1) ...
  Setting up libxcb-xfixes0:amd64 (1.11.1-1) ...
  Setting up libxshmfence1:amd64 (1.2-1) ...
  Setting up libxxf86vm1:amd64 (1:1.1.4-1) ...
  Setting up libgl1-mesa-glx:amd64 (11.2.2-1) ...
  Setting up libfontenc1:amd64 (1:1.1.3-1) ...
  Setting up libxfont1:amd64 (1:1.5.1-1) ...
  Setting up xvfb (2:1.18.3-1) ...
  Setting up aplpy-build-deps (1.0-3) ...
  Processing triggers for libc-bin (2.22-10) ...
  Processing triggers for systemd (230-2) ...
  
  
**************************************************************************************
  ** Environment                                                                
      **
  
**************************************************************************************
  
  
PATH=/home/lamby/git/projects/dotfiles/dotfiles/..//bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
  HOSTNAME=941d22d776a1
  TERM=xterm
  EVAL=db aplpy; ret="${?}"; if [ "${ret}" = 29 ]; then ft . 300; echo aplpy >> 
/tmp/tmp.jfA5Un13iT; fi; echo aplpy >> 
/home/lamby/unfiled/get-ftbfs-logs/.unreproducible; exit ${ret}
  PAGER=more
  DISPLAY=:0
  DOCKER_IMAGE=lamby-debian-sid
  DEB_BUILD_OPTIONS=parallel=9
  PIP_DOWNLOAD_CACHE=/home/lamby/.cache/pip
  HOME=/home/lamby
  LOGNAME=lamby
  SHLVL=1
  PWD=/home/lamby/temp/cdt.20160605130007.JD98N3epWq.aplpy/aplpy-1.0
  OLDPWD=/home/lamby/temp/cdt.20160605130007.JD98N3epWq.aplpy
  GPG_TTY=/dev/console
  QUILT_PATCHES=debian/patches
  QUILT_NO_DIFF_INDEX=1
  QUILT_REFRESH_ARGS=-p ab --no-timestamps --no-index
  DEBEMAIL=la...@debian.org
  DEBFULLNAME=Chris Lamb
  EDITOR=vim
  LESS=-cgiFx4M
  BLASTER=A220 I5 D1 H5 P330 T6
  _=/usr/bin/env
  
  
**************************************************************************************
  ** Building aplpy 1.0-3 on amd64                                              
      **
  
**************************************************************************************
  
   dpkg-buildpackage -rfakeroot -D -us -uc -b
  dpkg-buildpackage: info: source package aplpy
  dpkg-buildpackage: info: source version 1.0-3
  dpkg-buildpackage: info: source distribution unstable
  dpkg-buildpackage: info: source changed by Ole Streicher <oleb...@debian.org>
   dpkg-source --before-build aplpy-1.0
  dpkg-buildpackage: info: host architecture amd64
   fakeroot debian/rules clean
  dh clean --with python2,python3 --buildsystem=pybuild
     dh_testdir -O--buildsystem=pybuild
     dh_auto_clean -O--buildsystem=pybuild
  I: pybuild base:184: python2.7 setup.py clean 
  /usr/lib/python2.7/dist-packages/matplotlib/font_manager.py:273: UserWarning: 
Matplotlib is building the font cache using fc-list. This may take a moment.
    warnings.warn('Matplotlib is building the font cache using fc-list. This 
may take a moment.')
  /usr/lib/python2.7/dist-packages/astropy_helpers/setup_helpers.py:102: 
AstropyDeprecationWarning: Direct use of the adjust_compiler function in 
setup.py is deprecated and can be removed from your setup.py.  This 
functionality is now incorporated directly into the build_ext command.
    'command.', AstropyDeprecationWarning)
  running clean
  removing 
'/home/lamby/temp/cdt.20160605130007.JD98N3epWq.aplpy/aplpy-1.0/.pybuild/pythonX.Y_2.7/build'
 (and everything under it)
  'build/bdist.linux-x86_64' does not exist -- can't clean it
  'build/scripts-2.7' does not exist -- can't clean it
  I: pybuild base:184: python3.5 setup.py clean 
  /usr/lib/python3/dist-packages/matplotlib/font_manager.py:273: UserWarning: 
Matplotlib is building the font cache using fc-list. This may take a moment.
    warnings.warn('Matplotlib is building the font cache using fc-list. This 
may take a moment.')
  /usr/lib/python3/dist-packages/matplotlib/font_manager.py:273: UserWarning: 
Matplotlib is building the font cache using fc-list. This may take a moment.
    warnings.warn('Matplotlib is building the font cache using fc-list. This 
may take a moment.')
  Traceback (most recent call last):
    File "setup.py", line 25, in <module>
      conf = config.ConfigParser()
  AttributeError: module 'distutils.config' has no attribute 'ConfigParser'
  E: pybuild pybuild:274: clean: plugin distutils failed with: exit code=1: 
python3.5 setup.py clean 
  dh_auto_clean: pybuild --clean -i python{version} -p 3.5 --dir . returned 
exit code 13
  debian/rules:10: recipe for target 'clean' failed
  make: *** [clean] Error 25

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: aplpy.1.0-3.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to