Source: ruby-puppet-syntax
Version: 2.0.0-1
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

ruby-puppet-syntax fails to build from source in unstable/amd64:

  [..]

  Preparing to unpack .../ruby-safe-yaml_1.0.4-1_all.deb ...
  Unpacking ruby-safe-yaml (1.0.4-1) ...
  Selecting previously unselected package ruby-shadow.
  Preparing to unpack .../ruby-shadow_2.4.1-1+b3_amd64.deb ...
  Unpacking ruby-shadow (2.4.1-1+b3) ...
  Selecting previously unselected package puppet.
  Preparing to unpack .../puppet_4.5.0-4_all.deb ...
  Unpacking puppet (4.5.0-4) ...
  Processing triggers for man-db (2.7.5-1) ...
  Processing triggers for libc-bin (2.22-11) ...
  Setting up openssl (1.0.2h-1) ...
  Setting up ca-certificates (20160104) ...
  Setting up rubygems-integration (1.10) ...
  Setting up ruby-did-you-mean (1.0.0-2) ...
  Setting up ruby-minitest (5.9.0-1) ...
  Setting up ruby-net-telnet (0.1.1-2) ...
  Setting up ruby-power-assert (0.3.0-1) ...
  Setting up ruby-test-unit (3.1.7-2) ...
  Setting up libyaml-0-2:amd64 (0.1.6-3) ...
  Setting up libgmpxx4ldbl:amd64 (2:6.1.0+dfsg-2) ...
  Setting up libgmp-dev:amd64 (2:6.1.0+dfsg-2) ...
  Setting up libgeoip1:amd64 (1.6.9-1) ...
  Setting up libisc160:amd64 (1:9.10.3.dfsg.P4-10) ...
  Setting up libdns162:amd64 (1:9.10.3.dfsg.P4-10) ...
  Setting up libisccc140:amd64 (1:9.10.3.dfsg.P4-10) ...
  Setting up libisccfg140:amd64 (1:9.10.3.dfsg.P4-10) ...
  Setting up libbind9-140:amd64 (1:9.10.3.dfsg.P4-10) ...
  Setting up liblwres141:amd64 (1:9.10.3.dfsg.P4-10) ...
  Setting up bind9-host (1:9.10.3.dfsg.P4-10) ...
  Setting up net-tools (1.60+git20150829.73cef8a-2) ...
  Setting up augeas-lenses (1.2.0-0.3) ...
  Setting up libaugeas0 (1.2.0-0.3) ...
  Setting up libxslt1.1:amd64 (1.1.28-4) ...
  Setting up rake (10.5.0-2) ...
  Setting up libruby2.3:amd64 (2.3.1-5) ...
  Setting up ruby2.3 (2.3.1-5) ...
  Setting up ruby2.3-dev:amd64 (2.3.1-5) ...
  Setting up ruby-all-dev:amd64 (1:2.3.0+4) ...
  Setting up ruby (1:2.3.0+4) ...
  Setting up gem2deb-test-runner (0.30.3) ...
  Setting up ruby-setup (3.4.1-9) ...
  Setting up gem2deb (0.30.3) ...
  Setting up ruby-diff-lcs (1.2.5-2) ...
  Setting up ruby-rspec-support (3.4.0c3e0m1s1-1) ...
  Setting up ruby-rspec-expectations (3.4.0c3e0m1s1-1) ...
  Setting up ruby-rspec-mocks (3.4.0c3e0m1s1-1) ...
  Setting up ruby-thread-order (1.1.0-1) ...
  Setting up ruby-rspec-core (3.4.0c3e0m1s1-1) ...
  Setting up ruby-rspec (3.4.0c3e0m1s1-1) ...
  Setting up ruby-json (1.8.3-1+b3) ...
  Setting up facter (2.4.6-1) ...
  Setting up ruby-augeas (1:0.5.0-3+b4) ...
  Setting up ruby-deep-merge (1.0.1+gitf9df6fdb-1) ...
  Setting up hiera (2.0.0-2) ...
  Setting up ruby-nokogiri (1.6.7.2-3) ...
  Setting up ruby-rgen (0.8.0-1) ...
  Setting up ruby-safe-yaml (1.0.4-1) ...
  Setting up ruby-shadow (2.4.1-1+b3) ...
  Setting up puppet (4.5.0-4) ...
  Setting up ruby-puppet-syntax-build-deps (2.0.0-1) ...
  Processing triggers for ca-certificates (20160104) ...
  Updating certificates in /etc/ssl/certs...
  173 added, 0 removed; done.
  Running hooks in /etc/ca-certificates/update.d...
  done.
  Processing triggers for libc-bin (2.22-11) ...
  
  
**************************************************************************************
  ** Environment                                                                
      **
  
**************************************************************************************
  
  
PATH=/home/lamby/git/projects/dotfiles/dotfiles/..//bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
  HOSTNAME=89a96400866e
  TERM=xterm
  PAGER=more
  DISPLAY=:0
  DOCKER_IMAGE=lamby-debian-sid
  DEB_BUILD_OPTIONS=parallel=9
  PIP_DOWNLOAD_CACHE=/home/lamby/.cache/pip
  HOME=/home/lamby
  LOGNAME=lamby
  SHLVL=1
  
PWD=/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0
  OLDPWD=/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax
  GPG_TTY=/dev/console
  QUILT_PATCHES=debian/patches
  QUILT_NO_DIFF_INDEX=1
  QUILT_REFRESH_ARGS=-p ab --no-timestamps --no-index
  DEBEMAIL=la...@debian.org
  DEBFULLNAME=Chris Lamb
  EDITOR=vim
  LESS=-cgiFx4M
  BLASTER=A220 I5 D1 H5 P330 T6
  _=/usr/bin/env
  
  
**************************************************************************************
  ** Building ruby-puppet-syntax 2.0.0-1 on amd64                               
      **
  
**************************************************************************************
  
   dpkg-buildpackage -rfakeroot -D -us -uc -b
  dpkg-buildpackage: info: source package ruby-puppet-syntax
  dpkg-buildpackage: info: source version 2.0.0-1
  dpkg-buildpackage: info: source distribution unstable
  dpkg-buildpackage: info: source changed by Gaudenz Steinlin 
<gaud...@debian.org>
   dpkg-source --before-build ruby-puppet-syntax-2.0.0
  dpkg-buildpackage: info: host architecture amd64
   fakeroot debian/rules clean
  dh clean --buildsystem=ruby --with ruby
     dh_testdir -O--buildsystem=ruby
     dh_auto_clean -O--buildsystem=ruby
        dh_ruby --clean
     dh_ruby --clean
     dh_clean -O--buildsystem=ruby
   debian/rules build
  dh build --buildsystem=ruby --with ruby
     dh_testdir -O--buildsystem=ruby
     dh_update_autotools_config -O--buildsystem=ruby
     dh_auto_configure -O--buildsystem=ruby
        dh_ruby --configure
     dh_auto_build -O--buildsystem=ruby
        dh_ruby --build
     dh_ruby --build
     dh_auto_test -O--buildsystem=ruby
        dh_ruby --test
   fakeroot debian/rules binary
  dh binary --buildsystem=ruby --with ruby
     dh_testroot -O--buildsystem=ruby
     dh_prep -O--buildsystem=ruby
     dh_auto_install -O--buildsystem=ruby
        dh_ruby --install 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax
     dh_ruby --install
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Install files                                                               
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  install -d 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax/usr/lib/ruby/vendor_ruby
  install -D -m644 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/lib/puppet-syntax/version.rb
 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax/usr/lib/ruby/vendor_ruby/puppet-syntax/version.rb
  install -D -m644 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/lib/puppet-syntax/hiera.rb
 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax/usr/lib/ruby/vendor_ruby/puppet-syntax/hiera.rb
  install -D -m644 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/lib/puppet-syntax/templates.rb
 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax/usr/lib/ruby/vendor_ruby/puppet-syntax/templates.rb
  install -D -m644 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/lib/puppet-syntax/manifests.rb
 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax/usr/lib/ruby/vendor_ruby/puppet-syntax/manifests.rb
  install -D -m644 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/lib/puppet-syntax/tasks/puppet-syntax.rb
 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax/usr/lib/ruby/vendor_ruby/puppet-syntax/tasks/puppet-syntax.rb
  install -D -m644 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/lib/puppet-syntax.rb
 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax/usr/lib/ruby/vendor_ruby/puppet-syntax.rb
  dh_installchangelogs -pruby-puppet-syntax 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/CHANGELOG
 upstream
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Install Rubygems integration metadata                                       
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  generating gemspec at 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax/usr/share/rubygems-integration/all/specifications/puppet-syntax-2.0.0.gemspec
  /usr/bin/ruby2.3 /usr/bin/gem2deb-test-runner
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Run tests for ruby2.3 from debian/ruby-tests.rake                           
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  
RUBYLIB=/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax/usr/lib/ruby/vendor_ruby:.
 
GEM_PATH=debian/ruby-puppet-syntax/usr/share/rubygems-integration/all:/home/lamby/.gem/ruby/2.3.0:/var/lib/gems/2.3.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.3.0:/usr/share/rubygems-integration/2.3.0:/usr/share/rubygems-integration/all
 ruby2.3 -S rake -f debian/ruby-tests.rake
  /usr/bin/ruby2.3 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb --format 
documentation
  
  PuppetSyntax::Hiera
    should expect an array of files
    should return nothing from valid YAML
    should return an error from invalid YAML
  
  PuppetSyntax::Manifests
    should expect an array of files
    should return nothing from a valid file
    should return an error from an invalid file (FAILED - 1)
    should return a warning from an invalid file (FAILED - 2)
    should ignore warnings about storeconfigs
    should read more than one valid file
    should continue after finding an error in the first file (FAILED - 3)
    deprecation notices
      on puppet >= 3.7
        should return deprecation notices as warnings (FAILED - 4)
    future_parser
      future_parser = false (default)
        should fail without setting future option to true on future manifest 
(FAILED - 5)
      future_parser = true
        Puppet >= 3.2
          should pass with future option set to true on future manifest (FAILED 
- 6)
        Puppet >= 3.7
          should fail on what were deprecation notices in the non-future parser 
(FAILED - 7)
  
  PuppetSyntax rake tasks
    should generate FileList of manifests relative to Rakefile (PENDING: needs 
to be done)
    should generate FileList of templates relative to Rakefile (PENDING: needs 
to be done)
  
  PuppetSyntax::Templates
    should expect an array of files
    should return nothing from a valid file
    should ignore NameErrors from unbound variables
    should catch SyntaxError
    should catch Ruby warnings
    should read more than one valid file
    should continue after finding an error in the first file
    should ignore a TypeError
  
  PuppetSyntax
    should default exclude_paths to empty array
    should support setting exclude_paths
    should support appending exclude_paths
    should support future parser setting
    should support a fail_on_deprecation_notices setting
  
  Pending: (Failures listed here are expected and do not affect your suite's 
status)
  
    1) PuppetSyntax rake tasks should generate FileList of manifests relative 
to Rakefile
       # needs to be done
       # ./spec/puppet-syntax/tasks/puppet-syntax_spec.rb:4
  
    2) PuppetSyntax rake tasks should generate FileList of templates relative 
to Rakefile
       # needs to be done
       # ./spec/puppet-syntax/tasks/puppet-syntax_spec.rb:12
  
  Failures:
  
    1) PuppetSyntax::Manifests should return an error from an invalid file
       Failure/Error: expect(output.size).to eq(1)
  
         expected: 1
              got: 3
  
         (compared using ==)
       # ./spec/puppet-syntax/manifests_spec.rb:23:in `block (2 levels) in <top 
(required)>'
  
    2) PuppetSyntax::Manifests should return a warning from an invalid file
       Failure/Error: expect(output[0]).to match(/Unrecognised escape sequence 
'\\\[' .* at line 3$/)
  
         expected "Unrecognized escape sequence '\\[' at 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/spec/fixtures/test_module/manifests/fail_warning.pp:3:51"
 to match /Unrecognised escape sequence '\\\[' .* at line 3$/
         Diff:
         @@ -1,2 +1,2 @@
         -/Unrecognised escape sequence '\\\[' .* at line 3$/
         +"Unrecognized escape sequence '\\[' at 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/spec/fixtures/test_module/manifests/fail_warning.pp:3:51"
       # ./spec/puppet-syntax/manifests_spec.rb:33:in `block (2 levels) in <top 
(required)>'
  
    3) PuppetSyntax::Manifests should continue after finding an error in the 
first file
       Failure/Error: expect(output.size).to eq(3)
  
         expected: 3
              got: 5
  
         (compared using ==)
       # ./spec/puppet-syntax/manifests_spec.rb:59:in `block (2 levels) in <top 
(required)>'
  
    4) PuppetSyntax::Manifests deprecation notices on puppet >= 3.7 should 
return deprecation notices as warnings
       Failure/Error: expect(has_errors).to eq(false)
  
         expected: false
              got: true
  
         (compared using ==)
       # ./spec/puppet-syntax/manifests_spec.rb:75:in `block (4 levels) in <top 
(required)>'
  
    5) PuppetSyntax::Manifests future_parser future_parser = false (default) 
should fail without setting future option to true on future manifest
       Failure/Error: expect(output.size).to eq(1)
  
         expected: 1
              got: 0
  
         (compared using ==)
       # ./spec/puppet-syntax/manifests_spec.rb:113:in `block (4 levels) in 
<top (required)>'
  
    6) PuppetSyntax::Manifests future_parser future_parser = true Puppet >= 3.2 
should pass with future option set to true on future manifest
       Failure/Error: expect(output).to eq([])
  
         expected: []
              got: ["Attempt to assign a value to unknown setting :parser"]
  
         (compared using ==)
       # ./spec/puppet-syntax/manifests_spec.rb:130:in `block (5 levels) in 
<top (required)>'
  
    7) PuppetSyntax::Manifests future_parser future_parser = true Puppet >= 3.7 
should fail on what were deprecation notices in the non-future parser
       Failure/Error: expect(output[0]).to match(/Node inheritance is not 
supported/)
  
         expected "Attempt to assign a value to unknown setting :parser" to 
match /Node inheritance is not supported/
         Diff:
         @@ -1,2 +1,2 @@
         -/Node inheritance is not supported/
         +"Attempt to assign a value to unknown setting :parser"
       # ./spec/puppet-syntax/manifests_spec.rb:142:in `block (5 levels) in 
<top (required)>'
  
  Finished in 0.08564 seconds (files took 0.77007 seconds to load)
  29 examples, 7 failures, 2 pending
  
  Failed examples:
  
  rspec ./spec/puppet-syntax/manifests_spec.rb:19 # PuppetSyntax::Manifests 
should return an error from an invalid file
  rspec ./spec/puppet-syntax/manifests_spec.rb:28 # PuppetSyntax::Manifests 
should return a warning from an invalid file
  rspec ./spec/puppet-syntax/manifests_spec.rb:55 # PuppetSyntax::Manifests 
should continue after finding an error in the first file
  rspec ./spec/puppet-syntax/manifests_spec.rb:71 # PuppetSyntax::Manifests 
deprecation notices on puppet >= 3.7 should return deprecation notices as 
warnings
  rspec ./spec/puppet-syntax/manifests_spec.rb:107 # PuppetSyntax::Manifests 
future_parser future_parser = false (default) should fail without setting 
future option to true on future manifest
  rspec ./spec/puppet-syntax/manifests_spec.rb:126 # PuppetSyntax::Manifests 
future_parser future_parser = true Puppet >= 3.2 should pass with future option 
set to true on future manifest
  rspec ./spec/puppet-syntax/manifests_spec.rb:137 # PuppetSyntax::Manifests 
future_parser future_parser = true Puppet >= 3.7 should fail on what were 
deprecation notices in the non-future parser
  
  /usr/bin/ruby2.3 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb --format 
documentation failed
  ERROR: Test "ruby2.3" failed. Exiting.
  dh_auto_install: dh_ruby --install 
/home/lamby/temp/cdt.20160618085313.XymxOvJyXW.ruby-puppet-syntax/ruby-puppet-syntax-2.0.0/debian/ruby-puppet-syntax
 returned exit code 1
  debian/rules:18: recipe for target 'binary' failed
  make: *** [binary] Error 1

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: ruby-puppet-syntax.2.0.0-1.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to