Source: libarray-refelem-perl
Version: 1.00-1.1
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

libarray-refelem-perl fails to build from source in unstable/amd64:

  [..]

  
  
**************************************************************************************
  ** Starting build                                                             
      **
  
**************************************************************************************
  
   Package:              libarray-refelem-perl
   Version:              1.00-1.1
   Build architecture:   amd64
   Date:                 Sun, 19 Jun 2016 17:12:00 +0100
   Hostname:             0f1b73fd4167
   Uname:                Linux 0f1b73fd4167 4.5.0-2-amd64 #1 SMP Debian 4.5.4-1 
(2016-05-16) x86_64 GNU/Linux
   /etc/timezone:        Europe/London
  
  
**************************************************************************************
  ** Installing build dependencies                                              
      **
  
**************************************************************************************
  
  dh_testdir
  dh_testroot
  dh_prep
  dh_testdir
  dh_testroot
  dh_install
  dh_installdocs
  dh_installchangelogs
  dh_compress
  dh_fixperms
  dh_installdeb
  dh_gencontrol
  dh_md5sums
  dh_builddeb
  dpkg-deb: building package 'libarray-refelem-perl-build-deps' in 
'../libarray-refelem-perl-build-deps_1.00-1.1_all.deb'.
  
  The package has been created.
  Attention, the package has been created in the current directory,
  not in ".." as indicated by the message above!
  Selecting previously unselected package libarray-refelem-perl-build-deps.
  (Reading database ... 23077 files and directories currently installed.)
  Preparing to unpack libarray-refelem-perl-build-deps_1.00-1.1_all.deb ...
  Unpacking libarray-refelem-perl-build-deps (1.00-1.1) ...
  Reading package lists...
  Building dependency tree...
  Reading state information...
  0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
  1 not fully installed or removed.
  After this operation, 0 B of additional disk space will be used.
  Setting up libarray-refelem-perl-build-deps (1.00-1.1) ...
  
  
**************************************************************************************
  ** Environment                                                                
      **
  
**************************************************************************************
  
  
PATH=/home/lamby/git/projects/dotfiles/dotfiles/..//bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
  HOSTNAME=0f1b73fd4167
  TERM=xterm
  PAGER=more
  DISPLAY=:0
  DOCKER_IMAGE=lamby-debian-sid
  DEB_BUILD_OPTIONS=parallel=9
  PIP_DOWNLOAD_CACHE=/home/lamby/.cache/pip
  HOME=/home/lamby
  LOGNAME=lamby
  SHLVL=1
  
PWD=/home/lamby/temp/cdt.20160619171158.XYg3BdombD.libarray-refelem-perl/libarray-refelem-perl-1.00
  OLDPWD=/home/lamby/temp/cdt.20160619171158.XYg3BdombD.libarray-refelem-perl
  GPG_TTY=/dev/console
  QUILT_PATCHES=debian/patches
  QUILT_NO_DIFF_INDEX=1
  QUILT_REFRESH_ARGS=-p ab --no-timestamps --no-index
  DEBEMAIL=la...@debian.org
  DEBFULLNAME=Chris Lamb
  EDITOR=vim
  LESS=-cgiFx4M
  BLASTER=A220 I5 D1 H5 P330 T6
  _=/usr/bin/env
  
  
**************************************************************************************
  ** Building libarray-refelem-perl 1.00-1.1 on amd64                           
      **
  
**************************************************************************************
  
   dpkg-buildpackage -rfakeroot -D -us -uc -b
  dpkg-buildpackage: info: source package libarray-refelem-perl
  dpkg-buildpackage: info: source version 1.00-1.1
  dpkg-buildpackage: info: source distribution unstable
  dpkg-buildpackage: info: source changed by Niko Tyni <nt...@debian.org>
   dpkg-source --before-build libarray-refelem-perl-1.00
  dpkg-buildpackage: info: host architecture amd64
   fakeroot debian/rules clean
  dh_testdir
  dh_testroot
  /usr/bin/make realclean
  make[1]: Entering directory 
'/home/lamby/temp/cdt.20160619171158.XYg3BdombD.libarray-refelem-perl/libarray-refelem-perl-1.00'
  make[1]: *** No rule to make target 'realclean'.  Stop.
  make[1]: Leaving directory 
'/home/lamby/temp/cdt.20160619171158.XYg3BdombD.libarray-refelem-perl/libarray-refelem-perl-1.00'
  debian/rules:37: recipe for target 'clean' failed
  make: [clean] Error 2 (ignored)
  dh_clean build-stamp install-stamp
  dh_clean: Compatibility levels before 5 are no longer supported (level 4 
requested)
  debian/rules:37: recipe for target 'clean' failed
  make: *** [clean] Error 25

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: libarray-refelem-perl.1.00-1.1.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to