Source: apache-directory-api
Version: 1.0.0~M20-3
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

apache-directory-api fails to build from source in unstable/amd64:

  [..]

        /usr/bin/make -f debian/rules patch-poms; \
  fi
  cd . && /usr/lib/jvm/default-java/bin/java -noverify -cp 
/usr/share/maven/boot/plexus-classworlds-2.x.jar:/usr/lib/jvm/default-java/lib/tools.jar
 
-Dproperties.file.manual=/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/debian/maven.properties
 -Dclassworlds.conf=/etc/maven/m2-debian.conf -Dmaven.home=/usr/share/maven 
-Dmaven.multiModuleProjectDirectory=/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20
 org.codehaus.plexus.classworlds.launcher.Launcher 
-s/etc/maven/settings-debian.xml 
-Dmaven.repo.local=/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/debian/maven-repo
  package -DskipTests
  [INFO] Scanning for projects...
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-i18n:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-util:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-asn1-api:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-asn1-ber:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-asn1-parent:pom:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-all:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-model:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-codec-core:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-codec-standalone:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-codec-parent:pom:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-schema-data:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-schema-converter:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-schema-parent:pom:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-net-mina:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-net-parent:pom:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-client-api:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-client-parent:pom:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-extras-aci:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-extras-codec:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-extras-codec-api:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-extras-sp:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-extras-trigger:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-extras-util:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-extras-parent:pom:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-ldap-parent:pom:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-dsml-engine:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-dsml-parser:jar:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-dsml-parent:pom:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ org.apache.directory.api:api-parent:1.0.0-M20, 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/pom.xml,
 line 283, column 16
  [WARNING] 
  [WARNING] Some problems were encountered while building the effective model 
for org.apache.directory.api:api-parent:pom:1.0.0-M20
  [WARNING] 
'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)'
 must be unique: org.osgi:org.osgi.core:jar -> duplicate declaration of version 
debian @ line 283, column 16
  [WARNING] 
  [WARNING] It is highly recommended to fix these problems because they 
threaten the stability of your build.
  [WARNING] 
  [WARNING] For this reason, future Maven versions might no longer support 
building such malformed projects.
  [WARNING] 
  [INFO] 
------------------------------------------------------------------------
  [INFO] Reactor Build Order:
  [INFO] 
  [INFO] Apache Directory LDAP API
  [INFO] Apache Directory LDAP API I18n
  [INFO] Apache Directory LDAP API Utilities
  [INFO] Apache Directory API ASN.1 Parent
  [INFO] Apache Directory API ASN.1 API
  [INFO] Apache Directory API ASN.1 BER
  [INFO] Apache Directory LDAP API Parent
  [INFO] Apache Directory LDAP API Model
  [INFO] Apache Directory LDAP API Codec Parent
  [INFO] Apache Directory LDAP API Codec Core
  [INFO] Apache Directory LDAP API Net Parent
  [INFO] Apache Directory LDAP API Network MINA
  [INFO] Apache Directory LDAP API Codec Standalone
  [INFO] Apache Directory LDAP API DSML Parent
  [INFO] Apache Directory LDAP API DSML Parser
  [INFO] Apache Directory LDAP API Extras
  [INFO] Apache Directory LDAP API Extras ACI
  [INFO] Apache Directory LDAP API Schema Parent
  [INFO] Apache Directory LDAP API Schema Data
  [INFO] Apache Directory LDAP API Client Parent
  [INFO] Apache Directory LDAP API Client API
  [INFO] Apache Directory LDAP API DSML Engine
  [INFO] Apache Directory LDAP API Extras Codec API
  [INFO] Apache Directory LDAP API Extras Codec
  [INFO] Apache Directory LDAP API Extras Util
  [INFO] Apache Directory LDAP API Extras Stored Procedures
  [INFO] Apache Directory LDAP API Extras Trigger
  [INFO] Apache Directory LDAP API Schema Converter
  [INFO] Apache Directory API All
  [INFO]                                                                        
 
  [INFO] 
------------------------------------------------------------------------
  [INFO] Building Apache Directory LDAP API 1.0.0-M20
  [INFO] 
------------------------------------------------------------------------
  [INFO]                                                                        
 
  [INFO] 
------------------------------------------------------------------------
  [INFO] Building Apache Directory LDAP API I18n 1.0.0-M20
  [INFO] 
------------------------------------------------------------------------
  [INFO] 
  [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ 
api-i18n ---
  [WARNING] Using platform encoding (ANSI_X3.4-1968 actually) to copy filtered 
resources, i.e. build is platform dependent!
  [INFO] Copying 2 resources
  [INFO] 
  [INFO] --- maven-compiler-plugin:3.2:compile (default-compile) @ api-i18n ---
  [INFO] Changes detected - recompiling the module!
  [WARNING] File encoding has not been set, using platform encoding 
ANSI_X3.4-1968, i.e. build is platform dependent!
  [INFO] Compiling 1 source file to 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/i18n/target/classes
  [INFO] 
  [INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ 
api-i18n ---
  [INFO] Not copying test resources
  [INFO] 
  [INFO] --- maven-compiler-plugin:3.2:testCompile (default-testCompile) @ 
api-i18n ---
  [INFO] Not compiling test sources
  [INFO] 
  [INFO] --- maven-surefire-plugin:2.17:test (default-test) @ api-i18n ---
  [INFO] Tests are skipped.
  [INFO] 
  [INFO] --- maven-jar-plugin:2.4:jar (default-jar) @ api-i18n ---
  [INFO] Building jar: 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/i18n/target/api-i18n-1.0.0-M20.jar
  [INFO]                                                                        
 
  [INFO] 
------------------------------------------------------------------------
  [INFO] Building Apache Directory LDAP API Utilities 1.0.0-M20
  [INFO] 
------------------------------------------------------------------------
  [INFO] 
  [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ 
api-util ---
  [WARNING] Using platform encoding (ANSI_X3.4-1968 actually) to copy filtered 
resources, i.e. build is platform dependent!
  [INFO] Copying 0 resource
  [INFO] 
  [INFO] --- maven-compiler-plugin:3.2:compile (default-compile) @ api-util ---
  [INFO] Changes detected - recompiling the module!
  [WARNING] File encoding has not been set, using platform encoding 
ANSI_X3.4-1968, i.e. build is platform dependent!
  [INFO] Compiling 32 source files to 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/util/target/classes
  [INFO] 
  [INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ 
api-util ---
  [INFO] Not copying test resources
  [INFO] 
  [INFO] --- maven-compiler-plugin:3.2:testCompile (default-testCompile) @ 
api-util ---
  [INFO] Not compiling test sources
  [INFO] 
  [INFO] --- maven-surefire-plugin:2.17:test (default-test) @ api-util ---
  [INFO] Tests are skipped.
  [INFO] 
  [INFO] --- maven-jar-plugin:2.4:jar (default-jar) @ api-util ---
  [INFO] Building jar: 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/util/target/api-util-1.0.0-M20.jar
  [INFO]                                                                        
 
  [INFO] 
------------------------------------------------------------------------
  [INFO] Building Apache Directory API ASN.1 Parent 1.0.0-M20
  [INFO] 
------------------------------------------------------------------------
  [INFO]                                                                        
 
  [INFO] 
------------------------------------------------------------------------
  [INFO] Building Apache Directory API ASN.1 API 1.0.0-M20
  [INFO] 
------------------------------------------------------------------------
  [INFO] 
  [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ 
api-asn1-api ---
  [WARNING] Using platform encoding (ANSI_X3.4-1968 actually) to copy filtered 
resources, i.e. build is platform dependent!
  [INFO] Copying 0 resource
  [INFO] 
  [INFO] --- maven-compiler-plugin:3.2:compile (default-compile) @ api-asn1-api 
---
  [INFO] Changes detected - recompiling the module!
  [WARNING] File encoding has not been set, using platform encoding 
ANSI_X3.4-1968, i.e. build is platform dependent!
  [INFO] Compiling 9 source files to 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/api/target/classes
  [INFO] 
  [INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ 
api-asn1-api ---
  [INFO] Not copying test resources
  [INFO] 
  [INFO] --- maven-compiler-plugin:3.2:testCompile (default-testCompile) @ 
api-asn1-api ---
  [INFO] Not compiling test sources
  [INFO] 
  [INFO] --- maven-surefire-plugin:2.17:test (default-test) @ api-asn1-api ---
  [INFO] Tests are skipped.
  [INFO] 
  [INFO] --- maven-jar-plugin:2.4:jar (default-jar) @ api-asn1-api ---
  [INFO] Building jar: 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/api/target/api-asn1-api-1.0.0-M20.jar
  [INFO]                                                                        
 
  [INFO] 
------------------------------------------------------------------------
  [INFO] Building Apache Directory API ASN.1 BER 1.0.0-M20
  [INFO] 
------------------------------------------------------------------------
  [INFO] 
  [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ 
api-asn1-ber ---
  [WARNING] Using platform encoding (ANSI_X3.4-1968 actually) to copy filtered 
resources, i.e. build is platform dependent!
  [INFO] Copying 0 resource
  [INFO] 
  [INFO] --- maven-compiler-plugin:3.2:compile (default-compile) @ api-asn1-ber 
---
  [INFO] Changes detected - recompiling the module!
  [WARNING] File encoding has not been set, using platform encoding 
ANSI_X3.4-1968, i.e. build is platform dependent!
  [INFO] Compiling 24 source files to 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/ber/target/classes
  [INFO] 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/ber/src/main/java/org/apache/directory/api/asn1/ber/tlv/BerValue.java:
 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/ber/src/main/java/org/apache/directory/api/asn1/ber/tlv/BerValue.java
 uses or overrides a deprecated API.
  [INFO] 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/ber/src/main/java/org/apache/directory/api/asn1/ber/tlv/BerValue.java:
 Recompile with -Xlint:deprecation for details.
  [INFO] 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/ber/src/main/java/org/apache/directory/api/asn1/ber/Asn1Decoder.java:
 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/ber/src/main/java/org/apache/directory/api/asn1/ber/Asn1Decoder.java
 uses unchecked or unsafe operations.
  [INFO] 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/ber/src/main/java/org/apache/directory/api/asn1/ber/Asn1Decoder.java:
 Recompile with -Xlint:unchecked for details.
  [INFO] 
  [INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ 
api-asn1-ber ---
  [INFO] Not copying test resources
  [INFO] 
  [INFO] --- maven-compiler-plugin:3.2:testCompile (default-testCompile) @ 
api-asn1-ber ---
  [INFO] Not compiling test sources
  [INFO] 
  [INFO] --- maven-surefire-plugin:2.17:test (default-test) @ api-asn1-ber ---
  [INFO] Tests are skipped.
  [INFO] 
  [INFO] --- maven-jar-plugin:2.4:jar (default-jar) @ api-asn1-ber ---
  [INFO] Building jar: 
/home/lamby/temp/cdt.20160628210709.ymP6nguDmT.apache-directory-api/apache-directory-api-1.0.0~M20/asn1/ber/target/api-asn1-ber-1.0.0-M20.jar
  [INFO]                                                                        
 
  [INFO] 
------------------------------------------------------------------------
  [INFO] Building Apache Directory LDAP API Parent 1.0.0-M20
  [INFO] 
------------------------------------------------------------------------
  [INFO]                                                                        
 
  [INFO] 
------------------------------------------------------------------------
  [INFO] Building Apache Directory LDAP API Model 1.0.0-M20
  [INFO] 
------------------------------------------------------------------------
  [WARNING] The POM for antlr:antlr:jar:2.x is missing, no dependency 
information available
  [INFO] 
------------------------------------------------------------------------
  [INFO] Reactor Summary:
  [INFO] 
  [INFO] Apache Directory LDAP API .......................... SUCCESS [  0.003 
s]
  [INFO] Apache Directory LDAP API I18n ..................... SUCCESS [  1.556 
s]
  [INFO] Apache Directory LDAP API Utilities ................ SUCCESS [  0.981 
s]
  [INFO] Apache Directory API ASN.1 Parent .................. SUCCESS [  0.001 
s]
  [INFO] Apache Directory API ASN.1 API ..................... SUCCESS [  0.195 
s]
  [INFO] Apache Directory API ASN.1 BER ..................... SUCCESS [  0.253 
s]
  [INFO] Apache Directory LDAP API Parent ................... SUCCESS [  0.000 
s]
  [INFO] Apache Directory LDAP API Model .................... FAILURE [  0.017 
s]
  [INFO] Apache Directory LDAP API Codec Parent ............. SKIPPED
  [INFO] Apache Directory LDAP API Codec Core ............... SKIPPED
  [INFO] Apache Directory LDAP API Net Parent ............... SKIPPED
  [INFO] Apache Directory LDAP API Network MINA ............. SKIPPED
  [INFO] Apache Directory LDAP API Codec Standalone ......... SKIPPED
  [INFO] Apache Directory LDAP API DSML Parent .............. SKIPPED
  [INFO] Apache Directory LDAP API DSML Parser .............. SKIPPED
  [INFO] Apache Directory LDAP API Extras ................... SKIPPED
  [INFO] Apache Directory LDAP API Extras ACI ............... SKIPPED
  [INFO] Apache Directory LDAP API Schema Parent ............ SKIPPED
  [INFO] Apache Directory LDAP API Schema Data .............. SKIPPED
  [INFO] Apache Directory LDAP API Client Parent ............ SKIPPED
  [INFO] Apache Directory LDAP API Client API ............... SKIPPED
  [INFO] Apache Directory LDAP API DSML Engine .............. SKIPPED
  [INFO] Apache Directory LDAP API Extras Codec API ......... SKIPPED
  [INFO] Apache Directory LDAP API Extras Codec ............. SKIPPED
  [INFO] Apache Directory LDAP API Extras Util .............. SKIPPED
  [INFO] Apache Directory LDAP API Extras Stored Procedures . SKIPPED
  [INFO] Apache Directory LDAP API Extras Trigger ........... SKIPPED
  [INFO] Apache Directory LDAP API Schema Converter ......... SKIPPED
  [INFO] Apache Directory API All ........................... SKIPPED
  [INFO] 
------------------------------------------------------------------------
  [INFO] BUILD FAILURE
  [INFO] 
------------------------------------------------------------------------
  [INFO] Total time: 3.453 s
  [INFO] Finished at: 2016-06-28T21:09:27+02:00
  [INFO] Final Memory: 19M/311M
  [INFO] 
------------------------------------------------------------------------
  [ERROR] Failed to execute goal on project api-ldap-model: Could not resolve 
dependencies for project org.apache.directory.api:api-ldap-model:jar:1.0.0-M20: 
Cannot access central (https://repo.maven.apache.org/maven2) in offline mode 
and the artifact antlr:antlr:jar:2.x has not been downloaded from it before. -> 
[Help 1]
  [ERROR] 
  [ERROR] To see the full stack trace of the errors, re-run Maven with the -e 
switch.
  [ERROR] Re-run Maven using the -X switch to enable full debug logging.
  [ERROR] 
  [ERROR] For more information about the errors and possible solutions, please 
read the following articles:
  [ERROR] [Help 1] 
http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
  [ERROR] 
  [ERROR] After correcting the problems, you can resume the build with the 
command
  [ERROR]   mvn <goals> -rf :api-ldap-model
  /usr/share/cdbs/1/class/maven.mk:92: recipe for target 'mvn-build' failed
  make: *** [mvn-build] Error 1

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: apache-directory-api.1.0.0~M20-3.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to