Source: libapache-htpasswd-perl
Version: 1.8-1.1
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

libapache-htpasswd-perl fails to build from source in unstable/amd64:

  [..]

  
  
**************************************************************************************
  ** Starting build                                                             
      **
  
**************************************************************************************
  
   Package:              libapache-htpasswd-perl
   Version:              1.8-1.1
   Build architecture:   amd64
   Date:                 Fri, 01 Jul 2016 10:25:20 +0200
   Hostname:             181df15f8f76
   Uname:                Linux 181df15f8f76 4.6.0-1-amd64 #1 SMP Debian 4.6.2-2 
(2016-06-25) x86_64 GNU/Linux
   /etc/timezone:        Africa/Johannesburg
  
  
**************************************************************************************
  ** Installing build dependencies                                              
      **
  
**************************************************************************************
  
  dh_testdir
  dh_testroot
  dh_prep
  dh_testdir
  dh_testroot
  dh_install
  dh_installdocs
  dh_installchangelogs
  dh_compress
  dh_fixperms
  dh_installdeb
  dh_gencontrol
  dh_md5sums
  dh_builddeb
  dpkg-deb: building package 'libapache-htpasswd-perl-build-deps' in 
'../libapache-htpasswd-perl-build-deps_1.8-1.1_all.deb'.
  
  The package has been created.
  Attention, the package has been created in the current directory,
  not in ".." as indicated by the message above!
  Selecting previously unselected package libapache-htpasswd-perl-build-deps.
  (Reading database ... 23081 files and directories currently installed.)
  Preparing to unpack libapache-htpasswd-perl-build-deps_1.8-1.1_all.deb ...
  Unpacking libapache-htpasswd-perl-build-deps (1.8-1.1) ...
  Reading package lists...
  Building dependency tree...
  Reading state information...
  Correcting dependencies... Done
  The following additional packages will be installed:
    cdbs libcrypt-passwdmd5-perl
  The following NEW packages will be installed:
    cdbs libcrypt-passwdmd5-perl
  0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
  1 not fully installed or removed.
  Need to get 91.2 kB of archives.
  After this operation, 341 kB of additional disk space will be used.
  Get:1 http://httpredir.debian.org/debian sid/main amd64 cdbs all 0.4.142 
[80.7 kB]
  Get:2 http://httpredir.debian.org/debian sid/main amd64 
libcrypt-passwdmd5-perl all 1.3-10 [10.5 kB]
  Fetched 91.2 kB in 0s (0 B/s)
  Selecting previously unselected package cdbs.
  (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 23085 files and directories currently installed.)
  Preparing to unpack .../archives/cdbs_0.4.142_all.deb ...
  Unpacking cdbs (0.4.142) ...
  Selecting previously unselected package libcrypt-passwdmd5-perl.
  Preparing to unpack .../libcrypt-passwdmd5-perl_1.3-10_all.deb ...
  Unpacking libcrypt-passwdmd5-perl (1.3-10) ...
  Processing triggers for man-db (2.7.5-1) ...
  Setting up cdbs (0.4.142) ...
  Setting up libcrypt-passwdmd5-perl (1.3-10) ...
  Setting up libapache-htpasswd-perl-build-deps (1.8-1.1) ...
  
  
**************************************************************************************
  ** Environment                                                                
      **
  
**************************************************************************************
  
  
PATH=/home/lamby/git/projects/dotfiles/dotfiles/..//bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
  HOSTNAME=181df15f8f76
  TERM=xterm
  PAGER=more
  DISPLAY=:0
  DOCKER_IMAGE=lamby-debian-sid
  DEB_BUILD_OPTIONS=parallel=9
  PIP_DOWNLOAD_CACHE=/home/lamby/.cache/pip
  HOME=/home/lamby
  LOGNAME=lamby
  SHLVL=1
  
PWD=/home/lamby/temp/cdt.20160701102518.MLxrRVHm9O.libapache-htpasswd-perl/libapache-htpasswd-perl-1.8
  OLDPWD=/home/lamby/temp/cdt.20160701102518.MLxrRVHm9O.libapache-htpasswd-perl
  GPG_TTY=/dev/console
  QUILT_PATCHES=debian/patches
  QUILT_NO_DIFF_INDEX=1
  QUILT_REFRESH_ARGS=-p ab --no-timestamps --no-index
  DEBEMAIL=la...@debian.org
  DEBFULLNAME=Chris Lamb
  EDITOR=vim
  LESS=-cgiFx4M
  BLASTER=A220 I5 D1 H5 P330 T6
  _=/usr/bin/env
  
  
**************************************************************************************
  ** Building libapache-htpasswd-perl 1.8-1.1 on amd64                          
      **
  
**************************************************************************************
  
   dpkg-buildpackage -rfakeroot -D -us -uc -b
  dpkg-buildpackage: info: source package libapache-htpasswd-perl
  dpkg-buildpackage: info: source version 1.8-1.1
  dpkg-buildpackage: info: source distribution unstable
  dpkg-buildpackage: info: source changed by Salvatore Bonaccorso 
<car...@debian.org>
   dpkg-source --before-build libapache-htpasswd-perl-1.8
  dpkg-buildpackage: info: host architecture amd64
   fakeroot debian/rules clean
  CDBS WARNING:   perlmodule.mk is deprecated since 0.4.72 - please use 
perl-makemaker.mk instead
  CDBS WARNING:   perlmodule-vars.mk is deprecated since 0.4.72 - please use 
perl-makemaker-vars.mk instead
  test -x debian/rules
  rm -f debian/stamp-makefile-build debian/stamp-makefile-install
  /usr/bin/make -C . OPTIMIZE="-g -O2 -fstack-protector-strong -Wformat 
-Werror=format-security -D_REENTRANT -D_GNU_SOURCE -DDEBIAN -fwrapv 
-fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE 
-D_FILE_OFFSET_BITS=64 -Wdate-time -D_FORTIFY_SOURCE=2 -D_REENTRANT 
-D_GNU_SOURCE -DDEBIAN -fwrapv -fno-strict-aliasing -pipe -I/usr/local/include" 
LDDLFLAGS="-Wl,-z,relro -shared -L/usr/local/lib -fstack-protector-strong" -k 
distclean
  make[1]: Entering directory 
'/home/lamby/temp/cdt.20160701102518.MLxrRVHm9O.libapache-htpasswd-perl/libapache-htpasswd-perl-1.8'
  make[1]: *** No rule to make target 'distclean'.
  make[1]: Leaving directory 
'/home/lamby/temp/cdt.20160701102518.MLxrRVHm9O.libapache-htpasswd-perl/libapache-htpasswd-perl-1.8'
  /usr/share/cdbs/1/class/makefile.mk:91: recipe for target 'makefile-clean' 
failed
  make: [makefile-clean] Error 2 (ignored)
  rm -f debian/stamp-makefile-check
  dh_clean 
  dh_clean: Please specify the compatibility level in debian/compat
  /usr/share/cdbs/1/rules/debhelper.mk:217: recipe for target 'clean' failed
  make: *** [clean] Error 2

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: libapache-htpasswd-perl.1.8-1.1.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to