Source: ruby-grape-msgpack
Version: 0.1.2-2
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

ruby-grape-msgpack fails to build from source in unstable/amd64:

  [..]

  Unpacking libyaml-0-2:amd64 (0.1.6-3) ...
  Selecting previously unselected package libruby2.3:amd64.
  Preparing to unpack .../libruby2.3_2.3.1-5_amd64.deb ...
  Unpacking libruby2.3:amd64 (2.3.1-5) ...
  Selecting previously unselected package ruby2.3.
  Preparing to unpack .../ruby2.3_2.3.1-5_amd64.deb ...
  Unpacking ruby2.3 (2.3.1-5) ...
  Selecting previously unselected package ruby.
  Preparing to unpack .../ruby_1%3a2.3.0+4_amd64.deb ...
  Unpacking ruby (1:2.3.0+4) ...
  Selecting previously unselected package rake.
  Preparing to unpack .../archives/rake_10.5.0-2_all.deb ...
  Unpacking rake (10.5.0-2) ...
  Selecting previously unselected package gem2deb-test-runner.
  Preparing to unpack .../gem2deb-test-runner_0.31_amd64.deb ...
  Unpacking gem2deb-test-runner (0.31) ...
  Selecting previously unselected package libgmpxx4ldbl:amd64.
  Preparing to unpack .../libgmpxx4ldbl_2%3a6.1.1+dfsg-1_amd64.deb ...
  Unpacking libgmpxx4ldbl:amd64 (2:6.1.1+dfsg-1) ...
  Selecting previously unselected package libgmp-dev:amd64.
  Preparing to unpack .../libgmp-dev_2%3a6.1.1+dfsg-1_amd64.deb ...
  Unpacking libgmp-dev:amd64 (2:6.1.1+dfsg-1) ...
  Selecting previously unselected package ruby2.3-dev:amd64.
  Preparing to unpack .../ruby2.3-dev_2.3.1-5_amd64.deb ...
  Unpacking ruby2.3-dev:amd64 (2.3.1-5) ...
  Selecting previously unselected package ruby-all-dev:amd64.
  Preparing to unpack .../ruby-all-dev_1%3a2.3.0+4_amd64.deb ...
  Unpacking ruby-all-dev:amd64 (1:2.3.0+4) ...
  Selecting previously unselected package ruby-setup.
  Preparing to unpack .../ruby-setup_3.4.1-9_all.deb ...
  Unpacking ruby-setup (3.4.1-9) ...
  Selecting previously unselected package gem2deb.
  Preparing to unpack .../gem2deb_0.31_amd64.deb ...
  Unpacking gem2deb (0.31) ...
  Selecting previously unselected package ruby-i18n.
  Preparing to unpack .../ruby-i18n_0.7.0-2_all.deb ...
  Unpacking ruby-i18n (0.7.0-2) ...
  Selecting previously unselected package ruby-json.
  Preparing to unpack .../ruby-json_1.8.3-1+b3_amd64.deb ...
  Unpacking ruby-json (1.8.3-1+b3) ...
  Selecting previously unselected package ruby-atomic.
  Preparing to unpack .../ruby-atomic_1.1.16-2+b6_amd64.deb ...
  Unpacking ruby-atomic (1.1.16-2+b6) ...
  Selecting previously unselected package ruby-thread-safe.
  Preparing to unpack .../ruby-thread-safe_0.3.5-3_all.deb ...
  Unpacking ruby-thread-safe (0.3.5-3) ...
  Selecting previously unselected package ruby-tzinfo.
  Preparing to unpack .../ruby-tzinfo_1.2.2-1_all.deb ...
  Unpacking ruby-tzinfo (1.2.2-1) ...
  Selecting previously unselected package ruby-activesupport.
  Preparing to unpack .../ruby-activesupport_2%3a4.2.6-1_all.deb ...
  Unpacking ruby-activesupport (2:4.2.6-1) ...
  Selecting previously unselected package ruby-blankslate.
  Preparing to unpack .../ruby-blankslate_3.1.3-1_all.deb ...
  Unpacking ruby-blankslate (3.1.3-1) ...
  Selecting previously unselected package ruby-builder.
  Preparing to unpack .../ruby-builder_3.2.2-4_all.deb ...
  Unpacking ruby-builder (3.2.2-4) ...
  Selecting previously unselected package ruby-hashie.
  Preparing to unpack .../ruby-hashie_3.4.4-1_all.deb ...
  Unpacking ruby-hashie (3.4.4-1) ...
  Selecting previously unselected package ruby-multi-json.
  Preparing to unpack .../ruby-multi-json_1.11.2-3_all.deb ...
  Unpacking ruby-multi-json (1.11.2-3) ...
  Selecting previously unselected package ruby-multi-xml.
  Preparing to unpack .../ruby-multi-xml_0.5.5-2_all.deb ...
  Unpacking ruby-multi-xml (0.5.5-2) ...
  Selecting previously unselected package ruby-mustermann19.
  Preparing to unpack .../ruby-mustermann19_0.4.3+git20160621-1_all.deb ...
  Unpacking ruby-mustermann19 (0.4.3+git20160621-1) ...
  Selecting previously unselected package ruby-rack.
  Preparing to unpack .../ruby-rack_1.6.4-3_all.deb ...
  Unpacking ruby-rack (1.6.4-3) ...
  Selecting previously unselected package ruby-rack-accept.
  Preparing to unpack .../ruby-rack-accept_0.4.5-3_all.deb ...
  Unpacking ruby-rack-accept (0.4.5-3) ...
  Selecting previously unselected package ruby-descendants-tracker.
  Preparing to unpack .../ruby-descendants-tracker_0.0.4-2_all.deb ...
  Unpacking ruby-descendants-tracker (0.0.4-2) ...
  Selecting previously unselected package ruby-ice-nine.
  Preparing to unpack .../ruby-ice-nine_0.11.2-1_all.deb ...
  Unpacking ruby-ice-nine (0.11.2-1) ...
  Selecting previously unselected package ruby-axiom-types.
  Preparing to unpack .../ruby-axiom-types_0.1.1-1_all.deb ...
  Unpacking ruby-axiom-types (0.1.1-1) ...
  Selecting previously unselected package ruby-coercible.
  Preparing to unpack .../ruby-coercible_1.0.0-2_all.deb ...
  Unpacking ruby-coercible (1.0.0-2) ...
  Selecting previously unselected package ruby-equalizer.
  Preparing to unpack .../ruby-equalizer_0.0.10-1_all.deb ...
  Unpacking ruby-equalizer (0.0.10-1) ...
  Selecting previously unselected package ruby-virtus.
  Preparing to unpack .../ruby-virtus_1.0.5-2_all.deb ...
  Unpacking ruby-virtus (1.0.5-2) ...
  Selecting previously unselected package ruby-grape.
  Preparing to unpack .../ruby-grape_0.16.2-1_all.deb ...
  Unpacking ruby-grape (0.16.2-1) ...
  Selecting previously unselected package ruby-grape-entity.
  Preparing to unpack .../ruby-grape-entity_0.5.1-2_all.deb ...
  Unpacking ruby-grape-entity (0.5.1-2) ...
  Selecting previously unselected package ruby-msgpack.
  Preparing to unpack .../ruby-msgpack_0.6.2-1+b3_amd64.deb ...
  Unpacking ruby-msgpack (0.6.2-1+b3) ...
  Selecting previously unselected package ruby-rack-test.
  Preparing to unpack .../ruby-rack-test_0.6.3-1_all.deb ...
  Unpacking ruby-rack-test (0.6.3-1) ...
  Selecting previously unselected package ruby-diff-lcs.
  Preparing to unpack .../ruby-diff-lcs_1.2.5-2_all.deb ...
  Unpacking ruby-diff-lcs (1.2.5-2) ...
  Selecting previously unselected package ruby-rspec-support.
  Preparing to unpack .../ruby-rspec-support_3.4.0c3e0m1s1-1_all.deb ...
  Unpacking ruby-rspec-support (3.4.0c3e0m1s1-1) ...
  Selecting previously unselected package ruby-rspec-expectations.
  Preparing to unpack .../ruby-rspec-expectations_3.4.0c3e0m1s1-1_all.deb ...
  Unpacking ruby-rspec-expectations (3.4.0c3e0m1s1-1) ...
  Selecting previously unselected package ruby-rspec-mocks.
  Preparing to unpack .../ruby-rspec-mocks_3.4.0c3e0m1s1-1_all.deb ...
  Unpacking ruby-rspec-mocks (3.4.0c3e0m1s1-1) ...
  Selecting previously unselected package ruby-thread-order.
  Preparing to unpack .../ruby-thread-order_1.1.0-1_all.deb ...
  Unpacking ruby-thread-order (1.1.0-1) ...
  Selecting previously unselected package ruby-rspec-core.
  Preparing to unpack .../ruby-rspec-core_3.4.0c3e0m1s1-1_all.deb ...
  Unpacking ruby-rspec-core (3.4.0c3e0m1s1-1) ...
  Selecting previously unselected package ruby-rspec.
  Preparing to unpack .../ruby-rspec_3.4.0c3e0m1s1-1_all.deb ...
  Unpacking ruby-rspec (3.4.0c3e0m1s1-1) ...
  Processing triggers for man-db (2.7.5-1) ...
  Processing triggers for libc-bin (2.23-1) ...
  Setting up ruby-did-you-mean (1.0.0-2) ...
  Setting up libyaml-0-2:amd64 (0.1.6-3) ...
  Setting up openssl (1.0.2h-1) ...
  Setting up ruby-net-telnet (0.1.1-2) ...
  Setting up libgmpxx4ldbl:amd64 (2:6.1.1+dfsg-1) ...
  Setting up ruby-minitest (5.9.0-1) ...
  Setting up ca-certificates (20160104) ...
  Setting up ruby-power-assert (0.3.0-1) ...
  Setting up libgmp-dev:amd64 (2:6.1.1+dfsg-1) ...
  Setting up ruby-test-unit (3.1.7-2) ...
  Setting up rubygems-integration (1.10) ...
  Setting up rake (10.5.0-2) ...
  Setting up libruby2.3:amd64 (2.3.1-5) ...
  Setting up ruby2.3 (2.3.1-5) ...
  Setting up ruby2.3-dev:amd64 (2.3.1-5) ...
  Setting up ruby (1:2.3.0+4) ...
  Setting up ruby-diff-lcs (1.2.5-2) ...
  Setting up gem2deb-test-runner (0.31) ...
  Setting up ruby-json (1.8.3-1+b3) ...
  Setting up ruby-rack (1.6.4-3) ...
  Setting up ruby-hashie (3.4.4-1) ...
  Setting up ruby-all-dev:amd64 (1:2.3.0+4) ...
  Setting up ruby-multi-json (1.11.2-3) ...
  Setting up ruby-ice-nine (0.11.2-1) ...
  Setting up ruby-mustermann19 (0.4.3+git20160621-1) ...
  Setting up ruby-rack-test (0.6.3-1) ...
  Setting up ruby-thread-order (1.1.0-1) ...
  Setting up ruby-rspec-support (3.4.0c3e0m1s1-1) ...
  Setting up ruby-atomic (1.1.16-2+b6) ...
  Setting up ruby-setup (3.4.1-9) ...
  Setting up ruby-thread-safe (0.3.5-3) ...
  Setting up ruby-i18n (0.7.0-2) ...
  Setting up ruby-equalizer (0.0.10-1) ...
  Setting up ruby-multi-xml (0.5.5-2) ...
  Setting up ruby-msgpack (0.6.2-1+b3) ...
  Setting up ruby-tzinfo (1.2.2-1) ...
  Setting up ruby-blankslate (3.1.3-1) ...
  Setting up ruby-rack-accept (0.4.5-3) ...
  Setting up gem2deb (0.31) ...
  Setting up ruby-activesupport (2:4.2.6-1) ...
  Setting up ruby-grape-entity (0.5.1-2) ...
  Setting up ruby-rspec-expectations (3.4.0c3e0m1s1-1) ...
  Setting up ruby-rspec-mocks (3.4.0c3e0m1s1-1) ...
  Setting up ruby-descendants-tracker (0.0.4-2) ...
  Setting up ruby-rspec-core (3.4.0c3e0m1s1-1) ...
  Setting up ruby-coercible (1.0.0-2) ...
  Setting up ruby-builder (3.2.2-4) ...
  Setting up ruby-axiom-types (0.1.1-1) ...
  Setting up ruby-rspec (3.4.0c3e0m1s1-1) ...
  Setting up ruby-virtus (1.0.5-2) ...
  Setting up ruby-grape (0.16.2-1) ...
  Setting up ruby-grape-msgpack-build-deps (0.1.2-2) ...
  Processing triggers for libc-bin (2.23-1) ...
  Processing triggers for ca-certificates (20160104) ...
  Updating certificates in /etc/ssl/certs...
  173 added, 0 removed; done.
  Running hooks in /etc/ca-certificates/update.d...
  done.
  
  
**************************************************************************************
  ** Environment                                                                
      **
  
**************************************************************************************
  
  
PATH=/home/lamby/git/projects/dotfiles/dotfiles/..//bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
  HOSTNAME=3f02132accc9
  TERM=xterm
  PAGER=more
  DISPLAY=:0
  DOCKER_IMAGE=lamby-debian-sid
  DEB_BUILD_OPTIONS=parallel=9
  PIP_DOWNLOAD_CACHE=/home/lamby/.cache/pip
  HOME=/home/lamby
  LOGNAME=lamby
  SHLVL=1
  
PWD=/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2
  OLDPWD=/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack
  GPG_TTY=/dev/console
  QUILT_PATCHES=debian/patches
  QUILT_NO_DIFF_INDEX=1
  QUILT_REFRESH_ARGS=-p ab --no-timestamps --no-index
  DEBEMAIL=la...@debian.org
  DEBFULLNAME=Chris Lamb
  EDITOR=vim
  LESS=-cgiFx4M
  BLASTER=A220 I5 D1 H5 P330 T6
  _=/usr/bin/env
  
  
**************************************************************************************
  ** Building ruby-grape-msgpack 0.1.2-2 on amd64                               
      **
  
**************************************************************************************
  
   dpkg-buildpackage -rfakeroot -D -us -uc -b
  dpkg-buildpackage: info: source package ruby-grape-msgpack
  dpkg-buildpackage: info: source version 0.1.2-2
  dpkg-buildpackage: info: source distribution unstable
  dpkg-buildpackage: info: source changed by Hleb Valoshka <375...@gmail.com>
   dpkg-source --before-build ruby-grape-msgpack-0.1.2
  dpkg-buildpackage: info: host architecture amd64
   fakeroot debian/rules clean
  dh clean --buildsystem=ruby --with ruby
     dh_testdir -O--buildsystem=ruby
     dh_auto_clean -O--buildsystem=ruby
        dh_ruby --clean
     dh_ruby --clean
     dh_clean -O--buildsystem=ruby
   debian/rules build
  dh build --buildsystem=ruby --with ruby
     dh_testdir -O--buildsystem=ruby
     dh_update_autotools_config -O--buildsystem=ruby
     dh_auto_configure -O--buildsystem=ruby
        dh_ruby --configure
     dh_auto_build -O--buildsystem=ruby
        dh_ruby --build
     dh_ruby --build
     dh_auto_test -O--buildsystem=ruby
        dh_ruby --test
   fakeroot debian/rules binary
  dh binary --buildsystem=ruby --with ruby
     dh_testroot -O--buildsystem=ruby
     dh_prep -O--buildsystem=ruby
     dh_auto_install -O--buildsystem=ruby
        dh_ruby --install 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/debian/ruby-grape-msgpack
     dh_ruby --install
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Install files                                                               
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  install -d 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/debian/ruby-grape-msgpack/usr/lib/ruby/vendor_ruby
  install -D -m644 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/lib/grape-msgpack.rb
 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/debian/ruby-grape-msgpack/usr/lib/ruby/vendor_ruby/grape-msgpack.rb
  install -D -m644 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/lib/grape/msgpack.rb
 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/debian/ruby-grape-msgpack/usr/lib/ruby/vendor_ruby/grape/msgpack.rb
  install -D -m644 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/lib/grape/msgpack/version.rb
 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/debian/ruby-grape-msgpack/usr/lib/ruby/vendor_ruby/grape/msgpack/version.rb
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Install Rubygems integration metadata                                       
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  generating gemspec at 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/debian/ruby-grape-msgpack/usr/share/rubygems-integration/all/specifications/grape-msgpack-0.1.2.gemspec
  /usr/bin/ruby2.3 /usr/bin/gem2deb-test-runner
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Checking Rubygems dependency resolution on ruby2.3                          
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  
GEM_PATH=debian/ruby-grape-msgpack/usr/share/rubygems-integration/all:/home/lamby/.gem/ruby/2.3.0:/var/lib/gems/2.3.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.3.0:/usr/share/rubygems-integration/2.3.0:/usr/share/rubygems-integration/all
 ruby2.3 -e gem\ \"grape-msgpack\"
  
  
┌──────────────────────────────────────────────────────────────────────────────┐
  │ Run tests for ruby2.3 from debian/ruby-tests.rake                           
 │
  
└──────────────────────────────────────────────────────────────────────────────┘
  
  
RUBYLIB=/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/debian/ruby-grape-msgpack/usr/lib/ruby/vendor_ruby:.
 
GEM_PATH=debian/ruby-grape-msgpack/usr/share/rubygems-integration/all:/home/lamby/.gem/ruby/2.3.0:/var/lib/gems/2.3.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.3.0:/usr/share/rubygems-integration/2.3.0:/usr/share/rubygems-integration/all
 ruby2.3 -S rake -f debian/ruby-tests.rake
  /usr/bin/ruby2.3 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb --format 
documentation
  
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/lib/grape/msgpack.rb:39:in
 `<top (required)>': uninitialized constant Grape::Formatter::Base (NameError)
  Did you mean?  Base64
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
`require'
        from 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/spec/grape/msgpack_spec.rb:4:in
 `<top (required)>'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1361:in 
`load'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1361:in 
`block in load_spec_files'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1359:in 
`each'
        from /usr/lib/ruby/vendor_ruby/rspec/core/configuration.rb:1359:in 
`load_spec_files'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:106:in `setup'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:92:in `run'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:78:in `run'
        from /usr/lib/ruby/vendor_ruby/rspec/core/runner.rb:45:in `invoke'
        from /usr/bin/rspec:4:in `<main>'
  /usr/bin/ruby2.3 /usr/bin/rspec --pattern ./spec/\*\*/\*_spec.rb --format 
documentation failed
  ERROR: Test "ruby2.3" failed. Exiting.
  dh_auto_install: dh_ruby --install 
/home/lamby/temp/cdt.20160711222121.kc4OgnK1Sy.ruby-grape-msgpack/ruby-grape-msgpack-0.1.2/debian/ruby-grape-msgpack
 returned exit code 1
  debian/rules:18: recipe for target 'binary' failed
  make: *** [binary] Error 1

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: ruby-grape-msgpack.0.1.2-2.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to