Your message dated Tue, 19 Jul 2016 15:39:50 -0400
with message-id 
and subject line [Reproducible-builds] Bug#829113: Bug#829113: reprotest: 
Should unset $DISPLAY to avoid GUI popups from some build tools
has caused the Debian Bug report #829113,
regarding reprotest: Should unset $DISPLAY to avoid GUI popups from some build 
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: reprotest
Version: 0.1

Dear Maintainer,

   * What led up to the situation?

Testing my package dpmb with reprotest.

   * What exactly did you do (or not do) that was effective (or


$ reprotest 'dpkg-buildpackage -b' 

from a git checkout of commit 5f069a920df4e6f20a8eb9309c20c39ad60e6132
under X to see if my $SOURCE_DATE_EPOCH implementation in that commit is
working correctly.

   * What was the outcome of this action?

Two GUI popups from ebook-convert (from the package calibre) moaning
about non-existent $HOME and hence unreadable $HOME/.config/…

   * What outcome did you expect instead?

No interactivity, especially no GUI interactivity at all.

Unsetting $DISPLAY should this issue.

(I'm not sure if setting and not setting $DISPLAY is or should be one of
the not explicitly listed variations. But since I got that popup twice,
I assume not.)

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (600, 'testing'), (500, 'unstable-debug'), 
(500, 'buildd-unstable'), (110, 'experimental'), (1, 'experimental-debug'), (1, 
Architecture: amd64 (x86_64)

Kernel: Linux 4.6.0-trunk-amd64 (SMP w/8 CPU cores)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages reprotest depends on:
ii  apt-utils       1.2.14
ii  diffoscope      54
ii  libdpkg-perl    1.18.7
ii  procps          2:3.3.11-3
ii  python3-debian  0.1.28
pn  python3:any     <none>

Versions of packages reprotest recommends:
ii  autodep8  0.6

reprotest suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
I'm setting this specific bug as wontfix.  reprotest, to the extent
possible while still testing reproducibility, tries to simulate the
environment that it's called in, so that calling reprotest with a build
command is similar to calling the build command without reprotest.
Changing specific environment variable values is up to the build tools, the
source itself, or the one building the software.  I'll ask the mailing list
if it's better to set $HOME to an existing or nonexisting directory.

--- End Message ---
Reproducible-builds mailing list

Reply via email to