Source: nurpawiki
Version: 1.2.3-9
Severity: serious
Justification: fails to build from source
User: reproducible-builds@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-builds@lists.alioth.debian.org

Dear Maintainer,

nurpawiki fails to build from source in unstable/amd64. Looks like something
has dropped a dependency on `camlp4`… 

  [..]

  Unpacking libfindlib-ocaml-dev (1.6.2-1) ...
  Selecting previously unselected package libreact-ocaml.
  Preparing to unpack .../22-libreact-ocaml_1.2.0-2_amd64.deb ...
  Unpacking libreact-ocaml (1.2.0-2) ...
  Selecting previously unselected package libev4.
  Preparing to unpack .../23-libev4_1%3a4.22-1_amd64.deb ...
  Unpacking libev4 (1:4.22-1) ...
  Selecting previously unselected package liblwt-ocaml.
  Preparing to unpack .../24-liblwt-ocaml_2.5.2-1_amd64.deb ...
  Unpacking liblwt-ocaml (2.5.2-1) ...
  Selecting previously unselected package libreactivedata-ocaml.
  Preparing to unpack .../25-libreactivedata-ocaml_0.1-2_amd64.deb ...
  Unpacking libreactivedata-ocaml (0.1-2) ...
  Selecting previously unselected package libuutf-ocaml.
  Preparing to unpack .../26-libuutf-ocaml_0.9.4-2_amd64.deb ...
  Unpacking libuutf-ocaml (0.9.4-2) ...
  Selecting previously unselected package libtyxml-ocaml.
  Preparing to unpack .../27-libtyxml-ocaml_3.5.0-1_amd64.deb ...
  Unpacking libtyxml-ocaml (3.5.0-1) ...
  Selecting previously unselected package libjs-of-ocaml.
  Preparing to unpack .../28-libjs-of-ocaml_2.5-2+b3_amd64.deb ...
  Unpacking libjs-of-ocaml (2.5-2+b3) ...
  Selecting previously unselected package libev-dev.
  Preparing to unpack .../29-libev-dev_1%3a4.22-1_amd64.deb ...
  Unpacking libev-dev (1:4.22-1) ...
  Selecting previously unselected package libreact-ocaml-dev.
  Preparing to unpack .../30-libreact-ocaml-dev_1.2.0-2_amd64.deb ...
  Unpacking libreact-ocaml-dev (1.2.0-2) ...
  Selecting previously unselected package liblwt-ocaml-dev.
  Preparing to unpack .../31-liblwt-ocaml-dev_2.5.2-1_amd64.deb ...
  Unpacking liblwt-ocaml-dev (2.5.2-1) ...
  Selecting previously unselected package libreactivedata-ocaml-dev.
  Preparing to unpack .../32-libreactivedata-ocaml-dev_0.1-2_amd64.deb ...
  Unpacking libreactivedata-ocaml-dev (0.1-2) ...
  Selecting previously unselected package libuutf-ocaml-dev.
  Preparing to unpack .../33-libuutf-ocaml-dev_0.9.4-2_amd64.deb ...
  Unpacking libuutf-ocaml-dev (0.9.4-2) ...
  Selecting previously unselected package libtyxml-ocaml-dev.
  Preparing to unpack .../34-libtyxml-ocaml-dev_3.5.0-1_amd64.deb ...
  Unpacking libtyxml-ocaml-dev (3.5.0-1) ...
  Selecting previously unselected package libjs-of-ocaml-dev.
  Preparing to unpack .../35-libjs-of-ocaml-dev_2.5-2+b3_amd64.deb ...
  Unpacking libjs-of-ocaml-dev (2.5-2+b3) ...
  Selecting previously unselected package libssl-ocaml.
  Preparing to unpack .../36-libssl-ocaml_0.5.2-1_amd64.deb ...
  Unpacking libssl-ocaml (0.5.2-1) ...
  Selecting previously unselected package liblwt-ssl-ocaml.
  Preparing to unpack .../37-liblwt-ssl-ocaml_2.5.2-1_amd64.deb ...
  Unpacking liblwt-ssl-ocaml (2.5.2-1) ...
  Selecting previously unselected package libssl-dev:amd64.
  Preparing to unpack .../38-libssl-dev_1.0.2h-1_amd64.deb ...
  Unpacking libssl-dev:amd64 (1.0.2h-1) ...
  Selecting previously unselected package libssl-ocaml-dev.
  Preparing to unpack .../39-libssl-ocaml-dev_0.5.2-1_amd64.deb ...
  Unpacking libssl-ocaml-dev (0.5.2-1) ...
  Selecting previously unselected package liblwt-ssl-ocaml-dev.
  Preparing to unpack .../40-liblwt-ssl-ocaml-dev_2.5.2-1_amd64.deb ...
  Unpacking liblwt-ssl-ocaml-dev (2.5.2-1) ...
  Selecting previously unselected package libpcre-ocaml.
  Preparing to unpack .../41-libpcre-ocaml_7.2.3-1_amd64.deb ...
  Unpacking libpcre-ocaml (7.2.3-1) ...
  Selecting previously unselected package libzip-ocaml.
  Preparing to unpack .../42-libzip-ocaml_1.05-3+b1_amd64.deb ...
  Unpacking libzip-ocaml (1.05-3+b1) ...
  Selecting previously unselected package libocamlnet-ocaml.
  Preparing to unpack .../43-libocamlnet-ocaml_4.1.2-1_amd64.deb ...
  Unpacking libocamlnet-ocaml (4.1.2-1) ...
  Selecting previously unselected package libpcre16-3:amd64.
  Preparing to unpack .../44-libpcre16-3_2%3a8.39-2_amd64.deb ...
  Unpacking libpcre16-3:amd64 (2:8.39-2) ...
  Selecting previously unselected package libpcre32-3:amd64.
  Preparing to unpack .../45-libpcre32-3_2%3a8.39-2_amd64.deb ...
  Unpacking libpcre32-3:amd64 (2:8.39-2) ...
  Selecting previously unselected package libpcrecpp0v5:amd64.
  Preparing to unpack .../46-libpcrecpp0v5_2%3a8.39-2_amd64.deb ...
  Unpacking libpcrecpp0v5:amd64 (2:8.39-2) ...
  Selecting previously unselected package libpcre3-dev:amd64.
  Preparing to unpack .../47-libpcre3-dev_2%3a8.39-2_amd64.deb ...
  Unpacking libpcre3-dev:amd64 (2:8.39-2) ...
  Selecting previously unselected package libpcre-ocaml-dev.
  Preparing to unpack .../48-libpcre-ocaml-dev_7.2.3-1_amd64.deb ...
  Unpacking libpcre-ocaml-dev (7.2.3-1) ...
  Selecting previously unselected package libzip-ocaml-dev.
  Preparing to unpack .../49-libzip-ocaml-dev_1.05-3+b1_amd64.deb ...
  Unpacking libzip-ocaml-dev (1.05-3+b1) ...
  Selecting previously unselected package libocamlnet-ocaml-dev.
  Preparing to unpack .../50-libocamlnet-ocaml-dev_4.1.2-1_amd64.deb ...
  Unpacking libocamlnet-ocaml-dev (4.1.2-1) ...
  Selecting previously unselected package libgdbm-dev:amd64.
  Preparing to unpack .../51-libgdbm-dev_1.8.3-14_amd64.deb ...
  Unpacking libgdbm-dev:amd64 (1.8.3-14) ...
  Selecting previously unselected package libsqlite3-ocaml.
  Preparing to unpack .../52-libsqlite3-ocaml_4.0.5-1_amd64.deb ...
  Unpacking libsqlite3-ocaml (4.0.5-1) ...
  Selecting previously unselected package libocsigenserver-ocaml.
  Preparing to unpack .../53-libocsigenserver-ocaml_2.7-1+b1_amd64.deb ...
  Unpacking libocsigenserver-ocaml (2.7-1+b1) ...
  Selecting previously unselected package libsqlite3-dev:amd64.
  Preparing to unpack .../54-libsqlite3-dev_3.14.1-1_amd64.deb ...
  Unpacking libsqlite3-dev:amd64 (3.14.1-1) ...
  Selecting previously unselected package libsqlite3-ocaml-dev.
  Preparing to unpack .../55-libsqlite3-ocaml-dev_4.0.5-1_amd64.deb ...
  Unpacking libsqlite3-ocaml-dev (4.0.5-1) ...
  Selecting previously unselected package libocsigenserver-ocaml-dev.
  Preparing to unpack .../56-libocsigenserver-ocaml-dev_2.7-1+b1_amd64.deb ...
  Unpacking libocsigenserver-ocaml-dev (2.7-1+b1) ...
  Selecting previously unselected package libeliom-ocaml-dev.
  Preparing to unpack .../57-libeliom-ocaml-dev_4.2-3_amd64.deb ...
  Unpacking libeliom-ocaml-dev (4.2-3) ...
  Selecting previously unselected package libextlib-ocaml.
  Preparing to unpack .../58-libextlib-ocaml_1.7.0-2+b1_amd64.deb ...
  Unpacking libextlib-ocaml (1.7.0-2+b1) ...
  Selecting previously unselected package libextlib-ocaml-dev.
  Preparing to unpack .../59-libextlib-ocaml-dev_1.7.0-2+b1_amd64.deb ...
  Unpacking libextlib-ocaml-dev (1.7.0-2+b1) ...
  Selecting previously unselected package libpq5:amd64.
  Preparing to unpack .../60-libpq5_9.5.4-1_amd64.deb ...
  Unpacking libpq5:amd64 (9.5.4-1) ...
  Selecting previously unselected package libgssrpc4:amd64.
  Preparing to unpack .../61-libgssrpc4_1.14.3+dfsg-1_amd64.deb ...
  Unpacking libgssrpc4:amd64 (1.14.3+dfsg-1) ...
  Selecting previously unselected package libkdb5-8:amd64.
  Preparing to unpack .../62-libkdb5-8_1.14.3+dfsg-1_amd64.deb ...
  Unpacking libkdb5-8:amd64 (1.14.3+dfsg-1) ...
  Selecting previously unselected package libkadm5srv-mit10:amd64.
  Preparing to unpack .../63-libkadm5srv-mit10_1.14.3+dfsg-1_amd64.deb ...
  Unpacking libkadm5srv-mit10:amd64 (1.14.3+dfsg-1) ...
  Selecting previously unselected package libkadm5clnt-mit10:amd64.
  Preparing to unpack .../64-libkadm5clnt-mit10_1.14.3+dfsg-1_amd64.deb ...
  Unpacking libkadm5clnt-mit10:amd64 (1.14.3+dfsg-1) ...
  Selecting previously unselected package comerr-dev.
  Preparing to unpack .../65-comerr-dev_2.1-1.43.1-1_amd64.deb ...
  Unpacking comerr-dev (2.1-1.43.1-1) ...
  Selecting previously unselected package krb5-multidev.
  Preparing to unpack .../66-krb5-multidev_1.14.3+dfsg-1_amd64.deb ...
  Unpacking krb5-multidev (1.14.3+dfsg-1) ...
  Selecting previously unselected package libpq-dev.
  Preparing to unpack .../67-libpq-dev_9.5.4-1_amd64.deb ...
  Unpacking libpq-dev (9.5.4-1) ...
  Selecting previously unselected package libpostgresql-ocaml.
  Preparing to unpack .../68-libpostgresql-ocaml_2.0.5-2+b1_amd64.deb ...
  Unpacking libpostgresql-ocaml (2.0.5-2+b1) ...
  Selecting previously unselected package libpostgresql-ocaml-dev.
  Preparing to unpack .../69-libpostgresql-ocaml-dev_2.0.5-2+b1_amd64.deb ...
  Unpacking libpostgresql-ocaml-dev (2.0.5-2+b1) ...
  Setting up libev4 (1:4.22-1) ...
  Setting up libgssrpc4:amd64 (1.14.3+dfsg-1) ...
  Setting up comerr-dev (2.1-1.43.1-1) ...
  Setting up libgdbm-dev:amd64 (1.8.3-14) ...
  Setting up libsqlite3-dev:amd64 (3.14.1-1) ...
  Setting up ocaml-base-nox (4.02.3-7) ...
  Setting up libtinfo-dev:amd64 (6.0+20160625-1) ...
  Setting up dh-ocaml (1.0.10) ...
  Setting up libpcre-ocaml (7.2.3-1) ...
  Setting up libncurses5-dev:amd64 (6.0+20160625-1) ...
  Setting up libpq5:amd64 (9.5.4-1) ...
  Processing triggers for libc-bin (2.23-4) ...
  Setting up libcalendar-ocaml (2.04-1+b1) ...
  Setting up libreact-ocaml (1.2.0-2) ...
  Setting up libkdb5-8:amd64 (1.14.3+dfsg-1) ...
  Processing triggers for man-db (2.7.5-1) ...
  Setting up libpcrecpp0v5:amd64 (2:8.39-2) ...
  Setting up libpcre32-3:amd64 (2:8.39-2) ...
  Setting up libpcre16-3:amd64 (2:8.39-2) ...
  Setting up libcryptokit-ocaml (1.10-1+b1) ...
  Setting up libextlib-ocaml (1.7.0-2+b1) ...
  Setting up libzip-ocaml (1.05-3+b1) ...
  Setting up libreactivedata-ocaml (0.1-2) ...
  Setting up libderiving-ocsigen-ocaml (0.7.1-1) ...
  Setting up libfindlib-ocaml (1.6.2-1) ...
  Setting up ocaml-findlib (1.6.2-1) ...
  Setting up libsexplib-ocaml (113.33.03-3) ...
  Setting up libssl-ocaml (0.5.2-1) ...
  Setting up zlib1g-dev:amd64 (1:1.2.8.dfsg-2+b1) ...
  Setting up libev-dev (1:4.22-1) ...
  Setting up liblwt-ocaml (2.5.2-1) ...
  Setting up libkadm5srv-mit10:amd64 (1.14.3+dfsg-1) ...
  Setting up libkadm5clnt-mit10:amd64 (1.14.3+dfsg-1) ...
  Setting up libpcre3-dev:amd64 (2:8.39-2) ...
  Setting up libuutf-ocaml (0.9.4-2) ...
  Setting up libsqlite3-ocaml (4.0.5-1) ...
  Setting up libssl-dev:amd64 (1.0.2h-1) ...
  Setting up libipaddr-ocaml (2.7.0-2) ...
  Setting up libpostgresql-ocaml (2.0.5-2+b1) ...
  Setting up libocamlnet-ocaml (4.1.2-1) ...
  Setting up krb5-multidev (1.14.3+dfsg-1) ...
  Setting up libtyxml-ocaml (3.5.0-1) ...
  Setting up liblwt-ssl-ocaml (2.5.2-1) ...
  Setting up libpq-dev (9.5.4-1) ...
  Setting up libjs-of-ocaml (2.5-2+b3) ...
  Setting up libocsigenserver-ocaml (2.7-1+b1) ...
  Setting up ocaml-compiler-libs (4.02.3-7) ...
  Setting up ocaml-interp (4.02.3-7) ...
  Setting up ocaml-nox (4.02.3-7) ...
  Setting up libcalendar-ocaml-dev (2.04-1+b1) ...
  Setting up libsexplib-ocaml-dev (113.33.03-3) ...
  Setting up libreact-ocaml-dev (1.2.0-2) ...
  Setting up libzip-ocaml-dev (1.05-3+b1) ...
  Setting up libextlib-ocaml-dev (1.7.0-2+b1) ...
  Setting up libpostgresql-ocaml-dev (2.0.5-2+b1) ...
  Setting up libcamlp4-ocaml-dev (4.02.1+3-2) ...
  Setting up libssl-ocaml-dev (0.5.2-1) ...
  Setting up libsqlite3-ocaml-dev (4.0.5-1) ...
  Setting up libcryptokit-ocaml-dev (1.10-1+b1) ...
  Setting up libipaddr-ocaml-dev (2.7.0-2) ...
  Setting up libderiving-ocsigen-ocaml-dev (0.7.1-1) ...
  Setting up libfindlib-ocaml-dev (1.6.2-1) ...
  Setting up libuutf-ocaml-dev (0.9.4-2) ...
  Setting up libreactivedata-ocaml-dev (0.1-2) ...
  Setting up libpcre-ocaml-dev (7.2.3-1) ...
  Setting up liblwt-ocaml-dev (2.5.2-1) ...
  Setting up libtyxml-ocaml-dev (3.5.0-1) ...
  Setting up libocamlnet-ocaml-dev (4.1.2-1) ...
  Setting up liblwt-ssl-ocaml-dev (2.5.2-1) ...
  Setting up libjs-of-ocaml-dev (2.5-2+b3) ...
  Setting up libocsigenserver-ocaml-dev (2.7-1+b1) ...
  Setting up libeliom-ocaml-dev (4.2-3) ...
  Setting up nurpawiki-build-deps (1.2.3-9) ...
  Processing triggers for libc-bin (2.23-4) ...
  
  
**************************************************************************************
  ** Environment                                                                
      **
  
**************************************************************************************
  
  
PATH=/home/lamby/git/projects/dotfiles/dotfiles/..//bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
  HOSTNAME=6af0cf4af428
  TERM=xterm
  PAGER=more
  DISPLAY=:0
  DOCKER_IMAGE=lamby-debian-sid
  DEB_BUILD_OPTIONS=parallel=9
  PIP_DOWNLOAD_CACHE=/home/lamby/.cache/pip
  HOME=/home/lamby
  LOGNAME=lamby
  SHLVL=1
  
PWD=/home/lamby/temp/cdt.20160823175831.4Db7MGNPSU.db.nurpawiki/nurpawiki-1.2.3
  OLDPWD=/home/lamby/temp/cdt.20160823175831.4Db7MGNPSU.db.nurpawiki
  GPG_TTY=/dev/console
  QUILT_PATCHES=debian/patches
  QUILT_NO_DIFF_INDEX=1
  QUILT_REFRESH_ARGS=-p ab --no-timestamps --no-index
  DEBEMAIL=la...@debian.org
  DEBFULLNAME=Chris Lamb
  EDITOR=vim
  LESS=-cgiFx4M
  GPG_KEY=1E953E27D4311E58
  BLASTER=A220 I5 D1 H5 P330 T6
  _=/usr/bin/env
  
  
**************************************************************************************
  ** Building nurpawiki 1.2.3-9 on amd64                                        
      **
  
**************************************************************************************
  
   dpkg-buildpackage -rfakeroot -D -us -uc -b
  dpkg-buildpackage: info: source package nurpawiki
  dpkg-buildpackage: info: source version 1.2.3-9
  dpkg-buildpackage: info: source distribution unstable
  dpkg-buildpackage: info: source changed by Stphane Glondu <glo...@debian.org>
   dpkg-source --before-build nurpawiki-1.2.3
  dpkg-buildpackage: info: host architecture amd64
   fakeroot debian/rules clean
  dh clean --with ocaml
     dh_testdir
     dh_auto_clean
        make -j1 clean
  make[1]: Entering directory 
'/home/lamby/temp/cdt.20160823175831.4Db7MGNPSU.db.nurpawiki/nurpawiki-1.2.3'
  rm -Rf _build META version.ml
  make[1]: Leaving directory 
'/home/lamby/temp/cdt.20160823175831.4Db7MGNPSU.db.nurpawiki/nurpawiki-1.2.3'
     dh_ocamlclean
     dh_clean
   debian/rules build
  dh build --with ocaml
     dh_testdir
     dh_update_autotools_config
     dh_ocamlinit
     dh_auto_configure
     debian/rules override_dh_auto_build
  make[1]: Entering directory 
'/home/lamby/temp/cdt.20160823175831.4Db7MGNPSU.db.nurpawiki/nurpawiki-1.2.3'
  make
  make[2]: Entering directory 
'/home/lamby/temp/cdt.20160823175831.4Db7MGNPSU.db.nurpawiki/nurpawiki-1.2.3'
  echo 1.2.3
  1.2.3
  sed -e "s|%_NURPAWIKI_VERSION_%|1.2.3|g" version.ml.in > version.ml
  ocamlbuild -ocamlc 'ocamlfind ocamlc -thread -g -syntax camlp4o -package 
threads,netstring,calendar,extlib,postgresql,eliom.server,lwt.syntax' -ocamlopt 
'ocamlfind ocamlopt -thread  -syntax camlp4o -package 
threads,netstring,calendar,extlib,postgresql,eliom.server,lwt.syntax' -ocamldep 
'ocamlfind ocamldep -syntax camlp4o -package 
threads,netstring,calendar,extlib,postgresql,eliom.server,lwt.syntax' 
-classic-display -ocamlc 'ocamlfind ocamlc -thread -g -syntax camlp4o -package 
threads,netstring,calendar,extlib,postgresql,eliom.server,lwt.syntax' 
nurpawiki.cma
  ocamlfind ocamldep -syntax camlp4o -package 
threads,netstring,calendar,extlib,postgresql,eliom.server,lwt.syntax -modules 
version.ml > version.ml.depends
  + ocamlfind ocamldep -syntax camlp4o -package 
threads,netstring,calendar,extlib,postgresql,eliom.server,lwt.syntax -modules 
version.ml > version.ml.depends
  sh: 1: camlp4: not found
  File "version.ml", line 1:
  Error: Error while running external preprocessor
  Command line: camlp4 '-I' '/usr/lib/ocaml/camlp4' '-I' '/usr/lib/ocaml/lwt' 
'-I' '/usr/lib/ocaml/lwt' '-parser' 'o' '-parser' 'op' '-printer' 'p' 
'lwt-syntax-options.cma' 'lwt-syntax.cma'  'version.ml' > /tmp/ocamlpp46bddd
  
  Command exited with code 2.
  Makefile:24: recipe for target 'nurpawiki.cma' failed
  make[2]: *** [nurpawiki.cma] Error 10
  make[2]: Leaving directory 
'/home/lamby/temp/cdt.20160823175831.4Db7MGNPSU.db.nurpawiki/nurpawiki-1.2.3'
  debian/rules:13: recipe for target 'override_dh_auto_build' failed
  make[1]: *** [override_dh_auto_build] Error 2
  make[1]: Leaving directory 
'/home/lamby/temp/cdt.20160823175831.4Db7MGNPSU.db.nurpawiki/nurpawiki-1.2.3'
  debian/rules:9: recipe for target 'build' failed
  make: *** [build] Error 2

  [..]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: nurpawiki.1.2.3-9.unstable.amd64.log.txt.gz
Description: Binary data

_______________________________________________
Reproducible-builds mailing list
Reproducible-builds@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/reproducible-builds

Reply via email to