I'm currently in the process of upgrading Resin from a 2.x version to
3.1.0 and have been unable to eliminate the error below, which I get
when I attempt to set the user-name and group-name values in resin.conf.
I have tried this on Solaris 8 and a RedHat installation but get the
same error.

I have also included the output from the Linux install when NOT setting
the user-name. It shows that I am using Resin Pro with appropriate
license and the socket JNI library is being loaded.

Any help in troubleshooting this is much appreciated.

- tim

--- ERROR ---
Feb 8, 2007 6:19:14 PM com.caucho.boot.ResinWatchdog run
INFO: com.caucho.config.ConfigException: <user-name> requires Resin
Professional and compiled JNI.
com.caucho.config.ConfigException: <user-name> requires Resin
Professional and compiled JNI.
        at com.caucho.boot.ResinWatchdog.run(ResinWatchdog.java:497)
        at java.lang.Thread.run(Thread.java:595)

[EMAIL PROTECTED] resin-pro-3.1.0]$ bin/httpd.sh Resin Professional 3.1.0
(built Fri, 22 Dec 2006 07:11:14 PST)
Copyright(c) 1998-2006 Caucho Technology.  All rights reserved.

  1006350.license -- 2 Resin servers Pampered Chef

Starting Resin on Fri, 09 Feb 2007 08:20:43 -0600 (CST)

[08:20:45.575] Server[id=,cluster=app-tier] starting [08:20:45.576]
[08:20:45.576] Linux 2.6.9-34.ELsmp i386 [08:20:45.576] Java
1.5.0_11-b03, 32, mixed mode, UTF-8, en, Sun Microsystems Inc.
[08:20:45.577] user.name: web
[08:20:45.577] resin.home = /webapp/resin-pro-3.1.0/ [08:20:45.577]
root.directory = /webapp/resin-pro-3.1.0/ [08:20:45.578] resin.conf =
[08:20:45.592] Loaded Socket JNI library.
[08:20:45.594] hmux listening to localhost.localdomain:6800
[08:20:45.595] http listening to *:8080 [08:20:45.721] Host[] starting
[08:20:45.971] WebApp[http://localhost:8080] starting [08:20:46.440]
WebApp[http://localhost:8080/resin-doc] starting [08:20:46.698]
WebApp[http://localhost:8080/resin-admin] starting

resin-interest mailing list

Reply via email to