It is a bit unclear to me what you have tried and why.
You want to run Resin 3 but use the Apache/Jakarta JSTL implementation.
Right? (Why does Resin 3's implementation not suite your needs?)

Attachments do not reach the list, so please paste the error into the
mail, so we can see it.

I don't think you should need to remove any JARs from Resin, but you may
have to remove tld-files from within the Jakarta JARs. (We had to)

-------- Ursprungligt meddelande --------
Ämne: [Resin-interest] RESIN migration 3.022 from 2.1.17 issue - JSTL TAGS
Från: Karthik_rcs <[EMAIL PROTECTED]>
Datum: 2007-02-21 07:24
> Hello Team, We have been using Resin 2.1.17 version. Now we face some
> issues in jstl tags when we try migrating to 3 version. for Instance
> In a jsp, we are trying to display a nested bean information. A.B.iD (
> A is bean containing another Bean B, B has property iD) The above
> works perfectly in resin 2 version and we get the following error in 3
> alone. The log file is attached in the mail. We have done the
> following analysis. TroubleShooting Done We are using 1.0.2 jstl in
> our project. We removed jstl11.jar in the resin home/lib folder and
> making resin to pick jstl1.0.2 from our webapp lib folder,but the
> resin fails to start and gave this error. (The Config class Is there
> in jstl 1.0.2 too) class javax.servlet.jsp.jstl.core.Config is not
> loadable on startup. Resin requires javax.servlet.jsp.jstl.core.Config
> to be in the classpath on startup As alternate, we tried putting our
> jstl1.0.2 in RESIN.HOME\lib and removed jstl11.jar. Now we got the
> error while starting resin [2007/02/21 11:44:24.453]
> java.lang.NoClassDefFoundError: com/caucho/jstl/JstlPageContext Kindly
> let us know what needs to be done in order to resolve this issue.

resin-interest mailing list

Reply via email to