Steve --

We've had problems with Resin & the IBM JVM -- we're on Resin 3.0.19 and IBM J2RE 1.5.0 IBM J9 2.3 Linux amd64.

Ours have generally been problems with classloading like below. Often a redeploy of the web app fixes it, sometimes not.

We are actually about to move off of the IBM JVM to Sun's because of this (sounds like you don't have that option).


Caused by: java.lang.NullPointerException
       at com.caucho.vfs.Jar.openReadImpl(
       at com.caucho.vfs.JarPath.openReadImpl(
       at com.caucho.vfs.Path.openRead(
       at com.caucho.loader.ClassEntry.load(
at com.caucho.loader.DynamicClassLoader.loadClass(

Ferguson, Steve (DIS Contractor) wrote:

We have run into a little problem trying to deploy one of our web applications with Resin and IBM JDK 1.4.2. We have the need to use the IBM JDK due to one of our 3^rd party jar files so we need to make this work. When we start our application, JSPs compile successfully, but on startup, we receive several errors related to parsing XML. Here is an example. We did not receive these errors when we ran with Sun JDK 1.4.2, and did nothing special with regard to XML parsers, it just worked. 2007-03-01 08:31:51,162 () action.ActionServlet ERROR - (main) - Parsing error

processing resource path /WEB-INF/helpdesk-struts-config.xml,/WEB-INF/user-struts-config.xml,/WEB-INF/admin-struts-config.xml,/WEB-INF/ao-struts-config.xml,/WEB-INF/ata-struts-config.xml,/WEB-INF/ara-struts-config.xml,/WEB-INF/fsa-struts-config.xml,/WEB-INF/webtest-struts-config.xml


at org.apache.commons.digester.Digester.createSAXException(

at org.apache.commons.digester.Digester.createSAXException(

at org.apache.commons.digester.Digester.startElement(

        at com.caucho.xml.XmlParser.addElement(

        at com.caucho.xml.XmlParser.parseElement(

at com.caucho.xml.XmlParser.parseNode( Code))

        at com.caucho.xml.XmlParser.parseInt(

        at com.caucho.xml.AbstractParser.parse(

        at org.apache.commons.digester.Digester.parse(

at org.apache.struts.action.ActionServlet.parseModuleConfigFile(

at org.apache.struts.action.ActionServlet.initModuleConfig(

at org.apache.struts.action.ActionServlet.init(

        at javax.servlet.GenericServlet.init(

at com.caucho.server.dispatch.ServletConfigImpl.createServletImpl(

at com.caucho.server.dispatch.ServletConfigImpl.createServlet(

at com.caucho.server.dispatch.ServletManager.init(

at com.caucho.server.webapp.Application.start(

So to attempt to work around this problem, we tried to disable the cauco parser, in favor of using the xerces parser. We placed the following in our resin.conf

  <system-property javax.xml.parsers.DocumentBuilderFactory=


   <system-property javax.xml.parsers.SAXParserFactory=


   <system-property javax.xml.transform.TransformerFactory=


I then am unable to compile JSPs with some vague messages regarding the c standard tag libraries.

[09:50:51.324] Loading .tld files from global classpath

[09:51:15.848] /WEB-INF/pages/admin/ata/app/reg_form_preview.jsp:1: org.xml.sax.SAXParseException: The prefix "resin-c" for element "resin-c:out" is not bound.

Has anyone out there encountered problems like these with Resin and the IBM 1.4.2 JDK and solved this problem? Thanks in advance for any help.

Steve Ferguson


resin-interest mailing list
resin-interest mailing list

Reply via email to